Fordmods Logo

EB PROBLEM....HELP!!!!! 

 

Page 1 of 1 [ 12 posts ] 

 
 Post subject: EB PROBLEM....HELP!!!!!
Posted: Fri Dec 28, 2007 10:26 pm 
Fordmods Newbie
Offline
User avatar

Posts: 6

Joined: 9th Apr 2005

Ride: 92 EB FAIRMONT

Location: Melbourne
VIC, Australia

Hi guys,
just was driving down my street when all of a sudden the battery light came on and the engine cut... pulled over to the side of the road and nothing... it just stayed with the battery light on.... now when i go to start it ... it does not tick over just keeps trying to tick over.... also the battery light is still showing....
anyone know what it is???
it just cut while i was driving so i dunno what it could be... what could cause that...
any help would be great...

Also the car is a EB Fairmont

Cheers
Top
 Profile  
 
 
Posted: Fri Dec 28, 2007 10:27 pm 
Technical Contributor
Offline
User avatar

Age: 38

Posts: 4093

Joined: 20th Mar 2005

Gallery: 2 images

Ride: 2.0 Turbo VW

Power: 142 rwkw

Location: Seaford State:
VIC, Australia

1: Alternator is f**k.
2: Fusible link is blown.
3: Fan Belt snapped and you drained the Battery.

somewhere along those lines.

 

_________________

Carefree, we may not be number one, but we're up there.

Top
 Profile  
 
 
Posted: Fri Dec 28, 2007 10:31 pm 
Fordmods Newbie
Offline
User avatar

Posts: 6

Joined: 9th Apr 2005

Ride: 92 EB FAIRMONT

Location: Melbourne
VIC, Australia

Thanks for your very quick reply...
is there any was of checking them to pin point which one it is???
Top
 Profile  
 
 
Posted: Sat Dec 29, 2007 12:02 am 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 556

Joined: 10th Dec 2006

Gallery: 4 images

Ride: EAII Falcon S

Location: Brisbane
QLD, Australia

sounds like its not charging.. i had to replace mine cos i didnt know that if you spill fluid on the power steering drip tray it runs down the back of the alternator and stuffs it. :(

 

_________________

Speed Safely! ;-)

Top
 Profile  
 
 
Posted: Sat Dec 29, 2007 12:56 am 
Getting Side Ways
Offline

Age: 29

Posts: 1538

Joined: 4th May 2006

Gallery: 4 images

Ride: ef fairmont turbo

Power: 213 rwkw

Location: melbourne
VIC, Australia

if the Alternator is f**k: try starting the car up with a new battery, if it starts either your old batteri is out or if its still new you alternator is screwd
if the fan belt is snappd you should be able to see it up the front of the engine bay. check it out
my money is on it being a smart lock issue

 

_________________

96 EF FAIRMONT
Garrett gt40turbo, iceman plenum, ported head, turbo cam, double valvesprings, 023 fuel pump, 36lb injectors 4' cat, 4' dump, 2.5 exhaust, build bottom end, hypertonic pistons rods & rods, king bearings, j3. c10 3500 stall
232rwkw@4psi

Top
 Profile  
 
 
Posted: Sat Dec 29, 2007 1:02 am 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 556

Joined: 10th Dec 2006

Gallery: 4 images

Ride: EAII Falcon S

Location: Brisbane
QLD, Australia

4dlvr wrote:
my money is on it being a smart lock issue


the EB didnt have smartlock. :)

 

_________________

Speed Safely! ;-)

Top
 Profile  
 
 
Posted: Sat Dec 29, 2007 9:04 am 
Getting Side Ways
Offline
User avatar

Age: 41

Posts: 3785

Joined: 5th Nov 2004

Ride: Ford

Location: Victoria
VIC, Australia

Redford wrote:
4dlvr wrote:
my money is on it being a smart lock issue


the EB didnt have smartlock. :)


The EB II had Smartlock

 

_________________

Image

Top
 Profile  
 
 
Posted: Sat Dec 29, 2007 10:08 am 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 2396

Joined: 25th Sep 2005

Gallery: 9 images

Ride: Da Maverick & xe ute

Location: Upper FTG. melbourne
VIC, Australia

revcore wrote:
Redford wrote:
4dlvr wrote:
my money is on it being a smart lock issue


the EB didnt have smartlock. :)


The EB II had Smartlock


thats not true, early model ebII came out without smartlock, like mine, best 4.0 ford ever made.

 

_________________

Mods: sprint kit, steeda short shift, svo lip, El handles, El Air intake, au xr wheels, lukey cat back, jbl focal and pioneer sterio <--- Sold

Xe ute - Bright green with 302

Da maverick - Straight gas turbo

Top
 Profile  
 
 
Posted: Sat Dec 29, 2007 12:25 pm 
Tyre Shredder
Offline

Age: 32

Posts: 353

Joined: 27th Nov 2005

Gallery: 9 images

Ride: AUII XR6 VCT

Location: Canning Vale
WA, Australia

Definetely coil or dizzy/dizzy module, i had this prob with my EA, i discovered there was no spark from the coil, so i changed it, then the dizzy went, so i changed that and since then , i havent had a problem with it

 

_________________

www.aufalcon.com/dunkly

Top
 Profile  
 
 
Posted: Sat Dec 29, 2007 12:28 pm 
Tyre Shredder
Offline

Age: 32

Posts: 353

Joined: 27th Nov 2005

Gallery: 9 images

Ride: AUII XR6 VCT

Location: Canning Vale
WA, Australia

If its still cranking and just not starting it wouldnt be a battery/alternator problem.

 

_________________

www.aufalcon.com/dunkly

Top
 Profile  
 
 
Posted: Sat Dec 29, 2007 12:31 pm 
Getting Side Ways
Offline

Age: 36

Posts: 3794

Joined: 9th Aug 2005

Ride: Hilux

Location: Mornington
VIC, Australia

if its not cranking an there is no lights or anything working (apart from the warning lights) i would look for an electrical fault. My ED had a problem with the wiring harness from the ignition switch losing contact and therefore everything shutting off. kinda scary when ya car stops doing a hundred in the right hand lane

 

_________________

Now driving a Hilux

Top
 Profile  
 
 
Posted: Sat Dec 29, 2007 2:17 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 811

Joined: 30th Aug 2007

Gallery: 2 images

Ride: AU Fairmont

Location: Canberra
ACT, Australia

Was it driving fine before it turned off? My guess would be alternator, since mine just died and it was pretty similar, but the car became sluggish towards the end because I was running solely on non-recharging battery power. It would only just turn over when I tried to start it. You could try and find a voltage-metre and test the battery and alternator seperately?

 

_________________

Auto '99 AU Fairmont
--------------------------------------
Pacemaker 4499's, Hi-flow cat, 2.5" Redback catback
K & N Filter, NGK Plugs
Lows all 'round, Monroe's in the front, GSR's in the rear
Pioneer H/U
Tickford Bodykit
COMING SOON:
17's
30mm + 22mm adjustable sway bars.

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 12 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 13 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 3:18 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names