Fordmods Logo

EBII bogging down at idle and when driving 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: EBII bogging down at idle and when driving
Posted: Wed Feb 03, 2010 11:45 pm 
Stock as a Rock
Offline

Posts: 151

Joined: 1st Dec 2009

Ride: 93 eb2 falcon

Location: toowoomba
QLD, Australia

hey guys my EBII is bogging down as title states, runs for a minute fine but then shudders and bogs down as if its missin a spark! i havent touched the dizzy, checked the leads and all plugs and air hoses. its seemed to have started after i cleaned the ISC and removed the shift kit (the DIY one).
the fuel filter is only 2 months old so i know its not that. the water pump is leaking a bit next the the intake mani but i doubt it has anything to do with it!

just read in my manual that if the dizzy gets damp it could cause issues, could the water pump leaking onto the dizzy do it? if so would would be the best course of action?
Top
 Profile  
 
 
 Post subject: Re: EBII bogging down at idle and when driving
Posted: Thu Feb 04, 2010 3:10 pm 
Stock as a Rock
Offline

Age: 61

Posts: 156

Joined: 2nd Nov 2005

Ride: EA Fairmont

Location: Canberra
ACT, Australia

Hi There,

The water pump is on the divers side near the PS pump.
The leak you're describing is probably from the thermostat housing or thereabouts.

If you can see coolant on the dizzy cap / TFI module, then it 'may' cause a problem.
Try and fix the leak.

After removing the shift kit did you disconnect the battery for a while then
reconnect and make the computer relearn by going through the correct
procedure with the gears ??

Unfortunately there could be numerous other reasons for the car to have
the problem you describe.

Do a search for resetting computer, bad / poor idle, missing at idle etc as a starting point.
Good Luck
Top
 Profile  
 
 
 Post subject: Re: EBII bogging down at idle and when driving
Posted: Thu Feb 04, 2010 3:48 pm 
Stock as a Rock
Offline

Posts: 151

Joined: 1st Dec 2009

Ride: 93 eb2 falcon

Location: toowoomba
QLD, Australia

yes the thermostat! F$#K how did i get the wrong lol, i was checking the water pump at the time and must have been still thinking of it when i posted this!
Top
 Profile  
 
 
 Post subject: Re: EBII bogging down at idle and when driving
Posted: Thu Feb 04, 2010 11:19 pm 
Stock as a Rock
Offline

Posts: 151

Joined: 1st Dec 2009

Ride: 93 eb2 falcon

Location: toowoomba
QLD, Australia

well i got a new gasket, cleaned off the thermostat housing and block, whacked in the new one started tightening the bolts (one turn on one then the other) didnt even get close to tight at all when SNAP the f$#kN thermo housing snap off half way up the side! i have and interview for a mechanic apprenticeship 9.15 tomorrow morn on the other side of town! so f$#k this s$#t right now
Top
 Profile  
 
 
 Post subject: Re: EBII bogging down at idle and when driving
Posted: Sat Mar 06, 2010 11:52 am 
Stock as a Rock
Offline

Posts: 151

Joined: 1st Dec 2009

Ride: 93 eb2 falcon

Location: toowoomba
QLD, Australia

well the bogging idle and hesitaion got to the point where the car wouldnt get out he drive way, so i got her into the local ultratune and got the low down... a split hose from map sensor to intake, bushes in dizzy completely burnt out needs new one asap, to top it off i knew the timing was out but 12o out! so he moved it to plus 10 and s**t now it wheel stands from standing, i couldnt even do that in the rain! the best part was the price, was bloody good price. so yeah props to ultratune!
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 19 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 7:38 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names