Fordmods Logo

ED Problems - Changed coolant now problems 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: ED Problems - Changed coolant now problems
Posted: Tue Aug 11, 2009 10:46 pm 
Getting Side Ways
Offline
User avatar

Age: 41

Posts: 3785

Joined: 5th Nov 2004

Ride: Ford

Location: Victoria
VIC, Australia

I changed the coolant in the ED today along with a new thermostat and now it idles like a pig. I changed the temperature sensor on the thermostat housing but it didn't help.
I checked and double checked everything but I'm at a loss to explain it.
If anyone has any ideas on what may be causing it to idle the way it does then I'd be greatful for any advice.

 

_________________

Image

Top
 Profile  
 
 
 Post subject: Re: ED Problems - Changed coolant now problems
Posted: Wed Aug 12, 2009 1:42 pm 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 6467

Joined: 18th Dec 2006

Ride: 93 ED sedan

Power: 161 rwkw

Location: Rockhampton
QLD, Australia

Did you get the dizzy wet when changing/flushing the coolant?????...water in the dizzy.

 

_________________

http://youtu.be/jJTh9F3Vgg0

Top
 Profile  
 
 
 Post subject: Re: ED Problems - Changed coolant now problems
Posted: Wed Aug 12, 2009 2:10 pm 
Smokin em up
Offline
User avatar

Age: 48

Posts: 212

Joined: 9th Oct 2006

Gallery: 11 images

Ride: EA SPAC 1990

Location: melbourne
VIC, Australia

Try resetting the ECU, i had a similar problem a while ago and this fixed it

 

_________________

WHO EVER SAID "TWOS COMPANY THREES A CROWD" OBVIOUSLY NEVER HAD A THREESOME

Top
 Profile  
 
 
 Post subject: Re: ED Problems - Changed coolant now problems
Posted: Wed Aug 12, 2009 2:36 pm 
Getting Side Ways
Offline
User avatar

Age: 41

Posts: 3785

Joined: 5th Nov 2004

Ride: Ford

Location: Victoria
VIC, Australia

Was very careful and made sure no coolant got onto the dizzy. I might give resetting the ECU a go and see what happens. To reset the ECU you have to disconnect it for 15 minutes or something like that don't you? Then what has to be done once it's reconnected?

 

_________________

Image

Top
 Profile  
 
 
 Post subject: Re: ED Problems - Changed coolant now problems
Posted: Wed Aug 12, 2009 2:44 pm 
Getting Side Ways
Offline
User avatar

Age: 41

Posts: 3785

Joined: 5th Nov 2004

Ride: Ford

Location: Victoria
VIC, Australia

Just read the sticky's and now know how reset the ECU so scratch the last question :)

 

_________________

Image

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 32 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 5:44 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names