Fordmods Logo

Ed that doesn't start 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: Ed that doesn't start
Posted: Thu Apr 11, 2013 4:09 pm 
Fordmods Newbie
Offline

Age: 45

Posts: 4

Joined: 11th Apr 2013

Ride: Xf ed

Location: Tamworth
NSW, Australia

Hi all,I have a 93 futura that cranks but won't start.after degreasing & washing engine bay.there is fuel + spark but no fire.i have replaced coil,dizzy cap,rotor button & spark plugs,still no go! It has orange spark in each plug & plugs are wet with fuel on removal.any help greatly appreciated.
Top
 Profile  
 
 
 Post subject: Re: Ed that doesn't start
Posted: Thu Apr 11, 2013 6:11 pm 
Getting Side Ways
Offline

Posts: 1687

Joined: 5th Nov 2004

Gallery: 5 images

Ride: 1994 ED Ricer

Location: Perth
WA, Australia

Mate it seems like water has got down the dizzy further than the cap, If it was me I'd try a complete dizzy swap.
Top
 Profile  
 
 
 Post subject: Re: Ed that doesn't start
Posted: Thu Apr 11, 2013 6:41 pm 
Fordmods Newbie
Offline

Age: 45

Posts: 4

Joined: 11th Apr 2013

Ride: Xf ed

Location: Tamworth
NSW, Australia

I was dreading something like that,can dizzy be removed without removing manifold?
Top
 Profile  
 
 
 Post subject: Re: Ed that doesn't start
Posted: Fri Apr 12, 2013 8:42 am 
Parts Gopher
Offline

Age: 29

Posts: 92

Joined: 28th Mar 2012

Ride: 94 NC II FAIRLANE

Location: grafton
NSW, Australia

yes it can be just remove isc take rotor and plastic piece off dizzy and it will come out it is tight but it will happen.

 

_________________

If life was easy we would all be living

Top
 Profile  
 
 
 Post subject: Re: Ed that doesn't start
Posted: Fri Apr 12, 2013 11:14 am 
Fordmods Newbie
Offline

Age: 45

Posts: 4

Joined: 11th Apr 2013

Ride: Xf ed

Location: Tamworth
NSW, Australia

Thankyou for the reply,I will give it a go and see what prevails.
Top
 Profile  
 
 
 Post subject: Re: Ed that doesn't start
Posted: Fri Apr 12, 2013 7:52 pm 
Fordmods Newbie
Offline

Age: 45

Posts: 4

Joined: 11th Apr 2013

Ride: Xf ed

Location: Tamworth
NSW, Australia

Found the problem guys.had the dizzy cap around the wrong way hence firing order was out! Feel a bit dumb right now but was an easy fix :oops:
Top
 Profile  
 
 
 Post subject: Re: Ed that doesn't start
Posted: Sat Apr 13, 2013 9:52 pm 
Parts Gopher
Offline

Age: 29

Posts: 92

Joined: 28th Mar 2012

Ride: 94 NC II FAIRLANE

Location: grafton
NSW, Australia

I think we have all done it at least once at least you found the problem.

 

_________________

If life was easy we would all be living

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 14 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 11:51 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names