Fordmods Logo

ED with no compression after head change 

 

Page 1 of 1 [ 8 posts ] 

 
 Post subject: ED with no compression after head change
Posted: Thu Sep 28, 2006 11:08 pm 
Fordmods Newbie
Offline

Age: 29

Posts: 11

Joined: 17th Jul 2005

Gallery: 2 images

Ride: EAII

Location: Coffs Harbour
NSW, Australia

Last week I changed the head on my ED, I put a ported 94AA head on my car with a el xr6 cam and a set of AU rockers. It all fitted perfect until i went to kick it over this arvo and it started doin about 500rpm on the starter motor. pulled one of the sparkies out and put my thumb over the hole and it had bugger all compression.

Can someone help??

 

_________________

FORD 1993 ED 5-Speed, Wildcat Extractors, K&N Air Filter, 2 1/2 Redback, AU Multipoint injection, Lowered, Fresh 2-Tone Paint Job...

Soon to have a Garrett GT40 Turbo on it....

Top
 Profile  
 
 
Posted: Thu Sep 28, 2006 11:37 pm 
Technical Contributor
Offline
User avatar

Age: 38

Posts: 4093

Joined: 20th Mar 2005

Gallery: 2 images

Ride: 2.0 Turbo VW

Power: 142 rwkw

Location: Seaford State:
VIC, Australia

au rockers are 1.8:1 rocker ratio vs. e series 2.1:1

all your valves are open!

are you using the e series non hybrid cam?

if so... you need another set of rockers.

 

_________________

Carefree, we may not be number one, but we're up there.

Top
 Profile  
 
 
Posted: Thu Sep 28, 2006 11:48 pm 
Getting Side Ways
Offline
User avatar

Posts: 3115

Joined: 20th Dec 2004

Ride: Falcon

Location: Adelaide
SA, Australia

...and possibly a new set of valves as well.

 

_________________

Stoke me a clipper, I'll be back for Christmas

Top
 Profile  
 
 
Posted: Fri Sep 29, 2006 12:28 am 
Fordmods Junkie
Offline
User avatar

Posts: 3083

Joined: 22nd Sep 2005

Gallery: 13 images

Ride: EF

Location: Melbourne
VIC, Australia

e-series is only 1.9

 

_________________

Image
latest mod: A Service
MY BUILD THREAD

Top
 Profile  
 
 
Posted: Fri Sep 29, 2006 12:46 am 
Getting Side Ways
Offline
User avatar

Posts: 3115

Joined: 20th Dec 2004

Ride: Falcon

Location: Adelaide
SA, Australia

acutall, its 2.0

 

_________________

Stoke me a clipper, I'll be back for Christmas

Top
 Profile  
 
 
Posted: Fri Sep 29, 2006 12:52 am 
Fordmods Junkie
Offline
User avatar

Posts: 3083

Joined: 22nd Sep 2005

Gallery: 13 images

Ride: EF

Location: Melbourne
VIC, Australia

really?

 

_________________

Image
latest mod: A Service
MY BUILD THREAD

Top
 Profile  
 
 
Posted: Fri Sep 29, 2006 9:34 am 
Fordmods Newbie
Offline

Age: 29

Posts: 11

Joined: 17th Jul 2005

Gallery: 2 images

Ride: EAII

Location: Coffs Harbour
NSW, Australia

Oh...that sux...

Thanx for that....looks like ive gotta chuck the old ED rockers back on...cheers guys

 

_________________

FORD 1993 ED 5-Speed, Wildcat Extractors, K&N Air Filter, 2 1/2 Redback, AU Multipoint injection, Lowered, Fresh 2-Tone Paint Job...

Soon to have a Garrett GT40 Turbo on it....

Top
 Profile  
 
 
Posted: Fri Sep 29, 2006 9:55 pm 
Fordmods Newbie
Offline

Age: 29

Posts: 11

Joined: 17th Jul 2005

Gallery: 2 images

Ride: EAII

Location: Coffs Harbour
NSW, Australia

Yep...put the ed rockers on and she kicked straight over...but the turbo seems to be not spooling properly...ill start stuffing around with the timing and stuff 2morrow....cheers guys for your help

 

_________________

FORD 1993 ED 5-Speed, Wildcat Extractors, K&N Air Filter, 2 1/2 Redback, AU Multipoint injection, Lowered, Fresh 2-Tone Paint Job...

Soon to have a Garrett GT40 Turbo on it....

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 8 posts ] 

Who is online

Users browsing this forum: No registered users and 37 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 10:51 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names