Fordmods Logo

Fordmods Advertising

ED wont Idle 


Page 1 of 1 [ 3 posts ] 

 Post subject: ED wont Idle
Posted: Fri Dec 18, 2009 1:06 am 
Getting Side Ways
User avatar

Age: 44

Posts: 3763

Joined: 25th Nov 2004

Gallery: 6 images

Ride: EFII 5.8 NOS TerroristGhia

Power: 274 rwkw

Location: Sydney Australia
NSW, Australia

OK, i have done nothing to the car other than refill the oil.
The problem i have is that lately ( in the last 2 weeks) she has been refusing to idle. It revs smoothly and drives nicely. I thought maybe the ISC was out, so i changed that with the one from the ute, No difference at all.
I would be happy to raise the base idle, but am stuffed if i know where the idle screw is on the 6.

Car has done 193k and had a head done at 179. Last service about 187, next service due at 200k.

Last service it recieved a fuel filter as she was chugging at speed due to using E10* bloody crap) No she lives on a diet of 98 same as the blue car. Also last service it got new plugs/leads/dizzy cap/rotor and air and oil filter as well as a oil clean and replace( using that engine cleaner stuff, put in engine, run for 30mins, change oil)

Any help greatly appreciated as it is starting to piss me off driving with left foot brakeing to keep the engine running when coming to a stop.

Only other thing i can think of is maybe the fuel pump is cactus.




The Terrorist ED Retired due to RUST.
The TerrosistGhia, EF Ghia 351 EFI 5 Speed.
Millennium Falcon, Sleeper EL DOHC 6 Speed Manual EFI LPG
I didn't Vote for Multiculturalism, DID YOU!!!

 Post subject: Re: ED wont Idle
Posted: Fri Dec 18, 2009 8:40 am 
Getting Side Ways

Posts: 3364

Joined: 11th Jan 2009

Have you tried the TPS Brett? Are there any vacuum hoses broken or loose or, the Vacuum fitting at the back of the inlet manifold broken? item 30 in the pic.

 Post subject: Re: ED wont Idle
Posted: Fri Dec 18, 2009 9:25 pm 
Getting Side Ways
User avatar

Age: 48

Posts: 6467

Joined: 18th Dec 2006

Ride: 93 ED sedan

Power: 161 rwkw

Location: Rockhampton
QLD, Australia

There are 2 different throttle bodies for an ED.
To set base idle speed, make sure the thottle body is clean.
Have the engine at operating temp, screw in the throttle body butterfly stop ( about 4 turns ).
Then disconnect the electrical connector for the ISCV.
Start the engine.
Let the revs settle, then undo the screw till you get it to idle at about 500 rpm.
Turn off engine, reconnect ISCV, and start engine again....see where it is then at idle speed.



Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 17 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Tue Oct 25, 2016 1:18 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names