Fordmods Logo

EF Cruise control, common problems! 

 

Page 1 of 2 [ 21 posts ] Go to page 1, 2  Next

 
 Post subject: EF Cruise control, common problems!
Posted: Sun Feb 18, 2007 9:14 pm 
Tyre Shredder
Offline
User avatar

Age: 41

Posts: 363

Joined: 23rd Sep 2005

Gallery: 1 images

Ride: XR6 Wagon

Location: Perth
WA, Australia

Ok my sister has an EF GLi with cruise. The cruise has not worked since she got it, so I was going to try and fix it for her. Can anyone help with info on common problems with cruise to start with. Could it be a fuse or relay? Any help would be greatly appreciated.

 

_________________

ImageImage
EF XR6 Wagon,RPD R6 cam,Wildcat extractors, Magnaflow cat,2.5" Lukey exhhaust.
Too many more too list

Top
 Profile  
 
 
Posted: Sun Feb 18, 2007 9:35 pm 
Getting Side Ways
Offline
User avatar

Age: 46

Posts: 8590

Joined: 5th Nov 2004

Gallery: 5 images

Ride: AU Fairlane 5.0, KE Laser, 01 Kw

Location: Melbourne
VIC, Australia

Check your brake lights first off, common problem is the brake light switch.
Is it manual? If so check the clutch switch.

Is the cruise light showing on the cluster when you hit the on button?
Top
 Profile  
 
 
Posted: Sun Feb 18, 2007 11:27 pm 
Stock as a Rock
Offline

Age: 29

Posts: 121

Joined: 12th May 2006

Ride: BA XR6T

Location: perth
WA, Australia

might seem stupid but check the cable is actually attached

mine broke off - cruise no longer works dispite the light been on and everything

winding it around doesnt work either because it cant keep the speed :(

 

_________________

Old car burnt.
New car XR6 Turbo !!
No mods, anyone want a xr6t ?

Top
 Profile  
 
 
Posted: Mon Feb 19, 2007 11:10 am 
Smokin em up
Offline

Posts: 205

Joined: 8th Nov 2004

Location: geelong
VIC, Australia

Other thing to check is the actual cruise buttons on the steering wheel are working. My cruise problem was a simple case that the buttons were worn out 280,000 kms of use will do that.
Top
 Profile  
 
 
Posted: Mon Feb 19, 2007 12:57 pm 
Technical Contributor
Offline
User avatar

Age: 53

Posts: 5589

Joined: 14th Jan 2005

Gallery: 10 images

Ride: 96 XH/97 EL

Location: South Coast
NSW, Australia

If the brake master cylinder cruise pressure switch plug is not connected properly, this can cause the system not to engage also (i.e. caption comes on, but doesn't hold speed). You can continuity check the system from the cruise actuator plug in the engine bay (this includes steering wheel switches, etc).

 

_________________

96 XH Longreach 'S': LPG, Alarm, 3.23:1 LSD, Cruise, Trip Comp, ABS, Power Windows, Mid Series Dome Lt, Climate Ctrl
97 EL Futura S/W: LPG, Alarm, LED int Lts, Trip Comp, F/Lane Dome Lt, Climate Ctrl, T5 Conversion

Top
 Profile  
 
 
Posted: Mon Feb 19, 2007 1:19 pm 
Getting Side Ways
Offline
User avatar

Age: 79

Posts: 1233

Joined: 7th Apr 2005

Gallery: 7 images

Ride: GTHO PH 1 EF ex chaser

Location: Willow vale, GOLD COAST
QLD, Australia

Good reply SNAP but some members might have difficulty with understanding continuity and how to check it :shock: :roll: :twisted: :D

 

_________________

Rotten Old Revhead!!! XW GTHO + EF ex cop car (exractors 2.5 cat back zorst !6" Simmons K&N +airbox mods Lowered with Bilstein shocks+Whiteline Bars NEXT THING Swap HO for GTP or Ferrari!

Top
 Profile  
 
 
Posted: Mon Feb 19, 2007 2:16 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 2983

Joined: 15th Apr 2006

Gallery: 5 images

Ride: Falcon

Location: Aberfoyle Park
SA, Australia

Is there a diagnostic mode for cruise like there is for ABS?

But i think everone one here has hit every topic when it comes to what ca go wrong.

1. the pedal switched
2. The buttons
3. The actuator and cable

 

_________________

HOLDENS go like rockets. They fall apart in stages!!!

Top
 Profile  
 
 
Posted: Mon Feb 19, 2007 5:47 pm 
Technical Contributor
Offline
User avatar

Age: 53

Posts: 5589

Joined: 14th Jan 2005

Gallery: 10 images

Ride: 96 XH/97 EL

Location: South Coast
NSW, Australia

GTBob wrote:
Good reply SNAP but some members might have difficulty with understanding continuity and how to check it :shock: :roll: :twisted: :D
Already understand that, but people can:
a. Ask what it means, or
b. Google the term and see what comes up.

 

_________________

96 XH Longreach 'S': LPG, Alarm, 3.23:1 LSD, Cruise, Trip Comp, ABS, Power Windows, Mid Series Dome Lt, Climate Ctrl
97 EL Futura S/W: LPG, Alarm, LED int Lts, Trip Comp, F/Lane Dome Lt, Climate Ctrl, T5 Conversion

Top
 Profile  
 
 
Posted: Mon Feb 19, 2007 7:06 pm 
Getting Side Ways
Offline
User avatar

Age: 79

Posts: 1233

Joined: 7th Apr 2005

Gallery: 7 images

Ride: GTHO PH 1 EF ex chaser

Location: Willow vale, GOLD COAST
QLD, Australia

Yeah I know, pardon the geriatric view but I have just spent 2 days trying to teach some people the basics of setting up an internet A/C and still get some blank stares :twisted: :D :D :D

 

_________________

Rotten Old Revhead!!! XW GTHO + EF ex cop car (exractors 2.5 cat back zorst !6" Simmons K&N +airbox mods Lowered with Bilstein shocks+Whiteline Bars NEXT THING Swap HO for GTP or Ferrari!

Top
 Profile  
 
 
Posted: Mon Feb 19, 2007 8:18 pm 
Technical Contributor
Offline
User avatar

Age: 53

Posts: 5589

Joined: 14th Jan 2005

Gallery: 10 images

Ride: 96 XH/97 EL

Location: South Coast
NSW, Australia

Yeah, I'm hearin' ya Bob. I suppose if they don't get it, then option b. is out . . . . :P

 

_________________

96 XH Longreach 'S': LPG, Alarm, 3.23:1 LSD, Cruise, Trip Comp, ABS, Power Windows, Mid Series Dome Lt, Climate Ctrl
97 EL Futura S/W: LPG, Alarm, LED int Lts, Trip Comp, F/Lane Dome Lt, Climate Ctrl, T5 Conversion

Top
 Profile  
 
 
Posted: Mon Feb 19, 2007 11:42 pm 
Tyre Shredder
Offline
User avatar

Age: 41

Posts: 363

Joined: 23rd Sep 2005

Gallery: 1 images

Ride: XR6 Wagon

Location: Perth
WA, Australia

Thanks all will try all options and yes I know how to check for continuity LOL. Understandable tho, some people are smart but have no common sense if you get my meaning :roll:

 

_________________

ImageImage
EF XR6 Wagon,RPD R6 cam,Wildcat extractors, Magnaflow cat,2.5" Lukey exhhaust.
Too many more too list

Top
 Profile  
 
 
Posted: Tue Feb 20, 2007 12:22 am 
Stock as a Rock
Offline

Age: 48

Posts: 105

Joined: 3rd Nov 2005

Gallery: 19 images

Ride: EB Fairmont Ghia

Location: Northern Burbs Adelaide
SA, Australia

You can also check the vaccuum line that goes to the cruise control module in the engine bay if it's a vaccuum cruise.
My EB cruise is vaccuum but not sure if later models like yours are?

 

_________________

EB Fairmont Ghia 6 -160rwkw (E85 tune)
ZL Fairlane 6 - Grandpa Spec
XW Falcon 221 2V

Top
 Profile  
 
 
Posted: Tue Feb 20, 2007 1:37 am 
Getting Side Ways
Offline
User avatar

Age: 46

Posts: 8590

Joined: 5th Nov 2004

Gallery: 5 images

Ride: AU Fairlane 5.0, KE Laser, 01 Kw

Location: Melbourne
VIC, Australia

EF aren't vacuum.
Top
 Profile  
 
 
 Post subject: EF Cruise problems
Posted: Wed Feb 21, 2007 11:56 am 
Fordmods Newbie
Offline

Age: 67

Posts: 16

Joined: 21st Dec 2006

Location: Melbourne
VIC, Australia

OK Guys my EF Fairmont won't cruise and the light does come on on the dash. I think I hear a little clunk from the actuator but I could be imagining it.

Thanks for the long discourse on continuity checks. While it led nowhere it was a useful tip. If you know the pin designations on the actuator plug, you can put a multimeter between each one and chassis, and then press buttons, hit the brake pedal and see if it all does what it should.

BUT if you don't know which pin does what, you will just be guessing.

SO, the real question is: does anyone have the pin diagram for the EF cruise actuator plug?

Phew!!!

Admiral Duck

 

_________________

Intestinal (Admiral Duck) EF Fairmont tows the boat like no other

Top
 Profile  
 
 
Posted: Wed Feb 21, 2007 5:14 pm 
Parts Gopher
Offline
User avatar

Age: 30

Posts: 87

Joined: 5th Oct 2005

Ride: EF Fairmont

Location: Melbourne
VIC, Australia

when mine stuffed up the same thing happened, lights came on dash, but whenever you tried to set it, it would just make a clunk sound then nothing...got a 2nd hand unit and replaced, works perfectly now
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 21 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 4:13 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names