Fordmods Logo

EF doesn't turn over, fuel pump not priming 

 

Page 1 of 1 [ 2 posts ] 

 
 Post subject: EF doesn't turn over, fuel pump not priming
Posted: Fri Dec 11, 2009 12:32 pm 
Getting Side Ways
Offline

Posts: 836

Joined: 1st Apr 2005

Gallery: 4 images

Ride: EF XR6 Wagon, AU2 XR6 VCT

Power: 148 rwkw

Location: Auckland
New Zealand

I had the engine out of my EF XR6 to replace a leaky timing cover gasket. I put it back in and hooked everything up (I think). The rad hoses and fans haven't gone back in yet. The battery is fully charged. I tried to start it - the dash lights go as normal, but the fuel pump doesn't prime and the engine makes no attempt to turn over. The starter cable is securely tightened. Have I overlooked something? Or have I fried some electronics somewhere in the process? Thanks all.

 

_________________

95 EF XR6 wagon, 17" FTRs, DBA, QFM, KYB/Koni, AU block, ported EF head, SS Inductions, Territory intake, MLS gasket, milled, Franklin RH24B cam, Coby headers, no cat, Tickford 2.5", 2800rpm stall, J3 chip

Top
 Profile  
 
 
 Post subject: Re: EF doesn't turn over, fuel pump not priming
Posted: Fri Dec 11, 2009 10:01 pm 
Getting Side Ways
Offline

Posts: 836

Joined: 1st Apr 2005

Gallery: 4 images

Ride: EF XR6 Wagon, AU2 XR6 VCT

Power: 148 rwkw

Location: Auckland
New Zealand

Found it! The earth cable to the engine and the second wire to the starter motor were both not connected. Doh! Must have been half asleep putting the car back together. False alarm. Thanks.

 

_________________

95 EF XR6 wagon, 17" FTRs, DBA, QFM, KYB/Koni, AU block, ported EF head, SS Inductions, Territory intake, MLS gasket, milled, Franklin RH24B cam, Coby headers, no cat, Tickford 2.5", 2800rpm stall, J3 chip

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 30 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 4:08 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names