Fordmods Logo

ef ecu injector pin outs 

 

Page 1 of 4 [ 54 posts ] Go to page 1, 2, 3, 4  Next

 
 Post subject: ef ecu injector pin outs
Posted: Wed Jun 21, 2006 2:00 pm 
Parts Gopher
Offline

Posts: 67

Joined: 5th Mar 2006

Ride: zzzzz

Location: ???
VIC, Australia

hey,
can anyone tell me which pinouts on the ef ecu are for the injectors???
cause car won't start but cranks fine, so i want to check if the injectors are working.
Top
 Profile  
 
 
Posted: Wed Jun 21, 2006 2:48 pm 
Getting Side Ways
Offline
User avatar

Posts: 3115

Joined: 20th Dec 2004

Ride: Falcon

Location: Adelaide
SA, Australia

Ive got the pinout somewhere at home and will post tonight if I find it, but in the meantime its probably easier just to probe the injector plug instead of the ecu.

 

_________________

Stoke me a clipper, I'll be back for Christmas

Top
 Profile  
 
 
 Post subject: ef ecu injector pinouts
Posted: Thu Jun 22, 2006 12:51 pm 
Parts Gopher
Offline

Posts: 67

Joined: 5th Mar 2006

Ride: zzzzz

Location: ???
VIC, Australia

I probed the injectors, one of the pins has 12volts when the ignition is on and the other one has 0. The first pin drops to 9volts when the engine is cranking and the other pin has 0.19volts. What does tha mean???
Thanks,
Davo
Top
 Profile  
 
 
Posted: Thu Jun 22, 2006 4:57 pm 
Getting Side Ways
Offline
User avatar

Posts: 3115

Joined: 20th Dec 2004

Ride: Falcon

Location: Adelaide
SA, Australia

The pin thats 12V is connected to a common power feed that powers lots of things in the engine bay. The other pin goes to the ECU and is earthed to fire the injectors.

What makes you think its the injectors that are causing your problem?

 

_________________

Stoke me a clipper, I'll be back for Christmas

Top
 Profile  
 
 
Posted: Thu Jun 22, 2006 5:43 pm 
Getting Side Ways
Offline
User avatar

Posts: 1549

Joined: 27th Apr 2005

Gallery: 1 images

Ride: AU Fairmont Ghia

Location: Perth
WA, Australia

the pinout diagram is available in the tech docs section
Top
 Profile  
 
 
Posted: Thu Jun 22, 2006 6:44 pm 
Parts Gopher
Offline

Posts: 67

Joined: 5th Mar 2006

Ride: zzzzz

Location: ???
VIC, Australia

That pin out diagram is for the EL ECU plug, which is totally different to the EF.
Thanks anyway.
Davo.
Top
 Profile  
 
 
Posted: Thu Jun 22, 2006 11:06 pm 
Technical Contributor
Offline
User avatar

Posts: 2799

Joined: 6th Nov 2004

Gallery: 7 images

Ride: Falcon

Location: Sydney
NSW, Australia

I got this from elswhere on this site.. can't remember where, but it should help with what you are trying to check.

I also wanna know why you think its the injectors?

Basically one pin will be Battery voltage, and to other pin will have a pulsing ground. On a multimeter it will show up like a voltage. With the car on reds, but off, (Ignition on, not started), check for battery voltage on one, and check for ground on the other pin.. the only thing inside the ECU that could break relating to the injectors would probably be the MOSFET driver, in which case your injectors would be constantly grounded, always flowing fuel, flooding the engine big time.

This doesn't happen often though, so Id be check spark first.


Cheers

 

 

Attachments:
File comment: EF pinout, credit to whoever came up with it
ef_eecv_905.xls [25 KiB]
Downloaded 88 times

 

_________________

;++JustForDimSim++;

Cheap, fast and reliable.. choose 2.

Top
 Profile  
 
 
 Post subject: ef multi ribbed belt installation
Posted: Thu Jun 22, 2006 11:32 pm 
Parts Gopher
Offline

Posts: 67

Joined: 5th Mar 2006

Ride: zzzzz

Location: ???
VIC, Australia

the opposite is happening the injectors arent operating and no fuel is getting into the engine
Top
 Profile  
 
 
Posted: Thu Jun 22, 2006 11:34 pm 
Technical Contributor
Offline
User avatar

Posts: 2799

Joined: 6th Nov 2004

Gallery: 7 images

Ride: Falcon

Location: Sydney
NSW, Australia

have you checked for spark?

If so, check that the ECU has voltage.


Cheers

 

_________________

;++JustForDimSim++;

Cheap, fast and reliable.. choose 2.

Top
 Profile  
 
 
 Post subject: ef ecu injector pinouts
Posted: Thu Jun 22, 2006 11:45 pm 
Parts Gopher
Offline

Posts: 67

Joined: 5th Mar 2006

Ride: zzzzz

Location: ???
VIC, Australia

yep there is spark i checked the ecu has power, everything else is working fine, the car cranks fine but wont start.
also i checked the fuel pump and i pulled the fuel rail off to check the injectors and they were clean and there was plenty of fuel in the rail
Top
 Profile  
 
 
 Post subject: Re: ef ecu injector pinouts
Posted: Thu Jun 22, 2006 11:49 pm 
Getting Side Ways
Offline
User avatar

Posts: 3115

Joined: 20th Dec 2004

Ride: Falcon

Location: Adelaide
SA, Australia

davoeabodykit wrote:
yep there is spark i checked the ecu has power, everything else is working fine, the car cranks fine but wont start.
also i checked the fuel pump and i pulled the fuel rail off to check the injectors and they were clean and there was plenty of fuel in the rail


Fuel in the rail doesnt mean much, the injectors need pressure to work. Is the fuel pump priming before you start the engine.

I take it the spark plugs are dry after cranking?

Its just that its unusual for injectors not to work. There really isnt much that can go wrong.

 

_________________

Stoke me a clipper, I'll be back for Christmas

Top
 Profile  
 
 
 Post subject: ef ecu injector pinouts
Posted: Fri Jun 23, 2006 12:11 am 
Parts Gopher
Offline

Posts: 67

Joined: 5th Mar 2006

Ride: zzzzz

Location: ???
VIC, Australia

yep the pump is priming and the spark plugs are dry after i try to start the car.
the engine is a tickford engine out of an ef fairmont ghia and its in my ea s pack, could it be that the ea fuel pump isnt creating enough pressure for the ef engine???
Top
 Profile  
 
 
Posted: Fri Jun 23, 2006 12:25 am 
Technical Contributor
Offline
User avatar

Posts: 2799

Joined: 6th Nov 2004

Gallery: 7 images

Ride: Falcon

Location: Sydney
NSW, Australia

was it CPI before you put the EF engine in?


Cheers

 

_________________

;++JustForDimSim++;

Cheap, fast and reliable.. choose 2.

Top
 Profile  
 
 
 Post subject: ef ecu injector pinouts
Posted: Fri Jun 23, 2006 12:29 am 
Parts Gopher
Offline

Posts: 67

Joined: 5th Mar 2006

Ride: zzzzz

Location: ???
VIC, Australia

no it had the 3.9 mpfi engine
Top
 Profile  
 
 
Posted: Fri Jun 23, 2006 12:30 am 
Site Admin
Offline
User avatar

Age: 34

Posts: 8831

Joined: 18th Dec 2002

Gallery: 6 images

Ride: AUII V8 LTD

Power: 270 rwkw

Location: Sydney
NSW, Australia

Check for smartlock fault, also check ALL your fuses, including interior light as this will affect smartlock which in turn prevent your injectors from working :)

 

_________________

WAG363: AUII LTD Supercharged 363 Dart Stroker [Supercharged 363 LTD Build]
WAGGIN: 2012 Volkswagen Passat Wagon - V6 4Motion.

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 4  [ 54 posts ]  Go to page 1, 2, 3, 4  Next

Who is online

Users browsing this forum: No registered users and 21 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 11:27 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names