Fordmods Logo

EF GLI airbag problem 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: EF GLI airbag problem
Posted: Wed Feb 18, 2009 10:24 am 
Fordmods Newbie
Offline

Age: 30

Posts: 8

Joined: 18th Feb 2009

Ride: EF GLI

Location: Geelong
VIC, Australia

Hey guys, I just got a EF GLI with 112,000 on the clock and went for a roadworthy.

Background Info:
I was informed that the airbag light is producing an error. Took it to the first auto electrician, it produced a Code 33. I then took it to a family members auto elec workshop and they said it was the Airbag Control Unit. So off I went to wreckers and got one for $45.

So 6 hours and 5 people later I managed to get the bastard airbag control unit out and replace it. But it's still producing the Code 33 error. I tried the ask johnny page but it doesn't work just errors.

So my questions are:

When i reset the airbag with the 4th pin and ground how long should i hold it until the beeps are heard?

Where is the airbag "resistor" exactly, I can't locate it. Also, if there's a short circuit in the loom are there any locations i should check first?


Thanks for any replies as I'm a car noob and also new to fords in general.
MegaManga
Top
 Profile  
 
 
 Post subject: Re: EF GLI airbag problem
Posted: Wed Feb 18, 2009 11:28 am 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 6467

Joined: 18th Dec 2006

Ride: 93 ED sedan

Power: 161 rwkw

Location: Rockhampton
QLD, Australia

One of the usual problems with the Airbag is the "clockspring", which is found under the steering wheel. I'm not saying that is the problem, but don't dis-count it.

 

_________________

http://youtu.be/jJTh9F3Vgg0

Top
 Profile  
 
 
 Post subject: Re: EF GLI airbag problem
Posted: Wed Feb 18, 2009 11:30 am 
Fordmods Newbie
Offline

Age: 30

Posts: 8

Joined: 18th Feb 2009

Ride: EF GLI

Location: Geelong
VIC, Australia

Thanks mate, I'll reset the airbag computer tonight hopefully and see if it fixes the problem. If it doesn't I will check the clockspring. I'll keep progress posted :)
Top
 Profile  
 
 
 Post subject: Re: EF GLI airbag problem
Posted: Wed Feb 18, 2009 1:32 pm 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 6467

Joined: 18th Dec 2006

Ride: 93 ED sedan

Power: 161 rwkw

Location: Rockhampton
QLD, Australia

This is the special tool for hold the Clockspring together, and to keep it in place.

 

 

Attachments:
IMGP1063_resize.JPG
IMGP1063_resize.JPG [ 89.95 KiB | Viewed 31 times ]
IMGP1062_resize.JPG
IMGP1062_resize.JPG [ 89.38 KiB | Viewed 29 times ]

 

_________________

http://youtu.be/jJTh9F3Vgg0

Top
 Profile  
 
 
 Post subject: Re: EF GLI airbag problem
Posted: Wed Feb 18, 2009 4:53 pm 
Fordmods Newbie
Offline

Age: 30

Posts: 8

Joined: 18th Feb 2009

Ride: EF GLI

Location: Geelong
VIC, Australia

Car wouldn't start so I called out roadside assist. Apparently the Body Control Module is buggered and needs to be reset or replaced. I'm taking the car to my cousins auto electric shop tomorrow morning so hopefully everything will be sorted out. The immobiliser didn't even want me to start the damn thing. I'll be happy when all this is fixed.
Top
 Profile  
 
 
 Post subject: Re: EF GLI airbag problem
Posted: Thu Feb 19, 2009 1:54 pm 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 6467

Joined: 18th Dec 2006

Ride: 93 ED sedan

Power: 161 rwkw

Location: Rockhampton
QLD, Australia

Some times with those BEM's, you need to replace the ignition immobiliser unit at the steering column too. Its attached to the barrel assembly.

 

_________________

http://youtu.be/jJTh9F3Vgg0

Top
 Profile  
 
 
 Post subject: Re: EF GLI airbag problem
Posted: Thu Feb 19, 2009 8:30 pm 
Fordmods Newbie
Offline

Age: 30

Posts: 8

Joined: 18th Feb 2009

Ride: EF GLI

Location: Geelong
VIC, Australia

The problem was the airbag resistor, whichever moron repaired it previously put a 200ohm resistor in instead of a 2 ohm resistor. Electrician found it and rang me, so no more airbag light but im minus 150 bucks heh. Thanks for your help guys. I put in a head unit tonight aswell to celebrate.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: Google Adsense [Bot] and 19 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 19, 2017 12:22 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names