Fordmods Logo

Fordmods Advertising

EF Running Slightly Rough On Idle 


Page 1 of 1 [ 4 posts ] 

 Post subject: EF Running Slightly Rough On Idle
Posted: Sat Apr 01, 2006 9:37 pm 
Fordmods Newbie

Age: 60

Posts: 2

Joined: 1st Apr 2006

Location: Brisbane
QLD, Australia

Hi Guys

New to the Forum and hope to meet new freinds and share some experiences.

About to purchase an EF Fairmont 1995, 1 Owner from new, 154,000ks with full log book history and owner has it maintained regardless, however on idle it seems to run a little rough as if its missing slightly but when you rev up its as smooth as silk, owner has stated that it could be the computer but he really did not know but carried on to say that it has been like this for the last 3yrs and is so insignificant that it did not bother him.

Any guys got any idea what it could be taking into consideration it being a one owner with fairly low ks and well looked after.

Thanks in advance.

Tony (Auspom)
Posted: Sat Apr 01, 2006 9:45 pm 
Technical Contributor
User avatar

Age: 37

Posts: 4093

Joined: 20th Mar 2005

Gallery: 2 images

Ride: 2.0 Turbo VW

Power: 142 rwkw

Location: Seaford State:
VIC, Australia

I know, I know.... its a ford!
i think you'll find nearly everyone with a i6 has an erratic idle... I tend to think Manuals have it worse as theres less Dampening on the flywheel

Some say theirs is better with:

ISC clean
Injector Clean
New Fuel Filter
98Ron Fuel
High Volume Regulator/Pump
New quality Leads
New Plugs
Reset ECU
New Cat
New/Clean 02 sensor
Performance AIr Filter
Larger Cold Air Intake
New Coil Pack 'high pressure cleaning'

I however...
either still does it!

PS: Welcome!



Carefree, we may not be number one, but we're up there.

Last edited by Krytox on Sat Apr 01, 2006 10:40 pm, edited 1 time in total.

Posted: Sat Apr 01, 2006 10:23 pm 
Getting Side Ways

Posts: 4967

Joined: 22nd Nov 2004

QLD, Australia

My EF FAirmont does the same has for 100,000kms you name it ive either fixed it, cleaned it or checked it, since it hardly gets driven anymore it doesnt bother me now




Posted: Sat Apr 01, 2006 11:31 pm 
Getting Side Ways

Age: 32

Posts: 1494

Joined: 1st Dec 2004

Gallery: 2 images

Ride: BA MkII XT Wagon

Location: Maitland
NSW, Australia

id be checkin the inlet manifold gasket, happened to mine, got a vacuum leak, just spray carby cleaner or soemthin of the like around it and if theres a hole in the gasket the revs will rise then fall




Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 27 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Fri Oct 28, 2016 5:40 pm All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names