Fordmods Logo

EF Something Wrong. High Oil Pressure, and keeps missising. 

 

Page 1 of 1 [ 9 posts ] 

 
 Post subject: EF Something Wrong. High Oil Pressure, and keeps missising.
Posted: Fri Jun 05, 2009 10:00 pm 
Fordmods Newbie
Offline

Age: 27

Posts: 4

Joined: 3rd Jun 2009

Ride: EF Fairmont 4.0L

Location: Sydney
NSW, Australia

Ive got a EF fairmont and when driving on the highway it feels like every now and again it misses the oil pressure seems to be running high when mostly in the red. but every time it misses the oil pressure drops out of the red. ive replaced plugs, oil is fresh, put an injector clean through it. still the same any advice??????
Top
 Profile  
 
 
 Post subject: Re: EF Something Wrong. High Oil Pressure, and keeps missising.
Posted: Sat Jun 06, 2009 3:25 am 
Parts Gopher
Offline

Posts: 82

Joined: 6th Feb 2009

Ride: 2001 AUII XR6 ute

Location: In the shed
QLD, Australia

can you grab a multimeter and tell us what voltage you have at the battery with the engine running please?
Top
 Profile  
 
 
 Post subject: Re: EF Something Wrong. High Oil Pressure, and keeps missising.
Posted: Sat Jun 06, 2009 9:04 am 
Fordmods Newbie
Offline

Age: 27

Posts: 4

Joined: 3rd Jun 2009

Ride: EF Fairmont 4.0L

Location: Sydney
NSW, Australia

keeps floating around 14.35V while running
Top
 Profile  
 
 
 Post subject: Re: EF Something Wrong. High Oil Pressure, and keeps missising.
Posted: Sat Jun 06, 2009 9:37 am 
Parts Gopher
Offline

Age: 29

Posts: 52

Joined: 7th Nov 2006

Ride: NF fairlane

Location: melbourne
VIC, Australia

hey my nf fairlane does the same im not sure what it is any advise would be good?

 

_________________

Is There Life After Death Touch My Car And Find Out!!!

Top
 Profile  
 
 
 Post subject: Re: EF Something Wrong. High Oil Pressure, and keeps missising.
Posted: Sat Jun 06, 2009 12:14 pm 
NSW Cruise Moderator
Offline
User avatar

Age: 39

Posts: 7331

Joined: 5th Nov 2004

Gallery: 12 images

Ride: TE50

Location: ɹǝpun uʍop
NSW, Australia

could possibly be the signs of the coil pack nearing the end of its life, however oil pressure dropping on the miss is a bit unsual, as the engine would not loose enough speed to change to oil feed rate that drasticly.

Maybe an earth issue, any other guages flick around when you notice this happen?

 

_________________

Image

I have a car.

Top
 Profile  
 
 
 Post subject: Re: EF Something Wrong. High Oil Pressure, and keeps missising.
Posted: Sat Jun 06, 2009 4:58 pm 
Fordmods Newbie
Offline

Age: 27

Posts: 4

Joined: 3rd Jun 2009

Ride: EF Fairmont 4.0L

Location: Sydney
NSW, Australia

i might look into a replacement coilpack. nah none of the other gauges move when the oil pressure does.
Top
 Profile  
 
 
 Post subject: Re: EF Something Wrong. High Oil Pressure, and keeps missising.
Posted: Sat Jun 06, 2009 5:22 pm 
Smokin em up
Offline
User avatar

Age: 50

Posts: 259

Joined: 21st Aug 2008

Ride: Fairlane Concorde 4.0

Location: wagga
NSW, Australia

Possible electrical. I know you checked the voltage but check the voltage at the battery with headlights on/aircon on and see if it's between 13.8 and 14.5 volts. Also rev the car too 2,500 rpm and check the same. Check the voltage between the B+ term on the alternator (main output wire) and the positive battery terminal with all running and turned on. Voltage drop shouldn't exceed 300mV.(positive meter probe on B+ and negative meter probe on Battery + term)

Normally a bad earth would result in a reduction in oil pressure, but check the voltage between your eng block and neg batt term. Also check between neg batt term and chassis (green screw coolant tank bracket). Should all be less than 300mV with all running and headlights/aircon on.

 

_________________

NF Fairlane: Non Factory Dual Fuel - New coolant tank, New fuel injectors, New fuel pump, New earth cable, ECU capacitors replaced, New O2 sensor, leads and plugs, New Radiator/Condensor cleaned. 483,000kms. AU I6 Powered. Struts, Shockies, Tie rods and ball joints replaced.

Last edited by alfy12 on Sat Jun 06, 2009 7:52 pm, edited 2 times in total.

Top
 Profile  
 
 
 Post subject: Re: EF Something Wrong. High Oil Pressure, and keeps missising.
Posted: Sat Jun 06, 2009 5:23 pm 
NSW Cruise Moderator
Offline
User avatar

Age: 39

Posts: 7331

Joined: 5th Nov 2004

Gallery: 12 images

Ride: TE50

Location: ɹǝpun uʍop
NSW, Australia

check your earths before you commit to a coil pack though, nothing worse than doing the coil pack to find it was an earth strap.

"easiest" way to get to the coil pack if from under the car, coming up the side of No.5 cly or remove your oil filter and go from there. no easy way to do it. you could pull the BBM in half, but thats creating more work.

 

_________________

Image

I have a car.

Top
 Profile  
 
 
 Post subject: Re: EF Something Wrong. High Oil Pressure, and keeps missising.
Posted: Sat Jun 06, 2009 6:48 pm 
Parts Gopher
Offline

Age: 29

Posts: 52

Joined: 7th Nov 2006

Ride: NF fairlane

Location: melbourne
VIC, Australia

ive changed my coil pack, leads, plugs, isc, map sensor and still does it i cant work it out sometimes i im out driving for 2-3 hours and nothing and other times it happens all the time im changing my computer soon so will see if that works ive had it scaned by ford and nothing come up.

 

_________________

Is There Life After Death Touch My Car And Find Out!!!

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 9 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 22 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 6:10 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names