Fordmods Logo

ef xr6 power loss when driving or idling 

 

Page 1 of 1 [ 6 posts ] 

 
 Post subject: ef xr6 power loss when driving or idling
Posted: Tue Feb 23, 2010 10:56 pm 
Fordmods Newbie
Offline

Age: 32

Posts: 5

Joined: 24th Dec 2009

Ride: ef xr6

Location: adelaide
SA, Australia

hey guys i bought a ef xr6 recently been sweet as till i blew a hose and cleaned me engine bay out it had a lighting kit fitted from a fairmont ect i noticed start issues once retightned terminals which if i try still can just pull off thast all i done apart from sub amp ect

well today i have been driving on my way to work and for the first time ever i had the cd player cutting in and out and power loss to cluster and engine for split second here there
then cd player in out alot when i acclerated it sounded ruff as flatspotted when this was carrying on anyone know ?

ps tonight pulling out from bottle shop i noticed bad idle lights dim for split second "this is my first falcon i have drivin and im skitzin when looking at all the wireing

my email is douglasamills@hotmail.com i found it hard to find anywere to post up new to the site kinda urgent
Top
 Profile  
 
 
 Post subject: Re: ef xr6 power loss when driving or idling
Posted: Tue Feb 23, 2010 11:07 pm 
Getting Side Ways
Offline

Age: 29

Posts: 4182

Joined: 30th May 2005

Ride: 1993 EB XR8

Location: BrisVegas
QLD, Australia

Check the alternator is charging. Sounds like a dead alt or a stuffed battery. More likely alternator.

 

_________________

ILL60 - EF XR8, Sunroof, Ticky Kit, 19x8.5/19x11 TE37's, 347, AFr185's, TFS BoxRcustom converter, Hurst Quarterstick, huge billet cam.

51TER - DL LTD. Stock.

Top
 Profile  
 
 
 Post subject: Re: ef xr6 power loss when driving or idling
Posted: Tue Feb 23, 2010 11:10 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

Check your coil packs, leads and spark plugs...good idea to replace them if you haven't done so since you have just bought the car. Always a good idea to do a minor service on a second hand car so that you can keep track of recent services/repairs.

Power loss could be due to a lose earth or bad connection some where...check your main battery terminals again and make sure they are on nice and tight. Check the main cables to the terminal, make sure they are in good nick, ie. not hanging off 3 or 4 strands of copper. Also check the main earth cable on the engine block, it's on the exhaust side, make sure it is on properly and clean.

Someone else could give you more info, but surging/flatspotting could be ignition or fuel related, I am leaning more towards ignition since you said it started happening after cleaning the engine bay and, assume, installing a sound system.

Lastly, make sure you learn how to type a proper paragraph with structured sentences using commas, full stops, colons etc...it's hard to read an incoherent post.

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
 Post subject: Re: ef xr6 power loss when driving or idling
Posted: Fri Feb 26, 2010 6:34 pm 
Stock as a Rock
Offline

Age: 27

Posts: 168

Joined: 3rd Dec 2009

Ride: Falcon EL Option 20

Location: Redcliffe, Brisbane
QLD, Australia

Yeah common problem with early model cars apparently (got a mate who works in a car wash). When you wash the engine bay you can knock the grease and grime off an earth connection and make it loose.

Check all the wiring in the usual places. Do a spark check etc etc.

Cheers
Josh
Top
 Profile  
 
 
 Post subject: Re: ef xr6 power loss when driving or idling
Posted: Tue Jan 11, 2011 9:47 pm 
Fordmods Newbie
Offline

Age: 32

Posts: 5

Joined: 24th Dec 2009

Ride: ef xr6

Location: adelaide
SA, Australia

thanks guys i didnt realise i had a reply the battery i have is a kmart battery terminal is tight but not that tight i could still twist it off if i tried.
well over the last few months i have put new eagle leads in bosch iridium plugs my fuel pump died so i fitted a new xr6 fuelmiser pump and tank lock ring and luckily i found the tool to do it aswell.
I still have this issue my alternator seems to charge properly up to 15 16 volts when low and at night sits on around i think 12 volts daily.
i have sourced a new coilpack but looks daunting to fit and a new oil pressure switch because when i push my ac button at a set of lights my pressure guage drops and warns me low oil pressure like wtf?
so im still trying to figure out things to work nicely i just wish i had a honest mechanic to show me what the hell is wrong then charge me not to charge me to find nothing!


my grammar is bad i know but im working on it.
Top
 Profile  
 
 
 Post subject: Re: ef xr6 power loss when driving or idling
Posted: Tue May 03, 2011 9:56 pm 
Fordmods Newbie
Offline

Age: 32

Posts: 5

Joined: 24th Dec 2009

Ride: ef xr6

Location: adelaide
SA, Australia

zall issues fixed guys was dirty wires in the bay and a faulty coilpack that was replaced over month ago.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 6 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 28 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 10:30 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names