Fordmods Logo

EF xr6 temp issues 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: EF xr6 temp issues
Posted: Sat Dec 06, 2008 10:32 pm 
Fordmods Newbie
Offline

Age: 31

Posts: 4

Joined: 6th Dec 2008

Ride: EF XR6

Location: Midway Point
TAS, Australia

Gday! i'v jus signed up after buying my 1st E series falcon! I have i little issue hope some one can help...my rad split last weekend so after putting a new item in the temp guage will rise up to the M and then after about 10secs drop to below the L. Before it used to sit steady on the A. To try fix this problem i put in a new thermostat, water pump and hoses and a new temp switch and the problem is still not fixed...any ideas? cheers Jonesy
Top
 Profile  
 
 
Posted: Sun Dec 07, 2008 3:40 am 
Getting Side Ways
Offline
User avatar

Posts: 887

Joined: 8th Aug 2006

Ride: Falcon

Location: Central Highlands
QLD, Australia

get your coolant system back flushed!!

 

_________________

97 EL Fairmont 4l OHC .Silver.
Exhaust: Pacemaker's, 2.5" exhaust and Hiflow cat
Intake: FRAM AIRHOG , EL GT snorkel
XR6 300kpa fuel reg Stg 2 Auto Shift Kit.6DJA ECU
PM in Qld looking too buy Toyota 4*4 SR5 Dualcab Hilux 91-97 with 2.8l diesel engine/5spd manual

Top
 Profile  
 
 
Posted: Sun Dec 07, 2008 9:41 am 
Fordmods Newbie
Offline

Age: 31

Posts: 4

Joined: 6th Dec 2008

Ride: EF XR6

Location: Midway Point
TAS, Australia

Cheers will try that next week!
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 3:02 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names