Fordmods Logo

EL camshaft/head query 

 

Page 1 of 2 [ 19 posts ] Go to page 1, 2  Next

 
 Post subject: EL camshaft/head query
Posted: Sun Sep 09, 2007 8:46 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

Hey everyone. I searched up on camshaft threads...heaps to go through but didn't find one that could answer my question.

I have a standard EL engine in the car and an EL XR6 motor in my garage. I was thinking of putting an aftermarket cam in the XR motor, which will later be dropped in my car. I am planning on getting a mild CrowCam (Part No. 2222519), but I'm not sure if there is much gain over the XR cam...since I have no clue about all those duration/lift figures, what they mean and do. If there isn't too much gain, then I might as well just stick with the XR cam.

If I do end up with a mild cam, could the XR valve springs handle the work load? If they do I guess that would potentially save me a few pennies :D.

Another thing, if I was to go with an aftermarket cam for the XR motor, is it possible just to put the spare XR cam in my current running motor? It is a standard EL motor so I am not sure if the springs would be able to handle the work load of the XR cam. If it can, I might as well just chuck the XR cam into my current motor and just have some fun before I put the XR motor in. Timing doesn't have to be advanced or retarded or is there more to it :?? I do have an EL Fairmont Ghia ECU which I will use instead of standard if all goes to plan

I don't want to go any more then a mild cam, mainly cause I don't want to fiddle with aftermarket ECUs or something. Prefer a XR ECU friendly cam over an aftermarket ECU requirement cam.

Sorry about all the questions and long read.

phong =P~

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
 Post subject: Re:
Posted: Sun Sep 09, 2007 10:22 pm 
Smokin em up
Offline

Age: 28

Posts: 213

Joined: 17th Nov 2005

Gallery: 14 images

Ride: EL XR6

Location: Waikerie
SA, Australia

Lol I just started a post nearly exactly the same. I wana put the same cam in my Spare engine but year want to know what else i have to do/ How much you paying for your cam?

 

_________________

1996 EL XR8, Dynamic White, 18inch Simmons Wheels, Lowered all round with pedders shocks and springs, Clear tail lights and clear side repeaters

Top
 Profile  
 
 
 Post subject: Re:
Posted: Sun Sep 09, 2007 10:30 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

suttoo wrote:
Lol I just started a post nearly exactly the same. I wana put the same cam in my Spare engine but year want to know what else i have to do/ How much you paying for your cam?


I think they wanted about $550 for the mild CrowCam, vernier gears and also new valve springs...but if I don't have to replace the springs, I don't mind just keeping the old ones on. Not sure how much just the cam would be.

phong =P~

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
Posted: Mon Sep 10, 2007 12:44 pm 
Parts Gopher
Offline

Age: 28

Posts: 77

Joined: 22nd Jan 2007

Ride: EF

Location: Swan Hill
VIC, Australia

Have you made sure its not a hybrid engine before you buy a cam?

 

_________________

-<WEBBY>-

Top
 Profile  
 
 
Posted: Mon Sep 10, 2007 12:52 pm 
Getting Side Ways
Offline
User avatar

Posts: 681

Joined: 3rd Apr 2005

Gallery: 24 images

Ride: BF MKII Ghia

i have a el ghia 97, i got a wade 1636 cam, all i had to do was adjust the idle slightly but the computer is stock and it runs sweet with a noticeable improvement from the xr cam
Top
 Profile  
 
 
Posted: Mon Sep 10, 2007 6:46 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

webby_191189 wrote:
Have you made sure its not a hybrid engine before you buy a cam?


not a hybrid, came out of a 1997 EL Fairmont Ghia. I believe Hybrids only came out in 1998?

dsheps83 wrote:
i have a el ghia 97, i got a wade 1636 cam, all i had to do was adjust the idle slightly but the computer is stock and it runs sweet with a noticeable improvement from the xr cam


Thanks mate. I might get an aftermarket cam. Going to put the XR cam in my current motor hopefully this weekend. See how I go. Was told the springs can handle it so most likely the XR cam will go in my current car. Will see how it differs in power.

phong =P~

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
Posted: Mon Sep 10, 2007 7:10 pm 
Stock as a Rock
Offline

Posts: 121

Joined: 18th Mar 2007

Ride: EL Fairmont

Location: Melbourne
VIC, Australia

yea the springs that crow do as replacement are xr6 spec anyways so it'll be fine unless the old ones are rooted ....ive just ordered my 2222519 crow cam so looks like theres afew of us all doin it...let us know how it goes mate......

 

_________________

Live, Play, Work - FORD

Top
 Profile  
 
 
Posted: Mon Sep 10, 2007 7:11 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

ELFAIRY wrote:
yea the springs that crow do as replacement are xr6 spec anyways so it'll be fine unless the old ones are rooted ....ive just ordered my 2222519 crow cam so looks like theres afew of us all doin it...let us know how it goes mate......


Mine won't be done for a while...will probably take another 2 months before I can be bothered getting the whole motor back together. If you get it in before I do...let us know how it goes. Want to see a comparison.

But will keep you all posted about the XR in my standard motor...hopefully there is a difference.

phong =P~

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
Posted: Sun Sep 16, 2007 12:12 am 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

Hey everyone.

Worked on the car on Friday and today.

I found this problem...a broken rocker arm and one of the end pedestal cap thingies that hold the whole assembly together was chipped...you can see the part that is broken on the rocker arm.

Image

Image

Now because it was broken, I thought I'd just use the rocker pedestal assembly from my XR motor.

Chucked the XR cam in, bolted in the rocker assembly (with torque wrench) and started the car...it idled fine, sounded great and I thought lets take it for a drive...drove down the road and she just drove like a bag of s**t...

It kept bogging out and stuff, so I thought it may have been timing, but I have never touched the timing and the sprocket did not skip a tooth because i cabled tied the chain to it.

Now I just checked the engine in the dark and noticed that one lead had "light" sparks midway down the lead so I guess it would have been the lead.

Could it be possible that the lead can make the car run like a it was bogging down? The car was jerky and starved for power, and there was petrol smell so I put it down to that but I am unsure if a simple lead can cause such a big difference.

cheers

phong =P~

I

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
Posted: Sun Sep 16, 2007 12:32 am 
Getting Side Ways
Offline
User avatar

Posts: 1079

Joined: 18th Sep 2005

Ride: AUII Fairmont

Location: Belmont
WA, Australia

Pull that lead off and see if it makes a difference, if there is no difference, then you have a problem on that lead, or at least on the pot that lead is connected to.
Top
 Profile  
 
 
Posted: Sun Sep 16, 2007 12:34 am 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

TwistedEL wrote:
Pull that lead off and see if it makes a difference, if there is no difference, then you have a problem on that lead, or at least on the pot that lead is connected to.


Cool. I'll give it a shot tomorrow morn when I reverse the car out. Hopefully its just a lead :(

phong =P~

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
Posted: Sun Sep 16, 2007 2:47 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

Well i pulled the suspecting lead off, reversed out of the drive way and it ran the same if the lead was on.

So I thought I'd change it with a spare one I had lying around and changed one of the other ones as well.

Drove for a little while like it was normal, and once it got hot, it started to stutter again...

Now I wait for it to cool down, change all the leads and see what happens.

phong =P~

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
Posted: Sun Sep 16, 2007 3:08 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 11791

Joined: 5th Nov 2004

Gallery: 13 images

Ride: Holden VF Calais / NL FBT

Location: SE Melb
VIC, Australia

phongus wrote:
Well i pulled the suspecting lead off, reversed out of the drive way and it ran the same if the lead was on.

So I thought I'd change it with a spare one I had lying around and changed one of the other ones as well.

Drove for a little while like it was normal, and once it got hot, it started to stutter again...

Now I wait for it to cool down, change all the leads and see what happens.

phong =P~

Could be the dizzy on the way out

 

_________________

Nicko

Top
 Profile  
 
 
Posted: Sun Sep 16, 2007 3:11 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

Nicko wrote:
phongus wrote:
Well i pulled the suspecting lead off, reversed out of the drive way and it ran the same if the lead was on.

So I thought I'd change it with a spare one I had lying around and changed one of the other ones as well.

Drove for a little while like it was normal, and once it got hot, it started to stutter again...

Now I wait for it to cool down, change all the leads and see what happens.

phong =P~

Could be the dizzy on the way out


hopefully not :? Could it also be the just the cap? Just got to get the car up and running by tomorrow.

phong =P~

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
Posted: Sun Sep 16, 2007 6:00 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

all fixed...was the leads. Got all the leads I could find that were kept by my dad (don't know why) and used them. Now the car runs like normal...and a bit smoother then before all the mishaps. Will put the XR cam in on Wed/Thurs, will see how it goes then.

phong =P~

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 19 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 37 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 9:15 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names