Fordmods Logo

EL constantly blowing main engine fuses 

 

Page 1 of 1 [ 2 posts ] 

 
 Post subject: EL constantly blowing main engine fuses
Posted: Fri Dec 24, 2010 9:41 pm 
Oompa Loompa
Offline

Age: 38

Posts: 41

Joined: 6th Oct 2010

Ride: XH van

Location: whyalla
SA, Australia

i had the fuel pump replaced and the coil replaced along with a new set of leads and plugs now when the car starts the main engine fuse blows imediately the auto electrican i feel is giving me the run around saying he dont know what it is can anyone shed light on this i suspect its a short in the fuel pump or something along these lines..
Top
 Profile  
 
 
 Post subject: Re: EL constantly blowing main engine fuses
Posted: Fri Dec 24, 2010 11:49 pm 
Technical Contributor
Offline
User avatar

Age: 38

Posts: 4093

Joined: 20th Mar 2005

Gallery: 2 images

Ride: 2.0 Turbo VW

Power: 142 rwkw

Location: Seaford State:
VIC, Australia

Check wiring in the driver side kick panel.

Check for an aftermarket isolator for the fuel pump.

Remove the plug from the pump and see if it still shorts, and trace it back that way.

 

_________________

Carefree, we may not be number one, but we're up there.

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 2:18 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names