Fordmods Logo

EL Dash lights dont work 

 

Page 1 of 1 [ 2 posts ] 

 
 Post subject: EL Dash lights dont work
Posted: Sat Jan 12, 2008 2:44 pm 
Oompa Loompa
Offline

Posts: 36

Joined: 31st Oct 2007

Location: Darwin
NT, Australia

Gidday all! The instrument lights are not working on my EL Saphire. headlights turn on and the led lights dim down, but no lighting. A bit awkward at night time! Anyone got any ideas? Thanks
Top
 Profile  
 
 
Posted: Sun Jan 13, 2008 9:53 pm 
Smokin em up
Offline
User avatar

Age: 33

Posts: 255

Joined: 21st Feb 2007

Ride: BA MkII XR8 and XE Sedan 351

Location: St Clair
NSW, Australia

Umm,you could take out the instrument cluster and check the globes in the back of it,maybe they have all open circuited , or their is a wiring issue,could check fuses as well...Vito.

 

_________________

BRING BACK THE CLEVELAND!!!

My daily driver-1995 EF Falcon 5 speed 4lt
My project car/weekend warrior-1982 XE Falcon with 351 clevo power,new target is Sydney Powercruise!!
Now wrecking-1989 EA Falcon s-pack 5 speed CFI

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 27 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 6:19 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names