Fordmods Logo

EL drops to idle and then speeds up again. wtf 

 

Page 1 of 2 [ 21 posts ] Go to page 1, 2  Next

 
 Post subject: EL drops to idle and then speeds up again. wtf
Posted: Mon Jul 28, 2014 9:12 pm 
Stock as a Rock
Offline

Age: 23

Posts: 100

Joined: 16th Oct 2012

Ride: 98 EL Falcon

Location: Brisbane
QLD, Australia

G'day guys, back with another problem with this bloody stupid car.
So it has been running like absolute crap balls, and I did a diy smoke vacuum test which was conclusive that I have a bigass leak.

Well that was today's job..

see: Old broken inlet manifold gasket.
Image
The new gasket is made by permaseal. I bought it from bursons for $30.55. Much better material than the stock one. It took around 2 hours for me to change the gasket and get the car running again. After figuring out the injector 1 was unplugged and ht lead 3 wasn't 100% connected (don't buy bosch supersport leads. You will want to kill yourself).. Fun times.

So, after all that. The car is still doing this crap.
http://vid1368.photobucket.com/albums/ag175/Filipe_Argentino/VIDEO0003_zpsa6e0072a.mp4

(if the above link doesn't work)http://vid1368.photobucket.com/albums/ag175/Filipe_Argentino/VIDEO0003_zpsa6e0072a.mp4

So basically what is going here?
It is starting at idle, revving, lowering to idle and then raising before dropping again. My only guess is there are still vacuum leaks somewhere.
My understanding is now that the isc is disconnected, the throttle pedal is the only thing that is going to allow more air in to raise the revs. So why is it doing it on its own? :(

I have blocked off the isc because it is too slow, so is the replacement one I acquired. The idle has been bumped up accordingly. The throttle body is clean and polished, and throttle cable appears to be smooth (no sticking).

I'm stumped :(

 

_________________

98 EL Falcon Gli - AU II intech - t5 manual - Lowered on king lows - 2.5" custom exhaust - 200cell hi flow cat - 17" Speedy cobalt's powder coated in steel pearl - powerwindows - suede door inserts (classy) - fog lights - (probably other things I can't remember)

Top
 Profile  
 
 
 Post subject: Re: EL drops to idle and then speeds up again. wtf
Posted: Wed Jul 30, 2014 11:13 am 
Stock as a Rock
Offline

Age: 23

Posts: 100

Joined: 16th Oct 2012

Ride: 98 EL Falcon

Location: Brisbane
QLD, Australia

anybody?

 

_________________

98 EL Falcon Gli - AU II intech - t5 manual - Lowered on king lows - 2.5" custom exhaust - 200cell hi flow cat - 17" Speedy cobalt's powder coated in steel pearl - powerwindows - suede door inserts (classy) - fog lights - (probably other things I can't remember)

Top
 Profile  
 
 
 Post subject: Re: EL drops to idle and then speeds up again. wtf
Posted: Wed Jul 30, 2014 12:00 pm 
Parts Gopher
Offline

Age: 31

Posts: 70

Joined: 6th Sep 2005

Ride: AU II Fairlane

Location: Brisbane
QLD, Australia

Have you run diagnostics on it yet, try and see if any DTC's come up that might point you in the right direction. Make sure you check all the vacuum hoses, even a small leak can cause issues.

 

_________________

AU II Fairlane Ghia 180 hp@ the wheels, Pacemaker 4499, RedBack 2.5", stock CAT, CAI, Lovells low's. More to come

Top
 Profile  
 
 
 Post subject: Re: EL drops to idle and then speeds up again. wtf
Posted: Wed Jul 30, 2014 1:52 pm 
Stock as a Rock
Offline

Age: 23

Posts: 100

Joined: 16th Oct 2012

Ride: 98 EL Falcon

Location: Brisbane
QLD, Australia

I know there is a small vacuum leak through the oil dipstick, but otherwise all the hoses should still be good.

I did diagnostics and the only errors it gave me was for a faulty power steering switch (which isn't faulty because it is new, and it works). Also two errors for the isc (which makes sense as it is disconnected).

I might have to hook my smoke chamber back up to the intake manifold and see if I can get any extra smoke out.

 

_________________

98 EL Falcon Gli - AU II intech - t5 manual - Lowered on king lows - 2.5" custom exhaust - 200cell hi flow cat - 17" Speedy cobalt's powder coated in steel pearl - powerwindows - suede door inserts (classy) - fog lights - (probably other things I can't remember)

Top
 Profile  
 
 
 Post subject: Re: EL drops to idle and then speeds up again. wtf
Posted: Fri Aug 01, 2014 12:08 pm 
Getting Side Ways
Offline

Posts: 836

Joined: 1st Apr 2005

Gallery: 4 images

Ride: EF XR6 Wagon, AU2 XR6 VCT

Power: 148 rwkw

Location: Auckland
New Zealand

My EF was playing up at idle, but not as badly as yours. Finally found the vacuum leak by spraying Brakleen along every cm of every join between the throttle body and the head, plus all vacuum hoses (from both sides), brake booster vacuum reservoir, etc. The revs rise when you hit a leak. Found a small crack in the intake manifold gasket - it was tiny, but it was enough. If you do have a vacuum leak, this method should find it. It surprised me how thoroughly I had to spray in order to find the leak.

A little off topic, I'm intrigued by your bad experience with Bosch Supersports leads. I have been using Bosch MOTORsport leads (the blue ones) for a number of years with good results. I have had one lead split its blue cover on the inside of a tight bend after three years, but that's the only issue. The join of the terminal boot to the cable seems better than most.

 

_________________

95 EF XR6 wagon, 17" FTRs, DBA, QFM, KYB/Koni, AU block, ported EF head, SS Inductions, Territory intake, MLS gasket, milled, Franklin RH24B cam, Coby headers, no cat, Tickford 2.5", 2800rpm stall, J3 chip

Top
 Profile  
 
 
 Post subject: Re: EL drops to idle and then speeds up again. wtf
Posted: Fri Aug 01, 2014 6:29 pm 
Stock as a Rock
Offline

Age: 23

Posts: 100

Joined: 16th Oct 2012

Ride: 98 EL Falcon

Location: Brisbane
QLD, Australia

I appreciate the suggestions mate, I'll give them a go. Do you use think that throttle body cleaner spray will work as opposed to brake cleaner? I lost my job this week, so I have no money to buy stuff at the moment :-( this and the fact I just found that I have a cracked firewall to do deal with also. Good times..

My issue with the leads is the lead to plug connection. It is waaay to finicky for my liking. I seem to have two lead which suck. I spent a solid 15-20 mins trying to attach the no3 lead before I started the car again after doing the intake gasket. I freaked out thinking I broke the engine because it would idle. No, just the bloody leads weren't making proper contact.

3&5 are horrible to attach. It seems like they make the "click" but don't actually connect. They suck :-P

 

_________________

98 EL Falcon Gli - AU II intech - t5 manual - Lowered on king lows - 2.5" custom exhaust - 200cell hi flow cat - 17" Speedy cobalt's powder coated in steel pearl - powerwindows - suede door inserts (classy) - fog lights - (probably other things I can't remember)

Top
 Profile  
 
 
 Post subject: Re: EL drops to idle and then speeds up again. wtf
Posted: Fri Aug 01, 2014 7:11 pm 
Getting Side Ways
Offline

Posts: 836

Joined: 1st Apr 2005

Gallery: 4 images

Ride: EF XR6 Wagon, AU2 XR6 VCT

Power: 148 rwkw

Location: Auckland
New Zealand

I had been trying Start Ya Bastard starter spray, and couldn't find the leak. Then my mechanic neighbour told me to use Brakleen (or any brake cleaner spray) because it's much more flammable. I don't think throttle body cleaner will work, as it tends to reduce revs, not increase them. Might need to spend $5 or so for any cheap can of brake cleaner or parts cleaner spray at Supercrap.

As for the leads, the thing I like about the Motorsport ones (besides the pretty blue colour :D ) is the positive click when they go on. I have never had a bad connection or a boot come loose.

 

_________________

95 EF XR6 wagon, 17" FTRs, DBA, QFM, KYB/Koni, AU block, ported EF head, SS Inductions, Territory intake, MLS gasket, milled, Franklin RH24B cam, Coby headers, no cat, Tickford 2.5", 2800rpm stall, J3 chip

Top
 Profile  
 
 
 Post subject: Re: EL drops to idle and then speeds up again. wtf
Posted: Fri Aug 01, 2014 7:32 pm 
Stock as a Rock
Offline

Age: 23

Posts: 100

Joined: 16th Oct 2012

Ride: 98 EL Falcon

Location: Brisbane
QLD, Australia

I'll have to send dad on a mission to find me some brake cleaner. haha, he will love that :P

I wanted to buy the blue ones because
a) they're cool and powerful looking
b) they're probably at least somewhat better than the black ones

Problem was they were out of stock and out of my price range. The supersport leads were great on tube socket plugs, ie hyundai coils etc. But they are woeful on the falcon plugs. 1,2,4 &6 went on with minimal dramas (about 2~4 goes until I got the 'click' out of them) 3 & 5 would have taken at least 30+ goes each until they were on properly. They go down on the plug all the way, but it seems like the plug end pushes the contacts inside the boot further up inside the lead. Worth noting they are only a couple of months old.

Any ideas on common vacuum leaking points that I might not know about?
I know the breather hose on the back of the rocker cover seems a little lose, but doesn't appear to be leaking, also, I have bought another pcv just and mine seems to be leaking oil all over the place (even with a new grommet) so that might do something.

I might just have to break out the smoke container again. What a wonderfully functional disaster that was :P

 

_________________

98 EL Falcon Gli - AU II intech - t5 manual - Lowered on king lows - 2.5" custom exhaust - 200cell hi flow cat - 17" Speedy cobalt's powder coated in steel pearl - powerwindows - suede door inserts (classy) - fog lights - (probably other things I can't remember)

Top
 Profile  
 
 
 Post subject: Re: EL drops to idle and then speeds up again. wtf
Posted: Fri Aug 01, 2014 7:35 pm 
Getting Side Ways
Offline

Posts: 836

Joined: 1st Apr 2005

Gallery: 4 images

Ride: EF XR6 Wagon, AU2 XR6 VCT

Power: 148 rwkw

Location: Auckland
New Zealand

Personally, I would re-check the intake manifold gasket first. Some of the nuts are hard to tighten properly, and the gasket does compress. It is common for the nuts to need re-tightening after a bit. Also, if you have blocked off the ISC, I would check that it is sealed properly.

 

_________________

95 EF XR6 wagon, 17" FTRs, DBA, QFM, KYB/Koni, AU block, ported EF head, SS Inductions, Territory intake, MLS gasket, milled, Franklin RH24B cam, Coby headers, no cat, Tickford 2.5", 2800rpm stall, J3 chip

Top
 Profile  
 
 
 Post subject: Re: EL drops to idle and then speeds up again. wtf
Posted: Fri Aug 01, 2014 7:42 pm 
Stock as a Rock
Offline

Age: 23

Posts: 100

Joined: 16th Oct 2012

Ride: 98 EL Falcon

Location: Brisbane
QLD, Australia

I did go around and re-tighten the manifold, but I will re-check for the sake of it. I never thought of the ISC, but I suppose one side of it would be on the vacuum side, so I guess that makes sense.

I'll give them a go when the sun is back,
Thanks man :)

 

_________________

98 EL Falcon Gli - AU II intech - t5 manual - Lowered on king lows - 2.5" custom exhaust - 200cell hi flow cat - 17" Speedy cobalt's powder coated in steel pearl - powerwindows - suede door inserts (classy) - fog lights - (probably other things I can't remember)

Top
 Profile  
 
 
 Post subject: Re: EL drops to idle and then speeds up again. wtf
Posted: Sat Aug 02, 2014 9:38 pm 
Getting Side Ways
Offline
User avatar

Age: 40

Posts: 1807

Joined: 6th Feb 2006

Location: CENTRAL
VIC, Australia

I thought it was normal for the engine to hang like that my ef i6 manual was the same.
Top
 Profile  
 
 
 Post subject: Re: EL drops to idle and then speeds up again. wtf
Posted: Sun Aug 03, 2014 1:58 am 
Fordmods Newbie
Offline

Age: 37

Posts: 3

Joined: 19th May 2013

Gallery: 1 images

Ride: nf farlaine

Location: port lincoln
SA, Australia

try pvc valve i had same prob and replace it and runs fine now
Top
 Profile  
 
 
 Post subject: Re: EL drops to idle and then speeds up again. wtf
Posted: Mon Aug 04, 2014 10:57 am 
Stock as a Rock
Offline

Age: 23

Posts: 100

Joined: 16th Oct 2012

Ride: 98 EL Falcon

Location: Brisbane
QLD, Australia

Fastleno, I hope it isn't normal. It annoys the crap out of me :(

Trevnolan, I put my new pcv valve in about 20 mins ago, so we will see how it goes when I have the car running again.

I haven't had the chance to test out brake cleaner, but that is on my list of things to do.
Any other ideas you guys can think of for me to look at while I'm out there playing in the engine bay today?

 

_________________

98 EL Falcon Gli - AU II intech - t5 manual - Lowered on king lows - 2.5" custom exhaust - 200cell hi flow cat - 17" Speedy cobalt's powder coated in steel pearl - powerwindows - suede door inserts (classy) - fog lights - (probably other things I can't remember)

Top
 Profile  
 
 
 Post subject: Re: EL drops to idle and then speeds up again. wtf
Posted: Sat Aug 09, 2014 9:41 pm 
Getting Side Ways
Offline
User avatar

Age: 40

Posts: 1807

Joined: 6th Feb 2006

Location: CENTRAL
VIC, Australia

long shot but try disconnecting your power steer sensor on the rack
Top
 Profile  
 
 
 Post subject: Re: EL drops to idle and then speeds up again. wtf
Posted: Sun Aug 24, 2014 12:25 pm 
Stock as a Rock
Offline

Age: 23

Posts: 100

Joined: 16th Oct 2012

Ride: 98 EL Falcon

Location: Brisbane
QLD, Australia

It has been a while since I have had the chance to work on the falcon, but, I have managed to secure today as a 'car' day.

I have spent most of the morning spraying different things around the engine bay, and cannot for the life of me figure out where this leak is! :evil: :x

 

_________________

98 EL Falcon Gli - AU II intech - t5 manual - Lowered on king lows - 2.5" custom exhaust - 200cell hi flow cat - 17" Speedy cobalt's powder coated in steel pearl - powerwindows - suede door inserts (classy) - fog lights - (probably other things I can't remember)

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 21 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: Facebook [Bot], johny23 and 16 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 1:38 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names