Fordmods Logo

EL Engine Sluggish, ideas? 

 

Page 1 of 2 [ 17 posts ] Go to page 1, 2  Next

 
 Post subject: EL Engine Sluggish, ideas?
Posted: Thu Jan 24, 2013 3:26 am 
Oompa Loompa
Offline

Age: 24

Posts: 26

Joined: 8th Aug 2011

Ride: Ford Falcon 97' EL Fairmont Ghia

Location: Geelong
VIC, Australia

I have a 97 EL Fairmont ghia currently on 306,000Kms and is at a loss of power, Doing only 11second 0-100 and feeling somewhat sluggish in general.

Mods: Paceys, 2.5 cat back, high flow cat, bigger intake snorkel, au gasket, gas system (Not on when doing 0-100).

Is it simply because of the High Km's the engine is starting to get tired/worn. or should i be looking for a problem? The car has been regularly serviced.

Ideas:
1. Put together a low Km engine with the 3 engine i got laying around
2. Get the current block machined, etc.

I was planning on getting a Cam soon, so which avenue would be best?

Just looking for what people would do in my position.
Top
 Profile  
 
 
 Post subject: Re: EL Engine Sluggish, ideas?
Posted: Thu Jan 24, 2013 12:21 pm 
Parts Gopher
Offline

Age: 25

Posts: 87

Joined: 10th Apr 2011

Gallery: 3 images

Ride: 1993 ED xr6

Location: Melbourne
VIC, Australia

whats the idle like?
if its rough first place id look is the MAP sensor. mounted on the firewall just behind the inlet manifold

my motor has done nearly 400,000kms and you can still see the hone marks in the cylinder
and pulled 156.2rwkw

what sorta cam you looking at?

 

_________________

http://www.fordmods.com/the-garage-f53/cwhitz-ed-xr6-build-thread-introduction-t106086.html

Daily - 1993 ED XR6 - Wade 1521a - 156.2rwkw
Toy - 2009 Husqvarna TE510, converted to motard!

Top
 Profile  
 
 
 Post subject: Re: EL Engine Sluggish, ideas?
Posted: Thu Jan 24, 2013 12:25 pm 
Parts Gopher
Offline

Age: 25

Posts: 87

Joined: 10th Apr 2011

Gallery: 3 images

Ride: 1993 ED xr6

Location: Melbourne
VIC, Australia

there should be a black vacuum hose on it

 

_________________

http://www.fordmods.com/the-garage-f53/cwhitz-ed-xr6-build-thread-introduction-t106086.html

Daily - 1993 ED XR6 - Wade 1521a - 156.2rwkw
Toy - 2009 Husqvarna TE510, converted to motard!

Top
 Profile  
 
 
 Post subject: Re: EL Engine Sluggish, ideas?
Posted: Thu Jan 24, 2013 1:44 pm 
Getting Side Ways
Offline

Posts: 836

Joined: 1st Apr 2005

Gallery: 4 images

Ride: EF XR6 Wagon, AU2 XR6 VCT

Power: 148 rwkw

Location: Auckland
New Zealand

A well-maintained Falcon six is barely run it at 300,000 kms :D Seriously though, if it's not burning much oil and has fairly even compression across the cylinders, it's unlikely to be the kms on the engine causing the problem. With those mods, would think you should be 8.5 secs 0-100 maximum.

Couple things to check:
- +1 on the MAP sensor. Symptoms are typically terrible fuel economy and visible black exhaust smoke.
- Has your dizzy been turned back? I don't know what else it might affect in an EL, but advancing your spark (without knock) makes a big difference to torque.

Any other symptoms? Running hot? Idling rough? Anything like that? If you can pull the fault codes with a multi-meter, it may narrow the search.

 

_________________

95 EF XR6 wagon, 17" FTRs, DBA, QFM, KYB/Koni, AU block, ported EF head, SS Inductions, Territory intake, MLS gasket, milled, Franklin RH24B cam, Coby headers, no cat, Tickford 2.5", 2800rpm stall, J3 chip

Top
 Profile  
 
 
 Post subject: Re: EL Engine Sluggish, ideas?
Posted: Thu Jan 24, 2013 1:55 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

How's the auto? Has it been serviced? How about the diff?

Check your brakes or hand brake, they might be binding, however you can smell that stuff so probably not the issue.

As mentioned before, what's the fuel consumption?

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
 Post subject: Re: EL Engine Sluggish, ideas?
Posted: Thu Jan 24, 2013 3:37 pm 
Oompa Loompa
Offline

Age: 24

Posts: 26

Joined: 8th Aug 2011

Ride: Ford Falcon 97' EL Fairmont Ghia

Location: Geelong
VIC, Australia

-cwhitz

The idle seems fine, only problem is when starting on gas it runs a little rough for the first 5 seconds, other than that its fine. I was thinking the 1673 wade cam, or even the 977b, will probably go with the 1673.

-efxr6wagon

Ill have a look at the fault codes soon, when it cools down outside.

-phongus

The auto seems fine, it shifts smoothly, not sure if its diff. I got a 3.45LSD in the back. I get roughly 350-400kms on gas and 300 on petrol for a full tank.

Thanks guys. Ill check some of this stuff when it cools down.
Top
 Profile  
 
 
 Post subject: Re: EL Engine Sluggish, ideas?
Posted: Thu Jan 24, 2013 3:45 pm 
Oompa Loompa
Offline

Age: 24

Posts: 26

Joined: 8th Aug 2011

Ride: Ford Falcon 97' EL Fairmont Ghia

Location: Geelong
VIC, Australia

Also, after the car has been sitting for a night after a long drive and you start it up and give it some revs it shoots out allot of smoke. then it goes back to normal. Even sometimes it will blow a tiny bit of smoke and then it will go back to normal.
Top
 Profile  
 
 
 Post subject: Re: EL Engine Sluggish, ideas?
Posted: Thu Jan 24, 2013 3:56 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

CJLasky wrote:
I get roughly 350-400kms on gas and 300 on petrol for a full tank.


Jesus your petrol economy is crap! Although your gas economy is great...depending how big the tank is though. Either way, I get around 500km from 60L PULP...so about 12L/100km and that's with modifications. Poor economy could be a number of things, however the first things I'd look at would be the O2 sensor, MAP sensor, any vacuum leaks, a blocked catalytic converter/muffler or a severely blocked air filter. Check your ignition timing as well, could be slightly off causing issues.

Regarding your diff, might want to give it an oil change if it hasn't been done before (I didn't change mine after 100000km...to be honest I didn't feel any difference...was a little quieter I think).

CJLasky wrote:
Also, after the car has been sitting for a night after a long drive and you start it up and give it some revs it shoots out allot of smoke. then it goes back to normal. Even sometimes it will blow a tiny bit of smoke and then it will go back to normal.


What colour smoke? White/black/grey/bluey?

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
 Post subject: Re: EL Engine Sluggish, ideas?
Posted: Thu Jan 24, 2013 4:12 pm 
Oompa Loompa
Offline

Age: 24

Posts: 26

Joined: 8th Aug 2011

Ride: Ford Falcon 97' EL Fairmont Ghia

Location: Geelong
VIC, Australia

Blue/blackish smoke.

I was told by the previous owner that it had this problem and he end up putting a taxi valve on it, but said putting a catch can on it would fix the problem.
Top
 Profile  
 
 
 Post subject: Re: EL Engine Sluggish, ideas?
Posted: Fri Jan 25, 2013 11:40 am 
Parts Gopher
Offline

Age: 25

Posts: 87

Joined: 10th Apr 2011

Gallery: 3 images

Ride: 1993 ED xr6

Location: Melbourne
VIC, Australia

mine used to do that, and it was the valve stem seals. over night oil leaks through a bit and on start up it blew blue smoke but once it warmed up it was fine.

it sounds like you have a vacuum leak or timing issue to me.

 

_________________

http://www.fordmods.com/the-garage-f53/cwhitz-ed-xr6-build-thread-introduction-t106086.html

Daily - 1993 ED XR6 - Wade 1521a - 156.2rwkw
Toy - 2009 Husqvarna TE510, converted to motard!

Top
 Profile  
 
 
 Post subject: Re: EL Engine Sluggish, ideas?
Posted: Sat Jan 26, 2013 12:08 am 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 3737

Joined: 22nd May 2006

Ride: BF F6 Tornado - #0077

Location: Bendigo
VIC, Australia

sounds like a carbon copy of my car.

0-100 in 11-12 with tail wind. between 500 & 650 ks from a tank. lethergy. cranks but wont fire. engine occasionally looses all power for a split second. no smoke. under 180k on the clock.

Thinking its TFI related. CFB getting in there to fix it. maybe if i fix the head gasket if(when) it goes & I think I'll fix the car.

also a little slap/slop in the aux gear. too scared to investigate more

 

_________________

** For Sale ** http://www.fordmods.com/ford-parts-for-sale-f17/assorted-e-series-parts-t124697.html

F6 Tornado 2006 Build

Is it about sex? The engine in my car? Or a cure for cancer?
No?

Then f**k off

Top
 Profile  
 
 
 Post subject: Re: EL Engine Sluggish, ideas?
Posted: Sat Jan 26, 2013 12:12 am 
Oompa Loompa
Offline

Age: 24

Posts: 26

Joined: 8th Aug 2011

Ride: Ford Falcon 97' EL Fairmont Ghia

Location: Geelong
VIC, Australia

Just thinking about throwing a different engine in it to stop all this f**k around and to get a lot Km engine.
Top
 Profile  
 
 
 Post subject: Re: EL Engine Sluggish, ideas?
Posted: Sat Jan 26, 2013 10:30 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 3737

Joined: 22nd May 2006

Ride: BF F6 Tornado - #0077

Location: Bendigo
VIC, Australia

I'd be checking the whole ignition sys (coil, plugs, tfi, timing, leads, etc etc) way before ripping an engine

 

_________________

** For Sale ** http://www.fordmods.com/ford-parts-for-sale-f17/assorted-e-series-parts-t124697.html

F6 Tornado 2006 Build

Is it about sex? The engine in my car? Or a cure for cancer?
No?

Then f**k off

Top
 Profile  
 
 
 Post subject: Re: EL Engine Sluggish, ideas?
Posted: Sun Jan 27, 2013 6:53 pm 
Getting Side Ways
Offline

Age: 26

Posts: 789

Joined: 9th Dec 2011

Ride: S1 eb 5speed

Location: Coffs Harbour
NSW, Australia

First I'd suggest you
-correctly check/ set ignition timing (I run mine at +14 with 98octaine.)
-clean out ISC, TB and inlet manifold + airfilter if it needs it.
If the timing is set correctly and the rest is clean and the engine dosnt miss or hunt and carry on you'll need to look further.
That poor economy usually means one of 2 things with falcons.
Vacuume leak (fords are always heavily dependent on correct vacuum)
Or you are tuning ethanol fuel. Haha.

You may also have a stretched accelerator cable. Easy check, take the intake piping off the tb and with the engine off have someone push the pedal to the floor, if it dosnt open right up you have a stretched cable , or a floor matt under the pedal. (seen this many times)
Top
 Profile  
 
 
 Post subject: Re: EL Engine Sluggish, ideas?
Posted: Mon Jan 28, 2013 9:00 pm 
Oompa Loompa
Offline

Age: 24

Posts: 26

Joined: 8th Aug 2011

Ride: Ford Falcon 97' EL Fairmont Ghia

Location: Geelong
VIC, Australia

Did the compression test to day.

Results:

C1: 105, 110, 125 PSI
C2: 100, 120, 125 PSI
C3: 125, 135, 110 PSI
C4: 130, 125, 120 PSI
C5: 125 115, 110 PSI
C6: 110, 110, 110 PSI

Shouldn't it be around 150?

If i'm not mistaken its either the piston rings or the values. Ill be doing a test with oil in the spark plug holes tomorrow to see if its the rings.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 17 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 26 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 8:20 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names