Fordmods Logo

EL fairmont ghia lost spark while driving and towed 

 

Page 1 of 1 [ 9 posts ] 

 
 Post subject: EL fairmont ghia lost spark while driving and towed
Posted: Fri Aug 10, 2012 3:32 am 
Stock as a Rock
Offline

Age: 29

Posts: 122

Joined: 21st May 2010

Ride: 1997 EL Ford Fairmont Ghia

Location: Brisbane
QLD, Australia

Hi guys,

I was driving my EL ghia tonight and it was going great! First time i have driven it in 6 months (has been driven regularly in the mean time) and next thing i know, im in the middle of the road after loosing power at 80 and the car wotn start and im in the middle of the highway.

At the time i was giving it a bit for a boot and at about 4krpm it stutters and revs drop to zero, then its perked up again and kept going then did it again and that was it. Wouldnt start again. It felt liek two big coughs and then nothing. I rolled it off the road into a driveway and called RAC. They arrived and found there was no spark so it has just been towed to a workshop and ill get to it in the morning.

I guess the question is, what may have gone wrong? it cranked fine, and the fuel pump was priming, just no spark. It was driving really well before hand as well, it just dropped its guts and wouldnt start again...

I have to be on the ferry to the mainland on saturday night as well so fingers crossed its nothing too major, or too hard to get parts for in tasmania!
Top
 Profile  
 
 
 Post subject: Re: EL fairmont ghia lost spark while driving and towed
Posted: Fri Aug 10, 2012 8:30 am 
Tyre Shredder
Offline
User avatar

Posts: 326

Joined: 12th Jun 2010

Ride: EL Fairmont

Location: Central Highlands
QLD, Australia

Sounds like the ignition coil; They cost anywhere from $40-$80.

 

_________________

Current ride 2007
ML GLX Dualcab Triton 4x4

Top
 Profile  
 
 
 Post subject: Re: EL fairmont ghia lost spark while driving and towed
Posted: Fri Aug 10, 2012 9:00 am 
Stock as a Rock
Offline

Age: 29

Posts: 122

Joined: 21st May 2010

Ride: 1997 EL Ford Fairmont Ghia

Location: Brisbane
QLD, Australia

cool i will start there. I called the mechanic this morning and he said he started it and drove it around the corner so i guess that also points towards the coil?
Top
 Profile  
 
 
 Post subject: Re: EL fairmont ghia lost spark while driving and towed
Posted: Fri Aug 10, 2012 9:50 am 
Tyre Shredder
Offline
User avatar

Posts: 326

Joined: 12th Jun 2010

Ride: EL Fairmont

Location: Central Highlands
QLD, Australia

louie0408 wrote:
cool i will start there. I called the mechanic this morning and he said he started it and drove it around the corner so i guess that also points towards the coil?


Could also be a faulty TFI module on the side of the dizzy, they generally fail at operating temp cutting the power/trigger signal to the ignition coil. Once cooled down will work fine.

That's the 2 most common faults I have seen anyway on EL falcons with no spark.

 

_________________

Current ride 2007
ML GLX Dualcab Triton 4x4

Top
 Profile  
 
 
 Post subject: Re: EL fairmont ghia lost spark while driving and towed
Posted: Fri Aug 10, 2012 10:02 am 
Getting Side Ways
Offline

Posts: 2091

Joined: 3rd Apr 2008

Ride: EF Fairmont, XG Ute

I'd say TFI if it does it while hot? Quick easy and cheap either way.
Top
 Profile  
 
 
 Post subject: Re: EL fairmont ghia lost spark while driving and towed
Posted: Fri Aug 10, 2012 11:06 am 
Stock as a Rock
Offline

Age: 29

Posts: 122

Joined: 21st May 2010

Ride: 1997 EL Ford Fairmont Ghia

Location: Brisbane
QLD, Australia

That doesn't sound too severe, and like a pretty good diagnosis. Hopefully it will be back on the road by cob today and i can make the boat tomorrow!

Thanks all!
Top
 Profile  
 
 
 Post subject: Re: EL fairmont ghia lost spark while driving and towed
Posted: Fri Aug 10, 2012 11:14 am 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

imo, its the tfi module but i would change the coil aswell...
Top
 Profile  
 
 
 Post subject: Re: EL fairmont ghia lost spark while driving and towed
Posted: Fri Aug 10, 2012 11:57 am 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

TROYMAN wrote:
imo, its the tfi module but i would change the coil aswell...


+1

TFI module failing can cause issues with the coil, so if money allows, replace both at the same time (unless it's a new coil)

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
 Post subject: Re: EL fairmont ghia lost spark while driving and towed
Posted: Sat Aug 11, 2012 8:44 pm 
Stock as a Rock
Offline

Age: 29

Posts: 122

Joined: 21st May 2010

Ride: 1997 EL Ford Fairmont Ghia

Location: Brisbane
QLD, Australia

It ended up being a dead distributor and coil so both replaced for $400. At least it all happened close to home and not between Brisbane and Hobart...
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 9 posts ] 

Who is online

Users browsing this forum: No registered users and 46 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 10:53 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names