Fordmods Logo

EL Fairmont losing engine power 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: EL Fairmont losing engine power
Posted: Mon Aug 30, 2010 10:34 pm 
Stock as a Rock
Offline
User avatar

Age: 40

Posts: 119

Joined: 15th Nov 2004

Location: Bundaberg
QLD, Australia

My El has lost power when driving, I thought at first it was the Auto but after a while of driving,
(I Had to drive 500k's to get home) and I was cruising on cruise control I came to a hill and the auto kicked down to keep up the speed and then it cut out as it went to slow, I then found that if I pushed the pedel down to far the car would lose power and die, I could get to the 100kph but it took a long time to get ther and up the hills it went down to 60kph.

Any suggestion on what the problem could be?? I thought it could ba a O2 Sensor
Top
 Profile  
 
 
 Post subject: Re: EL Fairmont losing engine power
Posted: Mon Aug 30, 2010 10:51 pm 
Tyre Shredder
Offline
User avatar

Posts: 326

Joined: 12th Jun 2010

Ride: EL Fairmont

Location: Central Highlands
QLD, Australia

Monty wrote:
My El has lost power when driving, I thought at first it was the Auto but after a while of driving,
(I Had to drive 500k's to get home) and I was cruising on cruise control I came to a hill and the auto kicked down to keep up the speed and then it cut out as it went to slow, I then found that if I pushed the pedel down to far the car would lose power and die, I could get to the 100kph but it took a long time to get ther and up the hills it went down to 60kph.

Any suggestion on what the problem could be?? I thought it could ba a O2 Sensor


Blocked fuel filter or exhaust pipe, tired fuel pump, bad fuel pressure regulator Things I would check first

Does it idle ok and rev out in neutral/park gear ok??? It's not stuck in limp home mode--locked in 3rd gear??

 

_________________

Current ride 2007
ML GLX Dualcab Triton 4x4

Top
 Profile  
 
 
 Post subject: Re: EL Fairmont losing engine power
Posted: Mon Aug 30, 2010 11:06 pm 
Stock as a Rock
Offline
User avatar

Age: 40

Posts: 119

Joined: 15th Nov 2004

Location: Bundaberg
QLD, Australia

It does Idle fine, It does a very simular thing when I rev it out of gear but high in the rev range. It was not in limp mode as it went in over drive as per normal jus tlack of pulling power.
Top
 Profile  
 
 
 Post subject: Re: EL Fairmont losing engine power
Posted: Wed Sep 01, 2010 11:18 pm 
Stock as a Rock
Offline
User avatar

Age: 40

Posts: 119

Joined: 15th Nov 2004

Location: Bundaberg
QLD, Australia

Looks like I have gotten a bad batch of fuel somewere as filter badly clogged and fuel is dirty out of tank. Just need to empty tank on Sunday and give good cleanm then hopefully it will be all back to normal.
Top
 Profile  
 
 
 Post subject: Re: EL Fairmont losing engine power
Posted: Thu Sep 02, 2010 8:14 pm 
Getting Side Ways
Offline

Age: 40

Posts: 524

Joined: 15th Aug 2010

Ride: Territory SX TX

Location: Townsville
QLD, Australia

If it was a EF or AU I would have suggested coil pack, as thats exactly what my AU did when it shat its coil pack. But its not and it isnt, its fuel like you said.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: Swalgerman and 18 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 7:43 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names