Fordmods Logo

EL Fairmont, weird problem 

 

Page 1 of 1 [ 6 posts ] 

 
 Post subject: EL Fairmont, weird problem
Posted: Sat May 27, 2006 9:01 pm 
Fordmods Newbie
Offline

Posts: 5

Joined: 20th Apr 2006

Location: Ozark Mountains, Victoria
VIC, Australia

G'day, Ive just bought an EL Fairmont (6cyl) with Tickford dual fuel and Ive done about 3000k's in it last fortnight without problems. Today it wouldnt start at all, I flattened the battery trying and put another battery in and eventually got it started but it heaps of cranking over to get it to run. It seems to idle ok but if I try driving it as soon as there is some load it dies again....some more info.

Problem is exactly the same on gas and petrol.
There is spark but not sure if its enough?
Spark plugs appear to be slightly "wet" and car stinks of unburnt LPG or petrol.

Only thing I can think of is I was about to clean the car, had the ignition turned on (listening to radio) and the phone rang, I forgot abt car clean and left the ignition turned on for about 90 mins...dunno if this would cause a problem?

When I finally get the car running, it idles fine most of the time (a couple of times its sounded like its running on 4 cylinders) and revs out ok but soon as the car's in drive an attempt at putting the foot down hard kills the motor

Would appreciate any help, Im in the bush and the nearest mechanic is around 40k's away and there is no way Id get the car that far under its own steam and a tow truck will cost a fortune !

Unfortunately I dont have a manual for this model, but I do have basic mechanical knowledge and a good set of tools so Id like to at least attempt a fix myself if possible...

Should of stuck with my NC V8 Ghia, purchased new I did nearly 400,000K's in it and not one breakdown ever!
Thanks
Top
 Profile  
 
 
Posted: Sat May 27, 2006 10:28 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 832

Joined: 5th Nov 2004

Gallery: 7 images

Ride: EL Fairmont

Location: Brisbane
QLD, Australia

sounds like a weak spark. Either your coil is rooted, and/or TFI module is shagged. Replace this, check your dissy cap and ign leads and should all be sweet.

 

_________________

too many rabbits in china

Top
 Profile  
 
 
Posted: Sat May 27, 2006 11:09 pm 
Fordmods Newbie
Offline

Posts: 6

Joined: 13th Dec 2005

Location: melton
VIC, Australia

sounds like these el fairmonts are hving these problems at the same time as i have just replced my tfi and my coil as they stopped working yesterday all ok now buit when i checked the timing i notice timing mark on the balancer was way out is it because it has slipped and if so is it bad
Top
 Profile  
 
 
Posted: Sat May 27, 2006 11:10 pm 
Fordmods Newbie
Offline

Posts: 6

Joined: 13th Dec 2005

Location: melton
VIC, Australia

sounds like these el fairmonts are hving these problems at the same time as i have just replced my tfi and my coil as they stopped working yesterday all ok now buit when i checked the timing i notice timing mark on the balancer was way out is it because it has slipped and if so is it bad
Top
 Profile  
 
 
Posted: Sun May 28, 2006 10:59 am 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 832

Joined: 5th Nov 2004

Gallery: 7 images

Ride: EL Fairmont

Location: Brisbane
QLD, Australia

no i dont think so. Just create new mark with some paint and she should be apples

 

_________________

too many rabbits in china

Top
 Profile  
 
 
Posted: Sun May 28, 2006 8:38 pm 
Getting Side Ways
Offline
User avatar

Age: 54

Posts: 4102

Joined: 18th Nov 2004

Gallery: 10 images

Ride: PX2 Ranger 4x4 XLT Dual CAB

Location: Carrum Downs
VIC, Australia

terriGT wrote:
sounds like these el fairmonts are hving these problems at the same time as i have just replced my tfi and my coil as they stopped working yesterday all ok now buit when i checked the timing i notice timing mark on the balancer was way out is it because it has slipped and if so is it bad


If the balancer has slipped then replace it. The next thing it will do is fall apart.

 

_________________

Image
She's meanness put to music and the b**ch is born to run!
Like the sign says, "speed's just a question of money. How fast can you go?"

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 31 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 11, 2017 1:30 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names