Fordmods Logo

el falcon no power to anything 

 

Page 1 of 1 [ 10 posts ] 

 
 Post subject: el falcon no power to anything
Posted: Tue Dec 11, 2012 12:58 pm 
Fordmods Newbie
Offline

Age: 32

Posts: 10

Joined: 9th Sep 2012

Ride: el falcon 97

Location: brisbane
QLD, Australia

battery was not keeping charge so i changed the alternator and when i replace it and connected the battery back up i had no power to anything smart lock light not flashing no lights.i've changed all the fuses and relays and still nothing
Top
 Profile  
 
 
 Post subject: Re: el falcon no power to anything
Posted: Tue Dec 11, 2012 1:07 pm 
Getting Side Ways
Offline
User avatar

Age: 38

Posts: 1204

Joined: 24th Apr 2010

Gallery: 1 images

Ride: Ef Fairmont

Location: Bleakheath
NSW, Australia

Check your earth. They need a strong earth connection or it will do the same as what your saying.
Top
 Profile  
 
 
 Post subject: Re: el falcon no power to anything
Posted: Tue Dec 11, 2012 1:40 pm 
Fordmods Newbie
Offline

Age: 32

Posts: 10

Joined: 9th Sep 2012

Ride: el falcon 97

Location: brisbane
QLD, Australia

i changed it still nothing
Top
 Profile  
 
 
 Post subject: Re: el falcon no power to anything
Posted: Tue Dec 11, 2012 1:57 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11738

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

Battery dead? get it checked/tested...another way is to give it a light whack with a mallet and see if that made a difference.

This may seem stupid, but did you put the battery in the right way? So you changed the main fuse as well?

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
 Post subject: Re: el falcon no power to anything
Posted: Tue Dec 11, 2012 2:50 pm 
Getting Side Ways
Offline
User avatar

Age: 38

Posts: 1204

Joined: 24th Apr 2010

Gallery: 1 images

Ride: Ef Fairmont

Location: Bleakheath
NSW, Australia

gerryford23 wrote:
i changed it still nothing

I may be crazy but its still sounding to me like it could be an earth problem. I had the same problem when me and a mate did the extractors on my ef, everything was connected and it turned out the earth just needed a little tightening and hey presto ( thats how fragile it can sometimes be). Also check the earth cable where it joins onto the block as the power steering can sometimes leak down there and even though you have changed the wire the contact might have been a little dirty. Just double checking that earth might save you big bucks on tail chasing is all I am saying.
Top
 Profile  
 
 
 Post subject: Re: el falcon no power to anything
Posted: Tue Dec 11, 2012 2:53 pm 
Getting Side Ways
Offline
User avatar

Age: 38

Posts: 1204

Joined: 24th Apr 2010

Gallery: 1 images

Ride: Ef Fairmont

Location: Bleakheath
NSW, Australia

If the alt was not charging the battery, how do you know the battery is not dead now? Just like Phongus said, it may be a stupid question but sometimes we overlook the obvious when s**t goes sour with cars
Top
 Profile  
 
 
 Post subject: Re: el falcon no power to anything
Posted: Tue Dec 11, 2012 8:20 pm 
Fordmods Newbie
Offline

Age: 32

Posts: 10

Joined: 9th Sep 2012

Ride: el falcon 97

Location: brisbane
QLD, Australia

changed the earth strap and got the battery tested and they said its fine... so i'm still chasing my tail and at a loss. don't know what to do next
Top
 Profile  
 
 
 Post subject: Re: el falcon no power to anything
Posted: Thu Dec 13, 2012 10:30 am 
Getting Side Ways
Offline

Posts: 496

Joined: 14th Sep 2011

Ride: BF II Gas Ute

Location: Canberra
ACT, Australia

Hi,

On my car there is 2 leads on the Pos. ( big red, smaller white ) and 4 on the Neg. ( big black smaller black for the other 3 ) Have you checked any Fuseable links ? The manual says there are 3. Run a test light from the Pos of the battery to the engine. This will test the main earth connection. It still may be a connection you have bumped loose. Recheck all connections. Are you shure the battery was not reversed with connections ? Drunken mates helping do this sort of thing.......

Regards 96ELGli

 

_________________

Regards 96ELGli

Top
 Profile  
 
 
 Post subject: Re: el falcon no power to anything
Posted: Sat Dec 15, 2012 11:00 am 
Fordmods Newbie
Offline

Age: 32

Posts: 10

Joined: 9th Sep 2012

Ride: el falcon 97

Location: brisbane
QLD, Australia

i rechecked everything now the battery sparks when i conect the battery terminals and i blow the main 100amp fuse every time someone told me to replace wiring harness. i'm thinking about that but still think it only a small problem. and the battery was put in the right way
Top
 Profile  
 
 
 Post subject: Re: el falcon no power to anything
Posted: Sun Dec 16, 2012 6:58 am 
Getting Side Ways
Offline

Posts: 496

Joined: 14th Sep 2011

Ride: BF II Gas Ute

Location: Canberra
ACT, Australia

Hi,

I had a look at the manual, and the 100 amp goes to the alternator. I don't trust the wiring diagrams in manuals as I have found mistakes before. I treat them as more of a guide. If you change the harness chances are you will cause more faults. Back to the topic though, use an old fuse-able link and using some terminals make it take a normal cheap blade fuse. This means that when testing you only ruin a 25 cent fuse..... Try with alternator power cable off and see what happened. You may have fitted a / or damaged the new alternator which is why the link is blowing. There are always well meaning mates, but many people change things that don't need it because of what a mate said and a small cheap problem becomes a big expensive one. Often it would have been cheaper and less hassle to go to a repair shop.

Regards 96ELGli

 

_________________

Regards 96ELGli

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 10 posts ] 

Who is online

Users browsing this forum: No registered users and 31 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 11, 2017 11:01 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names