Fordmods Logo

EL Fuse Problems 

 

Page 1 of 1 [ 6 posts ] 

 
 Post subject: EL Fuse Problems
Posted: Fri Sep 23, 2011 1:31 am 
Fordmods Newbie
Offline

Age: 30

Posts: 5

Joined: 23rd Sep 2011

Ride: EL Fairmont Ghia

Location: 3756
VIC, Australia

Hey Guys Just started having problems recently with one of my fuses in my EL Fairmont Ghia. (Fuse controls Petrol Pump,Back Speakers and Boot) It happens randomly and when i take the fuse out the plastic part has expanded like its almost melted and the actual fuse has snapped/split.

Any ideas on what is going on.Cheers Guys
Top
 Profile  
 
 
 Post subject: Re: EL Fuse Problems
Posted: Sun Sep 25, 2011 12:15 am 
Smokin em up
Offline

Posts: 258

Joined: 30th Dec 2007

Location: cairns
QLD, Australia

Something is drawing a lot more current than it is supposed to.You may have a dirty electrical connection,an item in the circuit is on it's way out and is using a lot of power to run and then is blowing the fuse.That's all I can think of at the moment .Kevman.
Top
 Profile  
 
 
 Post subject: Re: EL Fuse Problems
Posted: Sun Sep 25, 2011 1:25 am 
Technical Contributor
Offline
User avatar

Age: 28

Posts: 3705

Joined: 27th Sep 2006

Gallery: 20 images

Ride: ED Falcon

Power: 133 rwkw

Location: Leeton
NSW, Australia

rear speakers aren't on a fuse... And fuel pump is on a main fuse... which part of the boot?

how about some pics of the damage? and which fuse is it that is blowing?

To be melting the plastic it sounds like someone else has had issues with it and replaced it with too big of a fuse to over come the issue...

You own a multimeter? Once you give me more details of which fuse is blowing and some pics of damage I'll walk you through identifying the component...

Cheers,
Tim

 

_________________

93 Red ED 5spd Manual Build Thread

Performance: Complete AUII VCT Wiring & Power Train, Pacey Headers, 2.5" Exhaust, Exedy Clutch, DBA Rotors
Visuals: FG XR Wheel, XR Front, 17's, BA 5 Spd Shifter, BA Ghia Window Switches, NL Cluster
Tunes: 8" Pioneer Sub, JBL Speakers, Clarion Double DIN Headunit

Top
 Profile  
 
 
 Post subject: Re: EL Fuse Problems
Posted: Sun Sep 25, 2011 3:12 am 
Fordmods Newbie
Offline

Age: 30

Posts: 5

Joined: 23rd Sep 2011

Ride: EL Fairmont Ghia

Location: 3756
VIC, Australia

Sorry Its the front speakers that are losing power,I cant open the boot or the petrol pump through the smartlock remote or the interior buttons.It is the DRLK fuse.
I have been using 30amp fuses.The trouble seemed to start happening soon after i had my car repaired at the Panel Beaters.
I disconnected the factory amp in the boot as I thought that might be causing the problem but its still happening.

Thanks for the reply.
Top
 Profile  
 
 
 Post subject: Re: EL Fuse Problems
Posted: Sun Sep 25, 2011 8:58 am 
Technical Contributor
Offline

Age: 60

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

Its the petrol filler flap, not the pump.

Was the repairs for the rear? If so check through the boot and see if they have jammed a wire or such. Check it anyway, sounds to me like there is a wire pinched.
Top
 Profile  
 
 
 Post subject: Re: EL Fuse Problems
Posted: Mon Sep 26, 2011 1:58 am 
Fordmods Newbie
Offline

Age: 30

Posts: 5

Joined: 23rd Sep 2011

Ride: EL Fairmont Ghia

Location: 3756
VIC, Australia

There were some repairs to the right rear door and the rear so yeah ill have a look,cheers.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 23 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 1:12 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names