Fordmods Logo

EL Futura - does some wierd s**t 

 

Page 1 of 1 [ 8 posts ] 

 
 Post subject: EL Futura - does some wierd s**t
Posted: Sat Oct 02, 2010 12:55 pm 
Smokin em up
Offline
User avatar

Age: 28

Posts: 213

Joined: 14th Sep 2009

Ride: Hanni - BA XR6T

Location: Rosedale
VIC, Australia

Hey everyone

My mother-in-law is having a few problems with her Futura at the moment. It was running fine until she put the battery in backwards (Whoops!!). The only adverse effect that had on the car was it blew the LPG Computer and Switch so now its not running on gas - thats fine though because thats getting fixed Tuesday.

But before we found that out, she had a service done at the local mechanic here - he said it was just your usual service - leads replaced aswell. But since then it is hard to start when its warm, stalls on take off and sounds like its missing . . .

Just wondering if anyone had any ideas for me before she spends a s**t load at the Ford Dealers again lol

Oh and just to let yas know its a I6 Auto on Gas with 185xx kms . . .

Any help is appreciated

Cheers
Grant
Top
 Profile  
 
 
 Post subject: Re: EL Futura - does some wierd s**t
Posted: Sat Oct 02, 2010 1:39 pm 
Getting Side Ways
Offline

Age: 32

Posts: 1044

Joined: 4th Aug 2010

Ride: NA Fairlane, DC LTD

Location: Alice Springs
NT, Australia

The description is a little discombobulating but I think you are saying that you got a service, after the service the car ran with the problems listed, THEN at a later time your mum put the battery in backwards?

I'd check plugs are in snug.
Leads are all on properly, you should be able to hear or feel a click as they lock onto the plug, somtimes they don't click but work ok until it vibrates loose.

If the battery was put in backwards before the service did it run with these problems then?

 

_________________

[color=#004080]Cheers, Jacob.

NA Fairlane Build thread:
the-garage-f53/my-fairlane-build-lowlane-t94891.html.
Also in the garage....
AU LTD, DC LTD, and Lowlane.

Top
 Profile  
 
 
 Post subject: Re: EL Futura - does some wierd s**t
Posted: Sat Oct 02, 2010 4:19 pm 
Smokin em up
Offline
User avatar

Age: 28

Posts: 213

Joined: 14th Sep 2009

Ride: Hanni - BA XR6T

Location: Rosedale
VIC, Australia

Sorry mate - the battery was put in backwards first - then it wasnt running on gas (that prob is sorted) and it was running rough on fuel - got the service and it has been running like a heap of crap.

Ive just been for a drive in it and its now on the side of the road - Im pretty sure it is the fuel filter so ill change it over with a new unit and ill post up how I go . . .


Cheers
Grant
Top
 Profile  
 
 
 Post subject: Re: EL Futura - does some wierd s**t
Posted: Sat Oct 02, 2010 4:49 pm 
Getting Side Ways
Offline
User avatar

Age: 44

Posts: 3805

Joined: 22nd Apr 2007

Gallery: 5 images

Ride: DENTED UP OLD AUT WAGON

Location: Wellington
New Zealand

Fuel pump is an interesting beast worth considering too matey. Although they tend to go "pop" rather than fading slowly to death as yours sounds like has happened.


Check that the vacuum lines from the BBM to the sensors are all connected and not broken anywhere as the car uses them to adjust fuel mixes and stuff. If there's a leak there it will think the car is constantly at ambient air pressure, which is impossible as the engine SUCKS air in constantly.

The symptoms of running rich, missing, stalling on take off and hard to start are all possible with a leak in these pressure sensing lines. However, these sort of symptoms can also be advising you of a warped or cracked head. Has the car overheated at all?

Anyway, best of luck. Look on the bbm for thin (about 5mm) black hoses running up to the firewall. Try pulling one off when the engine is running and see what happens.
Top
 Profile  
 
 
 Post subject: Re: EL Futura - does some wierd s**t
Posted: Sat Oct 02, 2010 7:32 pm 
Getting Side Ways
Offline

Age: 32

Posts: 1044

Joined: 4th Aug 2010

Ride: NA Fairlane, DC LTD

Location: Alice Springs
NT, Australia

Also maybe try disconnecting the leads or injectors one by one.
If it makes it worse that cylinder is firin ok, if it dosnt change that cylinder may be the problem.

I had an annoying miss after doing a plug change and service, I didn't realise it was a miss untill my helper (daughter) dropped a tool on my foot, I jumped and pulled the lead off number 1 by accident....an it didn't change the idle..

 

_________________

[color=#004080]Cheers, Jacob.

NA Fairlane Build thread:
the-garage-f53/my-fairlane-build-lowlane-t94891.html.
Also in the garage....
AU LTD, DC LTD, and Lowlane.

Top
 Profile  
 
 
 Post subject: Re: EL Futura - does some wierd s**t
Posted: Tue Oct 05, 2010 2:47 pm 
Smokin em up
Offline
User avatar

Age: 28

Posts: 213

Joined: 14th Sep 2009

Ride: Hanni - BA XR6T

Location: Rosedale
VIC, Australia

Okso found out that it ended up being a completly blocked up fuel filter and the fuel pump also died! So with the gas computer and switch, fuel filter and fuel pump and a tune its costing $950 from ford which I thought wasnt to bad . . . thanks for the help guys :)
Top
 Profile  
 
 
 Post subject: Re: EL Futura - does some wierd s**t
Posted: Tue Oct 05, 2010 9:24 pm 
Getting Side Ways
Offline

Age: 26

Posts: 1109

Joined: 4th Sep 2009

Ride: 92 EB s

Location: DORRIGO
NSW, Australia

How longs it been running on gas?
Do you use it on fuel often?
Top
 Profile  
 
 
 Post subject: Re: EL Futura - does some wierd s**t
Posted: Tue Oct 05, 2010 9:38 pm 
Smokin em up
Offline
User avatar

Age: 28

Posts: 213

Joined: 14th Sep 2009

Ride: Hanni - BA XR6T

Location: Rosedale
VIC, Australia

Its Factory Tickford Gas setup so since it was built pretty much and we run it on ULP once a week
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 8 posts ] 

Who is online

Users browsing this forum: dp_stoner and 20 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 9:48 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names