Fordmods Logo

EL Futura just stopped- wont start 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: EL Futura just stopped- wont start
Posted: Sun May 04, 2008 7:33 pm 
Fordmods Newbie
Offline

Posts: 2

Joined: 3rd May 2008

Location: esperance
WA, Australia

Gday guys, as the title says, it just cut out cruising at 110 last night. Motor turns over but won't fire. I had to get back to work today but my dad has changed the coil and TFI module on the dizzy, the 2 most common parts to fail, that I found out through this forum.

Has anyone got any ideas on what to look at next? Its a bit hard when I'm at work and can't see the car but will be getting back to town tomorrow night to check it out.

Thanks for your help

Woody
Top
 Profile  
 
 
Posted: Sun May 04, 2008 7:37 pm 
Technical Contributor
Offline
User avatar

Age: 38

Posts: 4093

Joined: 20th Mar 2005

Gallery: 2 images

Ride: 2.0 Turbo VW

Power: 142 rwkw

Location: Seaford State:
VIC, Australia

Possible Main Fuse, Fuel pump, fuel pump relay etc.

 

_________________

Carefree, we may not be number one, but we're up there.

Top
 Profile  
 
 
Posted: Sun May 04, 2008 7:41 pm 
Getting Side Ways
Offline
User avatar

Posts: 1008

Joined: 21st Dec 2004

Ride: ED V8

Location: driving under the sun........now!
WA, Australia

Do the EL's have a crank angle sensor?

I'm thinking not as they went back to a dizzy with the EL didn't they?

Anyway, enough musing.....

Establish if it's fuel or spark before changing anything else..... then problem solve from there.

Can you hear the fuel pump priming when you turn the key to run? If not your fuel pump is your problem.

If no spark I'd be making sure there's spark at the dizzy first. (at least then you'll know which side of it to look. ie coil lead.

Obviously check all main fuses and work from there!

 

_________________

ED XR8 Spri-mitatio-nt

Top
 Profile  
 
 
Posted: Sun May 04, 2008 10:01 pm 
Fordmods Junkie
Offline
User avatar

Posts: 2839

Joined: 6th Nov 2004

Gallery: 50 images

Ride: MYSTERY EL's & Maverick LWB

Power: 198 rwkw

Location: parramatta
NSW, Australia

check the CRT fuse , it may have some thing to do about it ?

 

_________________

Chance Favors The Prepared Mind !
For Sale : EL Fairmont 4L 5spd offers, AU Fairlane Ghia 4L vct Stock no mods $3.5k ono
Image

Top
 Profile  
 
 
Posted: Mon May 05, 2008 10:44 am 
Stock as a Rock
Offline

Age: 61

Posts: 156

Joined: 2nd Nov 2005

Ride: EA Fairmont

Location: Canberra
ACT, Australia

Hi There

As suggested, check the above, but also......
sometimes the Hall Effect Unit in the dizzy can often
fail in tandem with the TFI module.

I had a no spark problem on an EFI ZL Fairlane.

Replaced TFI module ..... No go
Replaced Hall Effect Unit ...... Started first go.

Just something to consider.
Top
 Profile  
 
 
Posted: Tue May 06, 2008 9:26 pm 
Fordmods Newbie
Offline

Posts: 2

Joined: 3rd May 2008

Location: esperance
WA, Australia

Thanks to everyone for there help....after finally getting a look at the car it took about 1 minute to work out that the fuel pump was knackered. No buzzing sound on ignition and 12 volts at the connection with no fuel coming out of the line. Bewdy, 1 hour and $130 later she was going...sweet.

Thanks again.

Woody
Top
 Profile  
 
 
Posted: Tue May 06, 2008 9:49 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 5889

Joined: 2nd Mar 2006

Gallery: 5 images

Ride: '14 Grand Cherokee

Location: Port Lincoln
SA, Australia

woodynads wrote:
Thanks to everyone for there help....after finally getting a look at the car it took about 1 minute to work out that the fuel pump was knackered. No buzzing sound on ignition and 12 volts at the connection with no fuel coming out of the line. Bewdy, 1 hour and $130 later she was going...sweet.

Thanks again.

Woody


lol exactly the same thing happened to me today, but i was stopped at a busy traffic light cross road :lol:

 

_________________

11/93 ED OPT20 GLi | Full Boat Spec

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 32 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 7:42 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names