Fordmods Logo

el into eb conversion (WE HAVE IGNITION) 

 

Page 5 of 5 [ 65 posts ] Go to page Previous  1, 2, 3, 4, 5

 
Posted: Fri Jan 12, 2007 5:42 pm 
Smokin em up
Offline
User avatar

Age: 31

Posts: 264

Joined: 5th Jan 2007

Ride: E-Hybrid Falcon

Location: nowra, nsw
NSW, Australia

yes i agree, thats why i've came to the conclusion that i will be doing all my work myself, i can't afford a 'good' mechanic, if such a thing exists in my area which i doubt.
i shaved my el head the other week, honed/polished all ports, cleaned & relieved chambers & building up an ed bottom end. might even do the block myself but i'm not too keen on that. will take it to an iso accredited engineering firm to get that done if not by myself.

 

_________________

crow cam,cai,exaust,bbm,190 reg & el injectors,xr6 interior,guages,white cluster,pioneer/mtx stereo,big boot install w.i.p, 17"rims,koni/pedders shocks&springs with nolathane re-bush,ssv kit,stainless inserts,clear lights,t5 & short shifter,chardonay/pearl paint

Top
 Profile  
 
 
Posted: Sat Jan 13, 2007 11:15 pm 
Smokin em up
Offline
User avatar

Age: 33

Posts: 242

Joined: 17th Dec 2004

Ride: falcon eb

Location: Perth
WA, Australia

kewl .

well got the head back today. reseated the valves in with valve grinding paste got pictures too thinking of manking a doco up on it. simple to do and quite easy so yeh .

hopefully head will go back on tomorow and all be runniong sweet.
Top
 Profile  
 
 
Posted: Sat Jan 13, 2007 11:16 pm 
Smokin em up
Offline
User avatar

Age: 33

Posts: 242

Joined: 17th Dec 2004

Ride: falcon eb

Location: Perth
WA, Australia

oh yeh didnt go for the stg 3 kit yet figured i just want to get it on the road for now . but i got the eb motor sitting there ive got some plans for along that way so yeh

the el head did get a bit of a port jobb too so should be nice .
Top
 Profile  
 
 
Posted: Sat Jan 13, 2007 11:41 pm 
Smokin em up
Offline
User avatar

Age: 33

Posts: 242

Joined: 17th Dec 2004

Ride: falcon eb

Location: Perth
WA, Australia

hey guys just a quick h/g question .

the acl race series one i have was on the car for like 2 days and started like 3 times then the head came back off

thing is the gasket still looks brand new didnt peal apart ne where got no oil on it or nething was wondering if it could be reused ?

also i noticed that on it theres only holes on 1 side for the water flow ? is this right or should i drill holes threw it for both sides ?
ill get a pic

ok well if u look at the head u can see the oval holes on both side's ]

but on the h/g u can only see the small holes on one side of the gasket and blank on the other ?

is how it spose to be ? or wouldnt it restric flow of water ?

 

 

Attachments:
DSC00021.JPG
DSC00021.JPG [ 71.52 KiB | Viewed 20 times ]
Top
 Profile  
 
 
Posted: Tue Jan 16, 2007 12:24 am 
Smokin em up
Offline
User avatar

Age: 33

Posts: 242

Joined: 17th Dec 2004

Ride: falcon eb

Location: Perth
WA, Australia

well finally some gfood new . got her all back together tonight and she started and ran sweet as pie

just got to time the dizzy with a light and she should be sweet

other then that just got to fix a water leak on the heater hose wher eit goes into the firewall which is a b**ch to get to .
and secure the thermos in right and hook the knock sensor and bbm switch up a,d she's all good .
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 5 of 5  [ 65 posts ]  Go to page Previous  1, 2, 3, 4, 5

Who is online

Users browsing this forum: Google [Bot] and 22 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 5:07 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names