Fordmods Logo

EL just died ?!? 

 

Page 1 of 2 [ 26 posts ] Go to page 1, 2  Next

 
 Post subject: EL just died ?!?
Posted: Sat May 31, 2008 9:38 pm 
Parts Gopher
Offline

Posts: 54

Joined: 9th May 2005

Gallery: 5 images

Location: Brisbane
QLD, Australia

Hi Guys,
I'm hoping someone can give me a clue what just happened to my EL Falcon.

It just died on the road while driving home from the car wash doing about 60Ks.
The battery light lit up on the dash, the headlights kept going,
but the spark just stopped very suddenly, and hitting the accelerator did nothing,
and that is still the situation if I try to start it.... no spark at all.

I checked my belt, and it is ok, but I can't say I'm sure about the alternator.
The battery is definately ok, since it's still cranking the engine very strong.

I used a high pressure hose at the carwash, but nothing I haven't done
before, and this has never happened,
and even when I run over puddles it onl;y stutters rather than just dying.

If my alternator suddenly died, isn't the car supposed to run on the battery for a while?

Please help...
Art.

 

_________________

Gamer = Lamer

Top
 Profile  
 
 
Posted: Sat May 31, 2008 9:51 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 3737

Joined: 22nd May 2006

Ride: BF F6 Tornado - #0077

Location: Bendigo
VIC, Australia

sounds like a major earth problem or a alternator.

if it was the alternator, after you restart the car it will be down on voltage as the starter will have drained it. i'd get it checked

 

_________________

** For Sale ** http://www.fordmods.com/ford-parts-for-sale-f17/assorted-e-series-parts-t124697.html

F6 Tornado 2006 Build

Is it about sex? The engine in my car? Or a cure for cancer?
No?

Then f**k off

Top
 Profile  
 
 
Posted: Sat May 31, 2008 9:55 pm 
Parts Gopher
Offline

Posts: 54

Joined: 9th May 2005

Gallery: 5 images

Location: Brisbane
QLD, Australia

It won't restart, there's no spark.
I just know the battery is ok because it does crank the starter,
just doesn't kick over.
I wish I could look at it under light, but had to leave it on the road and get a lift home :(

 

_________________

Gamer = Lamer

Top
 Profile  
 
 
Posted: Sat May 31, 2008 10:10 pm 
Getting Side Ways
Offline

Posts: 2448

Joined: 5th Nov 2004

Gallery: 7 images

Location: Brisbane
QLD, Australia

The alternator light would have gone on when the engine died.

Its an EL - Id suspect water in the Dizzy perhaps. Or perhaps you knocked off a connector (There is a test connector just next to the dizzy usually and the car wont run without it).

Coil Lead is another good one.

Finally - a total failure could easilly be the ECU, however if that was the case then you would have a spark as the dizzy will generate one if it doesnt get a signal from the ECU
Top
 Profile  
 
 
Posted: Sat May 31, 2008 10:14 pm 
Parts Gopher
Offline

Posts: 54

Joined: 9th May 2005

Gallery: 5 images

Location: Brisbane
QLD, Australia

What's a dizzy?
I thought distributor, but it's electronic ignition?!?!

All the washing was done with the bonnet down, but I hope you're right.

I changed the oil today, and filled brake fluid, so maybe I could have bumped
something. I hope you're right one way or another.

 

_________________

Gamer = Lamer

Top
 Profile  
 
 
Posted: Sat May 31, 2008 10:30 pm 
Getting Side Ways
Offline

Posts: 2448

Joined: 5th Nov 2004

Gallery: 7 images

Location: Brisbane
QLD, Australia

Electronic ignition on EA, EB, ED, EL still has distributor.

Just under the inlet manifold at the front
Top
 Profile  
 
 
Posted: Sat May 31, 2008 10:54 pm 
Parts Gopher
Offline

Posts: 54

Joined: 9th May 2005

Gallery: 5 images

Location: Brisbane
QLD, Australia

Oh, ok thanks.
Hopefully it will be fine tomorrow.

 

_________________

Gamer = Lamer

Top
 Profile  
 
 
Posted: Sat May 31, 2008 11:06 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

I think you could have gotten water into the distributor, though if it was water in the dizzy, then there would still be spark.

My guess is that you might have accidentally shorted the TFI module causing it to die. TFI module is attached to the distributor under the inlet manifold.

phong =P~

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
Posted: Sat May 31, 2008 11:57 pm 
Getting Side Ways
Offline

Posts: 539

Joined: 30th Nov 2004

Location: Melbourne
VIC, Australia

Sounds defiantly like Ignition problems.

first thing i would do is check all connections are on then Change the Coil Pack.

Doesn't sounds water hit the distributer issues as you know when u hit the dizzy with water and it usually is just a time issue (until the water evaporates)
Top
 Profile  
 
 
Posted: Sun Jun 01, 2008 7:27 am 
Parts Gopher
Offline

Posts: 54

Joined: 9th May 2005

Gallery: 5 images

Location: Brisbane
QLD, Australia

Well I drove Dad's car out to it this morning, and it started first go :)
Yay!

I guess it was water somewhere afterall.
Thanks for the replies, always worth checking in here before going to a mechanic I think.
Cheers, Art.

 

_________________

Gamer = Lamer

Top
 Profile  
 
 
Posted: Sun Jun 01, 2008 7:32 am 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

@rt wrote:
Well I drove Dad's car out to it this morning, and it started first go :)
Yay!

I guess it was water somewhere afterall.
Thanks for the replies, always worth checking in here before going to a mechanic I think.
Cheers, Art.


Good to hear you got it up and running...but how come you woke up so early to get the car back :?...I'd still be asleep if my car was out there and I didn't have work.

By the way, for future references, if you clean the engine bay again, it is always a good idea to maybe cover electrical bits with some plastic just in case.

phong =P~

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
Posted: Sun Jun 01, 2008 9:46 am 
Parts Gopher
Offline

Posts: 54

Joined: 9th May 2005

Gallery: 5 images

Location: Brisbane
QLD, Australia

Nah, I didn't clean the engine, just the wheels,
the bonnet was down the whole time.

I was sorta in a hurry because of a job interview Monday.
I could have borrowed Dad's car for the actual interview, but if I get
the job, I'd need a car after that, so I really only had one day to look at it.
Glad I didn't have to run around the wreckers looking for parts this time.

I didn't actually get it back till just now, I just drove out to see if it would start after some time to dry.

 

_________________

Gamer = Lamer

Top
 Profile  
 
 
Posted: Sun Jun 01, 2008 10:52 am 
Fordmods Newbie
Offline

Age: 54

Posts: 4

Joined: 31st May 2008

Location: Cairns
QLD, Australia

Sounds like a coil pack failure. These nasty little suckers can go without warning, and can be expensive to replace. Some people go back to a 'electronic dizzy' style of ignition.

 

_________________

zzzZZzzz

Top
 Profile  
 
 
Posted: Sun Jun 01, 2008 12:40 pm 
Getting Side Ways
Offline
User avatar

Age: 34

Posts: 2637

Joined: 5th Nov 2004

Ride: EL TURBO GHIA

Power: 372 rwkw

Location: penrith
NSW, Australia

replace the coil

 

_________________

HMMMM BOOST !!!


ED fairmont R.I.P

STREET FORDS FEATURE CAR ISSUE 42

Top
 Profile  
 
 
Posted: Sun Jun 01, 2008 1:00 pm 
Getting Side Ways
Offline
User avatar

Age: 35

Posts: 850

Joined: 10th Nov 2004

Gallery: 20 images

Ride: 03 BA Fairmont

Location: Forest Lake
QLD, Australia

why does everyone keep saying coil pack? it's an EL not an EF!!!!


more than likely a TFI module on the way out. works now the engine is cold. watch for it happening again!!!

 

_________________

Regards,
Punnisher_42
_____________
2003 BA Fairmont - Stock standard
1994 U13 cough Nissan Cough Bluebird

Favorite Quotes:
"Sportwagon = homo-erotic wank-fest." - downingj

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 26 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: Google [Bot] and 20 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 8:57 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names