Fordmods Logo

EL Powered EA... New tickford cam now has no power! 

 

Page 2 of 2 [ 23 posts ] Go to page Previous  1, 2

 
Posted: Mon Mar 13, 2006 9:02 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 832

Joined: 5th Nov 2004

Gallery: 7 images

Ride: EL Fairmont

Location: Brisbane
QLD, Australia

I see where you are coming from..

but

its really not all that hard

manifold bolts on, change vacuum lines etc

set up a shift light's output to switch the runners

dyno tune to sort out the timing (as it can ping a bit if not tuned correctly)

agreed best thing is to swap in the whole EL ECU and engine actually, as EL has knock sensor as well. EA ECU u have to make a bit of a compromise with the tune, but I still reckon its a worthwhile mod if your staying NA

 

_________________

too many rabbits in china

Top
 Profile  
 
 
Posted: Mon Mar 13, 2006 9:08 pm 
Getting Side Ways
Offline
User avatar

Posts: 1549

Joined: 27th Apr 2005

Gallery: 1 images

Ride: AU Fairmont Ghia

Location: Perth
WA, Australia

Its worthwile if you have smartlock and you can change ECU's

I'm doing a BBM conversion in my EA but after all the stuffing around I cant see that it is worthwile. If i hadnt bought all the parts I would have ditched the idea
Top
 Profile  
 
 
Posted: Mon Mar 13, 2006 9:47 pm 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 1966

Joined: 13th Aug 2005

Ride: 2000 Au wagon

Location: some where in nsw
NSW, Australia

thats my point,,if people are happy to spend the money fine,,i personaly don't see the value in something that can creat more hassles

 

_________________

Image

Top
 Profile  
 
 
Posted: Mon Mar 13, 2006 10:27 pm 
Parts Gopher
Offline
User avatar

Age: 37

Posts: 57

Joined: 24th Feb 2006

Ride: EA 2, Sierra, Au1 XR 6

Location: Eden Park
VIC, Australia

still think its got nothing to do with what type of intake your running as mine is great to drive with the same cam
in two differnt cars.

 

_________________

10/89 EA 11 Spac 5 Speed, Being Rebuilt From The Ground Up
87 Sierra To much to list all the mods
99 Au1 XR6 5 speed stock as a rock

Top
 Profile  
 
 
 Post subject: Re: EL Powered EA... New tickford cam now has no power!
Posted: Mon Mar 13, 2006 10:36 pm 
Getting Side Ways
Offline

Posts: 6449

Joined: 11th Nov 2004

ZeroGreen wrote:
As the subject says, i have an EL Powered EA Falcon, it went like a shower of metaphorical s**t, but yesterday i thought i'd fix my rocker cover gasket which was leaking like a bottomless bucket, so when i got the cover off i thought i would replace my cam gear which had a noisy lifter on start up, when i took that off i kinda figured i'd put an XR6 cam out of a EF in it, put it all together again... now it has no power, good top end, but has no bottom end... im running the standard fuel and fuel mapping system out of the EA (multi point) and it hasn't got anything near the power it had b4 i changed the cam... can anybody who has done this help out??? it feels like it is running a bit lean... i don't really know much if anything about injection systems, but if it were a carb it wouldn't be a problem.... DAMN INJECTION! :P cheers...

Chris...


ford changed the valve timming on the xr6 cam for reason. to make use of the extra flow that the xr6 head has.
as every good engine builder knows, you have to match the cam to the head. you have just fitted a cam desinged to run with different port flow.
that is why it's gutless down low.

you can fix this by adcancing the ignition timming about 5 degrees but you will find the engine will stumble a bit comming back to idle.

best bet is put the old cam back in.
by the way both the standard and XR6 EF cams have the same lift. only valve timming is different

 

_________________

PERMANENTLY BANNED

Top
 Profile  
 
 
Posted: Tue Mar 14, 2006 12:51 am 
Getting Side Ways
Offline
User avatar

Posts: 1392

Joined: 5th Nov 2004

Ride: XR6 Turbo, XR8, Transit

Location: Somewhere
VIC, Australia

Doesnt the XR6 normally have 3:45 diff gears ??

This could also be contributing to your problem if you have standard EA diff gears.

 

_________________

www.XR8Chic.com
1993 ED XR8 - Poly Green, AFR 185 Alloy heads, Edlebrock Performer RPM Manifold, Crane 2031, T56 6 Speed, 3.9 diff, = 205.7 rwkw.
1993 ED Fairmont - Cobalt Blue, 5L, 17" CSA's and not much else.
1969 Mustang Fastback - Gunmetal Grey, 302, Auto, LHD. Doesn't go very hard, but looks sexy as !

Top
 Profile  
 
 
Posted: Wed Mar 15, 2006 9:27 pm 
Oompa Loompa
Offline

Posts: 22

Joined: 10th Mar 2005

Location: Melbourne
VIC, Australia

Have seen this problem before. It has a WHOLE lot to do with the manifold etc. The STD EF cam is 'nearly' an EB/D XR spec cam, so it will go quite well with the Std EA/B/D manifold, but when you go one step further to the EF/L XR cam, it all comes unstuck. Put on the bbl and an ECU or shift light setup that can handle it and it will all come good. Basically the grind isnt suited to the early manifold.

 

_________________

Just 'invested?' in an EB11 ghia 5.0 wagon. time to play....

Top
 Profile  
 
 
Posted: Tue Mar 21, 2006 8:28 pm 
Fordmods Newbie
Offline

Posts: 12

Joined: 10th Mar 2006

Ride: EA

Location: Adelaide
SA, Australia

well... i put the standard cam back in it.... made sure all the timing is PERFECT... it's got more power then when it had the xr cam but it still doesn't have what it had... before i put it all back together i had one of my mechanic mates to go over it he said it was spot on with all the timing... what can i do to get the power back? was the cam originally out of place to begin with? if so, what way? ign timing could that have been out a bit causing the added power? and if i can get my hands on an EB XR6 cam, would that give me more power?

Cheers,
Chris...



P.S. i have ready access to the BBM and ECU's but i dont care what dino's say, they can be programmed by any moron to say what the owner of the car wants to hear, you want to know the difference between mods? take it on the track or street... and do 0-*kph tests... it's the only way to do it effectively! all i know so far is that my 0-80Kph time has dropped around a second or two

 

_________________

Brakes only slow you down!

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 2 of 2  [ 23 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: No registered users and 34 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 8:19 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names