Fordmods Logo

EL running rough 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: EL running rough
Posted: Sat Mar 15, 2008 2:25 pm 
Parts Gopher
Offline

Posts: 83

Joined: 9th May 2006

Ride: 98 EL XR6

Location: Mildura
VIC, Australia

i recently got an el xr6 - picked up pretty cheap coz i found a few probs with it while looking at it - and it actually goes really well considering the past owner treated it like s**t and the fact that i paid 7K 4 it.

any way it starts fine goes really well but has a really rough idle, almost like it has a vacuum leak some where... but it only does this when the car is warm.

i read a post that some1 had the same dramas but couldnt resolve it, jus wondering if ne1 has ne ideas

 

_________________

'98' EL XR6 Pacemaker headers, 2 1/2 inch (header back) exhaust with Hi-Flow CAT, IC&E coil and 9mm leads, NGK plugs, billet short throw shifter >147.9rwKw

'91' EB GL Custom cold air intake with K&N pod filter

Top
 Profile  
 
 
Posted: Sat Mar 15, 2008 2:42 pm 
Smokin em up
Offline

Age: 36

Posts: 210

Joined: 14th May 2005

Location: Perth
WA, Australia

Hi There,

Check the vaccume tree at the rear of the manifold and also the one under the throttle body.
Ive found with my el if I disconnect a vaccume hose the engine will idle high.
If all your hoses are good give it a service.
New Plugs, Leads, Dist Cap and Rotor and if its a old car change the ignition coil they start to die strangly and a HEGO (02) Sensor.

If its still running rough give it a stone cold compression test. Then drive it untill it runs rough then compression test it again.
Top
 Profile  
 
 
Posted: Sat Mar 15, 2008 3:41 pm 
Getting Side Ways
Offline

Age: 30

Posts: 1087

Joined: 1st Sep 2007

Ride: '07 LT XR5

Power: 133 rwkw

Location: sydney
NSW, Australia

ive had mine serviced quite a few times since getting mine, his new sparkies (iridiums) and new 02 sensor, but it still has a little gitter to it, i think the engines are just like that...

 

_________________

So much RAM the motherboard twisted off the POST.

I lost 3 cylinders... but gained a turbo...
Proud owner of an '07 XR5Turbo

Top
 Profile  
 
 
Posted: Sun Mar 16, 2008 4:37 pm 
Parts Gopher
Offline

Posts: 83

Joined: 9th May 2006

Ride: 98 EL XR6

Location: Mildura
VIC, Australia

sounds simple enough... how much would a new dist cap, rotor and O2 sensor cost me roughly???

im getting a new exhaust system - the works extractors, cat, new piping etc - next week, u think that would help at all???

 

_________________

'98' EL XR6 Pacemaker headers, 2 1/2 inch (header back) exhaust with Hi-Flow CAT, IC&E coil and 9mm leads, NGK plugs, billet short throw shifter >147.9rwKw

'91' EB GL Custom cold air intake with K&N pod filter

Top
 Profile  
 
 
Posted: Mon Mar 17, 2008 9:08 am 
Getting Side Ways
Offline

Age: 30

Posts: 1087

Joined: 1st Sep 2007

Ride: '07 LT XR5

Power: 133 rwkw

Location: sydney
NSW, Australia

02 sensor, once again depends where u get it from, but its about $80 new from bosch retailer.

and the exhaust will help it breathe a lot better there is no doubt, but as far as idle goes i'd say it wont have a big impact on it.

 

_________________

So much RAM the motherboard twisted off the POST.

I lost 3 cylinders... but gained a turbo...
Proud owner of an '07 XR5Turbo

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 28 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 3:57 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names