Fordmods Logo

EL tickford motor wont idle properly. 

 

Page 1 of 2 [ 23 posts ] Go to page 1, 2  Next

 
 Post subject: EL tickford motor wont idle properly.
Posted: Sun Sep 28, 2008 9:53 pm 
Tyre Shredder
Offline
User avatar

Age: 29

Posts: 312

Joined: 4th Oct 2007

Gallery: 8 images

Ride: AU XR8 220 Series 2

Location: Melbourne
VIC, Australia

Hey guys,

Yes ive put an EL tickford motor in my EB at the start of this year the motors runs beautiful it just doesn't idle to well. I am sure it is the ISC motor.

When i first started the new motor with the EL ISC it idled smooth but run up 1200-1300rpm and wouldnt come down. So i put my old ISC off my EB motor and i lowered it 850-900rpm but jumps up and down (hunting?). When take it for a drive n the pull up and stick it in Park its runs up to 1200 and doesn't come down till it turn it off.

I had a spare EB ISC and tried that it was worse wouldn't idle just stall.

Ived tried reseting the ISC, ive adjusted the base igniting timing etc. no success!

most of the time it will idle nice at 900rpm at the lights but sometimes stalls when it jumps around, airconditioner is a big no no when at the lights it stalls.

Also yesterday i was drive n i did a donut (not on a public road) heaps of smoke sweet :lol: then i reversed and it stalled. Started it and drove 1km and slowed down to 30kmh and just stalled :( n did it again 3 times it got back and dropped the battery off to make the computer lose it info and started it again n it run again no stalls when driving but yeh does the gay idle thing.

Ive taking to my mate at Delatite ford in Benalla when i was there, for them to tune it n fix it but they didn't :cry: - Useless but good blokes.

At a loss guys any help would be much appreciated, im pretty busy with uni an all but il try to be on here as much as i can n have ago at any ideas if i can myself time permitting.

Thanks guys :)

 

_________________

EB 1 Fairmont - SOLD
BA XR6 MKII - KIA
AU 2 XR8 220 - Stock - Silhouette, 5spd man.

Last edited by commandojones on Tue Sep 30, 2008 6:19 pm, edited 1 time in total.

Top
 Profile  
 
 
Posted: Sun Sep 28, 2008 10:25 pm 
Getting Side Ways
Offline
User avatar

Age: 29

Posts: 721

Joined: 31st Dec 2005

Ride: EF V8 Futura, 180sx

Location: Brisbane, Burpengary
QLD, Australia

warm your engine up to operating condition and set your base idle to 700-800 with the ISC disconnected and then turn car off and plug back up and try car like that is still continues suggest checking for vac leaks or timing or injectors or air filter or fuel filer, plugs(CONDITION/GAPS)

 

_________________

Ford EF Futura Black
18" koya Strykers, AU engine with port and polish EB head, crow valve springs, standard cam, Large aftermarket RX7 turbo, T5 manual 3" intercooler piping, 600x300x100 intercooler core, MSII with innovate wideband O2 sensor and guage. BA F6 bodykit

Top
 Profile  
 
 
Posted: Mon Sep 29, 2008 7:53 am 
Tyre Shredder
Offline
User avatar

Age: 29

Posts: 312

Joined: 4th Oct 2007

Gallery: 8 images

Ride: AU XR8 220 Series 2

Location: Melbourne
VIC, Australia

ok will do again, i have new plugs and leads. the climate control works aswell as cruise so i think there is no vac leaks but il check, my old man thinks its the fuel filter, i have had these injectors cleaned professinaly cleaned last year.

Thanks mate

 

_________________

EB 1 Fairmont - SOLD
BA XR6 MKII - KIA
AU 2 XR8 220 - Stock - Silhouette, 5spd man.

Top
 Profile  
 
 
Posted: Tue Sep 30, 2008 7:22 am 
Getting Side Ways
Offline
User avatar

Age: 29

Posts: 721

Joined: 31st Dec 2005

Ride: EF V8 Futura, 180sx

Location: Brisbane, Burpengary
QLD, Australia

yer u could do fuel filter as well and maybe try el isc and reset the idle

 

_________________

Ford EF Futura Black
18" koya Strykers, AU engine with port and polish EB head, crow valve springs, standard cam, Large aftermarket RX7 turbo, T5 manual 3" intercooler piping, 600x300x100 intercooler core, MSII with innovate wideband O2 sensor and guage. BA F6 bodykit

Top
 Profile  
 
 
Posted: Tue Sep 30, 2008 6:17 pm 
Tyre Shredder
Offline
User avatar

Age: 29

Posts: 312

Joined: 4th Oct 2007

Gallery: 8 images

Ride: AU XR8 220 Series 2

Location: Melbourne
VIC, Australia

Hi Xflow, yeh i reset the idle speed following my Gregorys Manual exactly the engine idles beautifully with the ISC disconnected and sound deep too. I adjusted it 850rpm n let it idle for 1min as it said then turned it off and started again and readjusted the idle down to 600rpm as in the book and reconnected the ISC. The ISC screws my sweet idle up its gay it idles at 1300rpm n sounds gay too. Could i drive it with idle set at 900rpm with the ISC disconnected? probably stall with A/C etc.

Other thing mate how would you check for vac leaks. i can't see, feel or hear any leaks.

Would a Repco fuel filter be OK you think? I used to buy all my parts from my mate at ford at less than trade prices, but im in melb now and dont have such contacts.

Cheers Mate your a good Bloke! :wink:

 

_________________

EB 1 Fairmont - SOLD
BA XR6 MKII - KIA
AU 2 XR8 220 - Stock - Silhouette, 5spd man.

Top
 Profile  
 
 
Posted: Tue Sep 30, 2008 6:18 pm 
Tyre Shredder
Offline
User avatar

Age: 29

Posts: 312

Joined: 4th Oct 2007

Gallery: 8 images

Ride: AU XR8 220 Series 2

Location: Melbourne
VIC, Australia

Oh yeh forgot, my EL ISC is in Wangaratta so i can't toy with that at the moment- Damn!!!!!!

 

_________________

EB 1 Fairmont - SOLD
BA XR6 MKII - KIA
AU 2 XR8 220 - Stock - Silhouette, 5spd man.

Top
 Profile  
 
 
Posted: Tue Sep 30, 2008 7:10 pm 
Getting Side Ways
Offline
User avatar

Age: 29

Posts: 721

Joined: 31st Dec 2005

Ride: EF V8 Futura, 180sx

Location: Brisbane, Burpengary
QLD, Australia

yer repco fuel filters are fine(make sure it the one for ef/el) it should be tin with a nut at each end and goes just before the diff on the left hand side. they do tend to rust the thread together so if you have use a pipe spanner and use some spray lube to help crach the seal without stripping the nuts


i know a few people drive without ISC but engine will stall if you turn the steering wheel or turn ac on.

try removing the ISC valve and and spraying the inside with some carby cleanner and see if the valve can close with a light up the hole. might be some carbon on the ISC valve stopping it from closing

now i can go and tend to my issue from on the way home from work 2 relays dieing on my engine and the engine cuts out while driving. nasty little bugger

 

_________________

Ford EF Futura Black
18" koya Strykers, AU engine with port and polish EB head, crow valve springs, standard cam, Large aftermarket RX7 turbo, T5 manual 3" intercooler piping, 600x300x100 intercooler core, MSII with innovate wideband O2 sensor and guage. BA F6 bodykit

Top
 Profile  
 
 
Posted: Tue Sep 30, 2008 7:27 pm 
Tyre Shredder
Offline
User avatar

Age: 29

Posts: 312

Joined: 4th Oct 2007

Gallery: 8 images

Ride: AU XR8 220 Series 2

Location: Melbourne
VIC, Australia

OK mate get to Repco soon thanks for the heads up, i ahve sprayed carby clearner in it b4 but im gonna chek the ISC like you said. Goood luck with your relays bud. Thanks

 

_________________

EB 1 Fairmont - SOLD
BA XR6 MKII - KIA
AU 2 XR8 220 - Stock - Silhouette, 5spd man.

Top
 Profile  
 
 
Posted: Tue Sep 30, 2008 11:24 pm 
Getting Side Ways
Offline

Age: 42

Posts: 1343

Joined: 14th Dec 2007

Gallery: 1 images

Ride: EL fairmont offroader

Location: seaspray
VIC, Australia

To my knowledge when troyman put an AU motor in his EA using an EA or EB ISC, he fitted a gasket with smaller holes in order to make it idle properly.

 

_________________

wrecking 9/97 EL fairmont sedan burgundy 6cyl auto 270k modBAintake

Top
 Profile  
 
 
Posted: Tue Sep 30, 2008 11:28 pm 
Tyre Shredder
Offline
User avatar

Age: 29

Posts: 312

Joined: 4th Oct 2007

Gallery: 8 images

Ride: AU XR8 220 Series 2

Location: Melbourne
VIC, Australia

Yes it thought ive heard of this being done, ive blocked it rite off no success. Ok i will experiment with it 2morrow.

thanks

 

_________________

EB 1 Fairmont - SOLD
BA XR6 MKII - KIA
AU 2 XR8 220 - Stock - Silhouette, 5spd man.

Top
 Profile  
 
 
Posted: Wed Oct 01, 2008 11:45 am 
Tyre Shredder
Offline
User avatar

Age: 29

Posts: 312

Joined: 4th Oct 2007

Gallery: 8 images

Ride: AU XR8 220 Series 2

Location: Melbourne
VIC, Australia

Ok this morining i put on a gasket with 5mm holes in it, it started and idle nice when it was cold very smooth, took it for a drive damn it goes good on mobil premo, 1km or so i stopped slip in in Neutral n i still idle beautiful on 850-900rpm kept on driving til temp up got home n parked idle went up to 1200rpm (NOOO!!) but it was smooth not jumping around so much, it slowly went down to 1000rpm but hmmm. I thinks its an improvement but its still gay.

Any suggestions? PLEASE

Also Xflow i tried to look inside them damn thing nut i dont realy no what im looking for, tried to seperate the ISC but it didn't want ot budge.

 

_________________

EB 1 Fairmont - SOLD
BA XR6 MKII - KIA
AU 2 XR8 220 - Stock - Silhouette, 5spd man.

Top
 Profile  
 
 
Posted: Wed Oct 01, 2008 11:57 am 
Fordmods Junkie
Offline
User avatar

Posts: 11738

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

Try adjusting the base idle now since you have the different gasket with smaller holes in them.

phong =P~

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
Posted: Wed Oct 01, 2008 12:23 pm 
Getting Side Ways
Offline
User avatar

Age: 38

Posts: 1228

Joined: 5th Mar 2006

Gallery: 25 images

Ride: FALCON EB TURBO, EL XR6

Location: Sydney
NSW, Australia

The ISC is plated off on my EB... not a problem. Turning the steering wheel, a/c, although it is a manual so that probably helps. But yeah without the blocking plate, even with a plate with small holes, the idle still jumped around. so i just plated off the bugger.

 

_________________

FALCAHOLIC

IF AT FIRST YOU DON'T SUCCEED
DESTROY ALL EVIDENCE THAT YOU EVEN TRIED


Image

Top
 Profile  
 
 
Posted: Wed Oct 01, 2008 6:27 pm 
Tyre Shredder
Offline
User avatar

Age: 29

Posts: 312

Joined: 4th Oct 2007

Gallery: 8 images

Ride: AU XR8 220 Series 2

Location: Melbourne
VIC, Australia

ok i will readjust when i get some time, n let you know what goes

Thanks

 

_________________

EB 1 Fairmont - SOLD
BA XR6 MKII - KIA
AU 2 XR8 220 - Stock - Silhouette, 5spd man.

Top
 Profile  
 
 
Posted: Fri Oct 03, 2008 11:55 am 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 845

Joined: 6th Mar 2005

Gallery: 1 images

Ride: Mini Cooper S Supercharged

Location: Sydney
NSW, Australia

Did you get it sorted? If not, check your IAT sensor. Yeah, I know, Weird! I had a similar problem, and it turns out the plug had slipped off my IAT sensor somehow. Plugged it back in and away we go!
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 23 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: Google [Bot] and 20 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 7:30 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names