Fordmods Logo

EL Trip Meter and Odometer problems... 

 

Page 1 of 1 [ 10 posts ] 

 
 Post subject: EL Trip Meter and Odometer problems...
Posted: Mon Apr 04, 2005 5:29 pm 
Oompa Loompa
Offline

Age: 35

Posts: 36

Joined: 15th Mar 2005

Ride: Falcon

Location: Melbourne
VIC, Australia

Has anyone had any problems with their trip meter and odometer?? I noticed the other day that my odometer refuses to go over 150171 k's! keeps resetting itself after i turn the car off. and the damn trip meter resets back to 54.2 k's as well. it is really starting to p*** me off.
any ideas on how to fix it?

 

_________________

those who live by the sword get shot by those who dont

Top
 Profile  
 
 
Posted: Mon Apr 04, 2005 6:16 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 2976

Joined: 5th Nov 2004

Ride: BF Typhoon

Location: Melbourne
VIC, Australia

NO idea on that one..?
Maybe try disconnecting the battery for a while (30min+) to reset everthing.

Sorry, not too much help. :roll:

 

_________________

BF Typhoon, Dejavu - 6sp Auto, Leather, Sunroof, 19"s, Electric Pedals, Tint, FPV Sports Wheel, FPV Mats.

Top
 Profile  
 
 
Posted: Mon Apr 04, 2005 6:18 pm 
Oompa Loompa
Offline

Age: 35

Posts: 36

Joined: 15th Mar 2005

Ride: Falcon

Location: Melbourne
VIC, Australia

yeah i mite give that a try, but doesnt that stuff around with the idle control which takes bloody ages to reset and is a b**ch to drive?

 

_________________

those who live by the sword get shot by those who dont

Top
 Profile  
 
 
Posted: Mon Apr 04, 2005 6:27 pm 
Getting Side Ways
Offline

Age: 36

Posts: 2215

Joined: 5th Nov 2004

Gallery: 17 images

Ride: Oettinger Golf GTI

Location: Sydney
NSW, Australia

Some people would prefer their dash not goin over 150... lol
Top
 Profile  
 
 
 Post subject: Re: EL Trip Meter and Odometer problems...
Posted: Mon Apr 04, 2005 6:34 pm 
Getting Side Ways
Offline
User avatar

Posts: 2644

Joined: 6th Nov 2004

Gallery: 8 images

Ride: 2007

Location: Mount Annan
NSW, Australia

dzynafalcon wrote:
Has anyone had any problems with their trip meter and odometer?? I noticed the other day that my odometer refuses to go over 150171 k's! keeps resetting itself after i turn the car off. and the damn trip meter resets back to 54.2 k's as well. it is really starting to p*** me off.
any ideas on how to fix it?


I assume the odometer counts up past the 150171 but resets to this figure when the car is switched off. If so it sounds like the Eprom in the cluster is faulty or the store and/or recall circuitry is stuffed. Looking at the Eprom schematic you should be able to test the latter if your handy with a multimeter. Pin 7 should go from 5 volts when the car is running to 0 volts to store the data. Pin 6 should drop momentarily to 0 volts when the ignition is turned on to recall the data.
Cheers
TW.

 

_________________

BF Fairmont Ghia Series II update.
GQ XR6T ghia patrol.

,======o00o
//__|__|_,\_____\,___
|_/--\'_|'__|_/--\_[]IIII[]
_( o ) )_____( o ) )=o=) )__

Top
 Profile  
 
 
Posted: Tue Apr 05, 2005 2:23 pm 
Getting Side Ways
Offline
User avatar

Age: 47

Posts: 496

Joined: 11th Nov 2004

Ride: 06 Teritory,mod Capri,XE falcon

Location: Coffs Harbour
NSW, Australia

Yeah,gotta agree with twason.Sounds like your EEPROM has gone AWOL.Try pin test as suggested,otherwise,find a 2nd hand dash with similar kms. to yours and get EEPROM exchanged over.Most TV repair shops,etc can manage this precision solder and best of all,you keep your original dash.Donater dash can be low,mid or high series as all you are after is the EEPROM......

 

_________________

Getting old is a fact,maturing is optional......

Top
 Profile  
 
 
Posted: Tue Apr 05, 2005 3:40 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 844

Joined: 23rd Nov 2004

Gallery: 9 images

Ride: FBT

Location: Nth East
VIC, Australia

Id wait about 50,000km before you get it fixed though :D

 

_________________

"12 yards long, two lanes wide, 65 tonnes of american pride" Fairlane
Image

Top
 Profile  
 
 
Posted: Tue Apr 05, 2005 4:19 pm 
Oompa Loompa
Offline

Age: 35

Posts: 36

Joined: 15th Mar 2005

Ride: Falcon

Location: Melbourne
VIC, Australia

Yeah i dont mind the fact that its not getting any more k's on the clock, but the thing that is really annoying is the trip meter resetting itself. i cant accurately work out kms/fuel, so its a bit of guess work at the moment. i guess i could write down the ks every time i turned the car off, but that would definitely drive me nuts

 

_________________

those who live by the sword get shot by those who dont

Top
 Profile  
 
 
 Post subject: dzynafalcon
Posted: Tue Apr 05, 2005 5:03 pm 
Getting Side Ways
Offline
User avatar

Posts: 2644

Joined: 6th Nov 2004

Gallery: 8 images

Ride: 2007

Location: Mount Annan
NSW, Australia

dzynafalcon wrote:
Yeah i dont mind the fact that its not getting any more k's on the clock, but the thing that is really annoying is the trip meter resetting itself. i cant accurately work out kms/fuel, so its a bit of guess work at the moment. i guess i could write down the ks every time i turned the car off, but that would definitely drive me nuts


Can I get the Eprom if you do change it out, I need an Eprom for a faulty cluster I have.

Cheers
TW.

 

_________________

BF Fairmont Ghia Series II update.
GQ XR6T ghia patrol.

,======o00o
//__|__|_,\_____\,___
|_/--\'_|'__|_/--\_[]IIII[]
_( o ) )_____( o ) )=o=) )__

Top
 Profile  
 
 
Posted: Tue Apr 05, 2005 5:58 pm 
Oompa Loompa
Offline

Age: 35

Posts: 36

Joined: 15th Mar 2005

Ride: Falcon

Location: Melbourne
VIC, Australia

yeah ill let ya know if i replace it. will see how i go getting it fixed first

 

_________________

those who live by the sword get shot by those who dont

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 10 posts ] 

Who is online

Users browsing this forum: No registered users and 21 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 2:05 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names