Fordmods Logo

EL Wagon bit sluggish 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: EL Wagon bit sluggish
Posted: Tue Dec 09, 2008 1:45 pm 
Parts Gopher
Offline

Age: 28

Posts: 73

Joined: 22nd Oct 2006

Ride: '97 Falcon Futura Wagon

Location: Melbourne
VIC, Australia

Hey modders,

My 97 EL Futura wagon seems to be a bit sluggish and am trying to comprehend a reasonable cause.
It has:
- LPG (but seems sluggish on both fuels)
- New plugs, yesterday (to try to fix it)
- Wade 1636 cam
- Pacemaker PH4499 Extractors
- Hi-Flow cat
- 2.5" Redback catback
- K&N Panel

I believe it has a lack of power as my friend's stock EL GLi wagon feels much more powerful and mine once had more power. The tranny is a bit lazy and needs a new S5 solenoid. I've checked the timing and it seems fine.

Any suggestions welcome.
Thanks guys, Pete.

 

_________________

Is the noise in my head bothering you? Because the noise in yours is annoying the s**t out of me.
El Futura Wagon - LPG, Wade 1636, Pacy 4499s, hi-flow cat, 2.5" Redback catback, mild shift kit, Sony HU, VDO 100WRMS Splits, Pioneer 30WRMS Coaxs, Pioneer 12" sub, Audioline 300WPMPO amp.

Top
 Profile  
 
 
Posted: Tue Dec 09, 2008 5:23 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 2477

Joined: 10th Mar 2007

Gallery: 27 images

Ride: 1995 EF Fairmont

Location: Auckland
New Zealand

Definately get the s5 solinoid sorted out first and see how the car goes from there.

Probably a long shot, but maybe a blocked cat or muffler? I know you have a catback and hi flow cat but it could be a possibility

How was the car before and after the cam install? Is the cam dialed in correctly?

 

_________________

Money Talks, But All Mine Ever Says Is Goodbye
EF Fairmont - EFF111 Build Thread

Top
 Profile  
 
 
Posted: Tue Dec 09, 2008 5:27 pm 
Getting Side Ways
Offline

Age: 29

Posts: 2563

Joined: 19th Feb 2007

Gallery: 21 images

Ride: 98 EL Futura

Power: 199 rwkw

Location: Lilydale
VIC, Australia

yeah the trans can rob power if its slipping and as kwikxr said could be the cat. When was the last time you cleaned the K&N filter? they can get pretty blocked up aswell. I would check cat clean filter and reset the ECU and see how it goes.

 

_________________

EL Futura: CVE head, Wolf V500, ICE Ignition and Coil, 36lb injectors, Walbro 255lb, Paci comps, 3" exhaust, T5, Harrop Truetrac with 3.9s. Now with 198.9rwkw, (~185rwkw and 13.80 @99.1mph) with more power to come

Top
 Profile  
 
 
Posted: Wed Dec 10, 2008 12:24 am 
Parts Gopher
Offline

Age: 28

Posts: 73

Joined: 22nd Oct 2006

Ride: '97 Falcon Futura Wagon

Location: Melbourne
VIC, Australia

The exhaust is def not blocked. The cam can only sit in one spot on the sprocket, so I can only assume it's dialled in (and the appropriate shims were installed too). The filter is relatively new, <5,000kms.

Thanks for the replies, I'll get onto the tranny as soon as I can afford it (they're expensive those solenoids).

 

_________________

Is the noise in my head bothering you? Because the noise in yours is annoying the s**t out of me.
El Futura Wagon - LPG, Wade 1636, Pacy 4499s, hi-flow cat, 2.5" Redback catback, mild shift kit, Sony HU, VDO 100WRMS Splits, Pioneer 30WRMS Coaxs, Pioneer 12" sub, Audioline 300WPMPO amp.

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 41 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 11, 2017 8:35 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names