Fordmods Logo

EL wont go 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: EL wont go
Posted: Sun Sep 25, 2011 11:57 pm 
Fordmods Newbie
Offline

Posts: 3

Joined: 25th Sep 2011

Ride: EL Futura

Location: Gold Coast
QLD, Australia

Hi,
I am sure this issue may have been addressed in the past, but I am desperate. Recently bought '97 EL Futura Auto. Going perfectly with just a few minor oil leaks...however..I recently drove it to work and realised upon arriving that I was VERY low on petrol. Had to park it on forward-facing hill. At end of day it refused to start, but sounded exactly like it was out of fuel. Put around 25 litres into it but it still refused to go. Almost kicks over but just refuses to fire. It has now been stuck at my workplace for a week...any suggestions? I am guessing maybe injectors? Can't afford to get a mechanic to look at it for a couple more weeks. Thanks.
Top
 Profile  
 
 
 Post subject: Re: EL wont go
Posted: Mon Sep 26, 2011 12:05 am 
Tyre Shredder
Offline
User avatar

Posts: 326

Joined: 12th Jun 2010

Ride: EL Fairmont

Location: Central Highlands
QLD, Australia

Check the fuel pump, you should hear it turn on before you start the car.

 

_________________

Current ride 2007
ML GLX Dualcab Triton 4x4

Top
 Profile  
 
 
 Post subject: Re: EL wont go
Posted: Mon Sep 26, 2011 12:12 am 
Fordmods Newbie
Offline

Posts: 3

Joined: 25th Sep 2011

Ride: EL Futura

Location: Gold Coast
QLD, Australia

THanks..that's the one thing I did try..and i am pretty sure its ok
Top
 Profile  
 
 
 Post subject: Re: EL wont go
Posted: Mon Sep 26, 2011 12:23 am 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

Fuel filter might be blocked? you did run it close to empty, might have picked up a hell of a lot of dirt.

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
 Post subject: Re: EL wont go
Posted: Mon Sep 26, 2011 12:27 am 
Fordmods Newbie
Offline

Posts: 3

Joined: 25th Sep 2011

Ride: EL Futura

Location: Gold Coast
QLD, Australia

Yeah..will look into that.I had run it very low on fuel a couple of times (still getting used to the way it chews fuel after my little four-cylinder former car!)
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 35 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 5:32 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names