Fordmods Logo

engine cutting out 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: engine cutting out
Posted: Sun May 23, 2010 4:59 pm 
Smokin em up
Offline
User avatar

Age: 27

Posts: 238

Joined: 31st Jan 2008

Gallery: 3 images

Ride: EF

Location: ballarat
VIC, Australia

i have an el fairmont auto and while i was drivin on the highway today my sub made my speakers cut out, then my head unit turned off then the cluster stopped working and the engine cut out. anyone have any ideas?

i also had to jump start it five times within 10 kms to get home

 

_________________

If it has wheels or a skirt, You can't afford it.

Top
 Profile  
 
 
 Post subject: Re: engine cutting out
Posted: Sun May 23, 2010 5:11 pm 
Getting Side Ways
Offline

Age: 27

Posts: 506

Joined: 3rd Sep 2007

Gallery: 18 images

Ride: EF Falcon

Location: Victor Harbor
SA, Australia

checked the fuse??? it think its one of the 15amp ones??? green???

 

_________________

Image
Falcon Build http://www.fordmods.com/post1285079.html#p1285079

Top
 Profile  
 
 
 Post subject: Re: engine cutting out
Posted: Sun May 23, 2010 5:19 pm 
Smokin em up
Offline
User avatar

Age: 27

Posts: 238

Joined: 31st Jan 2008

Gallery: 3 images

Ride: EF

Location: ballarat
VIC, Australia

yeah mate checked all the fuses, my mate put the battery terminals on backwards last night might have somethin to do with it? also starts when jumpstarted for about a min then does the same thing

 

_________________

If it has wheels or a skirt, You can't afford it.

Top
 Profile  
 
 
 Post subject: Re: engine cutting out
Posted: Sun May 23, 2010 5:28 pm 
Getting Side Ways
Offline

Age: 27

Posts: 506

Joined: 3rd Sep 2007

Gallery: 18 images

Ride: EF Falcon

Location: Victor Harbor
SA, Australia

wild_cleveland wrote:
yeah mate checked all the fuses, my mate put the battery terminals on backwards last night might have somethin to do with it? also starts when jumpstarted for about a min then does the same thing



hmmmm.... yeah this is out of my league then. :?

 

_________________

Image
Falcon Build http://www.fordmods.com/post1285079.html#p1285079

Top
 Profile  
 
 
 Post subject: Re: engine cutting out
Posted: Sun May 23, 2010 6:21 pm 
Stock as a Rock
Offline

Age: 33

Posts: 141

Joined: 17th Jun 2006

Ride: Falcon

Location: canberra
ACT, Australia

Is the battery charging? Sounds like he fried the alt wiring, possibly even killed the alternator. I had a bloke hook up the wires on his battery wrong on his camry a few months ago and fried the alternator and the wiring from the alt to the battery. i'd check that to start off.

 

_________________

Fords Rule. OK.

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum
cron

 

 

It is currently Wed Dec 13, 2017 3:18 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names