Fordmods Logo

Engine dies and something squealing LOUD (EA FALC) 

 

Page 1 of 1 [ 6 posts ] 

 
 Post subject: Engine dies and something squealing LOUD (EA FALC)
Posted: Thu Jul 26, 2007 12:17 am 
Parts Gopher
Offline

Age: 29

Posts: 96

Joined: 18th Apr 2007

Gallery: 2 images

Ride: Fairmont Ghia

Power: 104 rwkw

Location: Perth
WA, Australia

ok well ive had the battery out for a fair while after i lost 2 belts (power steering and alternator) i know, i know, should have been replaced within a week if not 2 days but im lazy and there were a few rounded bolts to replace...

anyways ive fixed her all up and ive noticed that whilst driving i will clutch and the revs drop right off, battery light comes on as if the car is dead, until i put it back into gear of course...only once i put it back into gear there is a really REALLY loud squealing sound (also hear it when i start her up)

now at first i was thinking it was the belts i just replaced but they seem alright, im now starting to think its maybe a bearing or something, maybe in the clutch fan (the big a*** ugly white fan hanging off the front of the engine, not sure what its called) but yeh, if its that it will be simple because i have some thermos to put in so im not too fussed

any help is greatly appreciated, cheers Tilly

edit: oh i also assume the revs are dropping off because the ECU is relearning the car but i havent done anything to it so i dont see why it should have such a dramatic drop in revs with clutch right in

 

_________________

Image

Dont ban high performance cars...Ban low performance drivers

Top
 Profile  
 
 
Posted: Thu Jul 26, 2007 1:37 am 
Technical Contributor
Offline
User avatar

Age: 53

Posts: 5589

Joined: 14th Jan 2005

Gallery: 10 images

Ride: 96 XH/97 EL

Location: South Coast
NSW, Australia

Sounds like the car is stalling due to too low idle speed. I also get the impression the car has been sitting without use for a while.
I'd be checking the ISC, and also check and adjust idle speed.

Still sounds like your belts are slipping - take them all off and start the car for a few minutes - if no squeal on startup, that'll be your problem.
Put them on one by one, until your squeal returns, that'll show you which one (if not a couple) is the culprit.

 

_________________

96 XH Longreach 'S': LPG, Alarm, 3.23:1 LSD, Cruise, Trip Comp, ABS, Power Windows, Mid Series Dome Lt, Climate Ctrl
97 EL Futura S/W: LPG, Alarm, LED int Lts, Trip Comp, F/Lane Dome Lt, Climate Ctrl, T5 Conversion

Top
 Profile  
 
 
Posted: Thu Jul 26, 2007 2:09 pm 
Smokin em up
Offline
User avatar

Posts: 262

Joined: 5th Nov 2006

Location: wilcannia
NSW, Australia

the alternator belt seems to need to be done uplike a guitar string to not squeal. it is the most likely culprit.

 

_________________

vote for pedro ? f**k pedro, f**k him up his stupid a***hole.

Top
 Profile  
 
 
Posted: Thu Jul 26, 2007 2:15 pm 
Smokin em up
Offline

Age: 35

Posts: 296

Joined: 16th Oct 2006

Ride: 94 EF (OPT20), TF Cortina Ghia

Location: Bendigo
VIC, Australia

give your belts a hit with "Belt Grip" get at any auto shop around $15 a spray can. its green. goes a long way. makes belts stick to pulley like you know what to a blanket.

 

_________________

"Look I found tape, I'm a mechanic now!!!" Mike Teutul

Top
 Profile  
 
 
Posted: Thu Jul 26, 2007 8:39 pm 
Tyre Shredder
Offline

Posts: 330

Joined: 26th Apr 2006

Location: rockingham
WA, Australia

you gotta basically hang off the alternator to make sure its tight, and yeh, your idle speed has always been low. If yah want, i can fix it sat?
Top
 Profile  
 
 
Posted: Thu Jul 26, 2007 9:03 pm 
Parts Gopher
Offline

Age: 29

Posts: 96

Joined: 18th Apr 2007

Gallery: 2 images

Ride: Fairmont Ghia

Power: 104 rwkw

Location: Perth
WA, Australia

cheers guys, yeh moods if ya wanna have a look, im still also thinking it MIGHT be the clutch fan, on closer inspection it looks out of line, and i remember back to when i lost both the belts that the car made the same noise...strange, but yeh ill check all my belts again, spray some of that stuff on em and try her out

cheers again, ill give u all the results after the weekend :D

 

_________________

Image

Dont ban high performance cars...Ban low performance drivers

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 26 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 9:29 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names