Fordmods Logo

engine mount keeps breaking 

 

Page 1 of 2 [ 21 posts ] Go to page 1, 2  Next

 
 Post subject: engine mount keeps breaking
Posted: Sun May 17, 2009 8:58 pm 
Getting Side Ways
Offline

Age: 27

Posts: 1323

Joined: 12th Nov 2006

Gallery: 9 images

Ride: 02 xls ute 347

Location: adelaide
SA, Australia

i replaced my broken engine mount about 2 months ago and now it has broken again is this s common problem in manual falcons its the engine mount on the left side the hard one to get to.
I dont want to have to keep changing it every 2 months is there any sort of brand of engine mount people recommend or maybe even use a solid metal one?

 

_________________

02 series 3 AU marline ute 5speed 347 stroker

Top
 Profile  
 
 
 Post subject: Re: engine mount keeps breaking
Posted: Sun May 17, 2009 10:02 pm 
Oompa Loompa
Offline

Posts: 28

Joined: 16th Apr 2009

Ride: EL Fairmont

Location: Perth
WA, Australia

I've heard good things about the durability of custom urethanes if you can find someone to do them up for you...
Top
 Profile  
 
 
 Post subject: Re: engine mount keeps breaking
Posted: Sun May 17, 2009 10:12 pm 
Fordmods Newbie
Offline

Posts: 17

Joined: 11th Aug 2007

Location: melbourne
VIC, Australia

how hard you driving it? my manuel EL hasn't broken an engine mount in the two year i've had it, i've seen people put bolts throught the engine mount or weld steel chain the the outside of the mount. both work well, just depends what tools you have access too.
Top
 Profile  
 
 
 Post subject: Re: engine mount keeps breaking
Posted: Sun May 17, 2009 10:15 pm 
Getting Side Ways
Offline

Age: 33

Posts: 6746

Joined: 13th Mar 2006

Gallery: 10 images

Ride: NCII Fairlane

Location: Bathurst
NSW, Australia

ea_falcon wrote:
i replaced my broken engine mount about 2 months ago and now it has broken again is this s common problem in manual falcons its the engine mount on the left side the hard one to get to.
I dont want to have to keep changing it every 2 months is there any sort of brand of engine mount people recommend or maybe even use a solid metal one?


what car? what engine? what mounts?

Can i suggest if you are using like EA to ED mounts have you thought about upgradeing if you will to el / au round type ones.

 

_________________

R.I.P Tobias my son.

Top
 Profile  
 
 
 Post subject: Re: engine mount keeps breaking
Posted: Mon May 18, 2009 6:59 pm 
Getting Side Ways
Offline

Age: 27

Posts: 1323

Joined: 12th Nov 2006

Gallery: 9 images

Ride: 02 xls ute 347

Location: adelaide
SA, Australia

its an ea falcon 6 cyl 5spd
i drive my car pretty hard untill last night when i crashed it (spun out hit a g\utter and my front left wheel ripped of :( but it should be back on the road in 3 or so days

putting a bolt through it sounds like a good idea because correct me if im wrong but is the rubber only held onto the metal by glue?
is it possible to use the ef and onwards engine mounts on the earlier e series falcons
cheers

 

_________________

02 series 3 AU marline ute 5speed 347 stroker

Top
 Profile  
 
 
 Post subject: Re: engine mount keeps breaking
Posted: Mon May 18, 2009 7:07 pm 
Getting Side Ways
Offline

Age: 33

Posts: 6746

Joined: 13th Mar 2006

Gallery: 10 images

Ride: NCII Fairlane

Location: Bathurst
NSW, Australia

ea_falcon wrote:
its an ea falcon 6 cyl 5spd
i drive my car pretty hard untill last night when i crashed it (spun out hit a g\utter and my front left wheel ripped of :( but it should be back on the road in 3 or so days

putting a bolt through it sounds like a good idea because correct me if im wrong but is the rubber only held onto the metal by glue?
is it possible to use the ef and onwards engine mounts on the earlier e series falcons
cheers


AFAIK yes you can use EF to AU round ones as they are interchangable.

 

_________________

R.I.P Tobias my son.

Top
 Profile  
 
 
 Post subject: Re: engine mount keeps breaking
Posted: Mon May 18, 2009 7:44 pm 
Tyre Shredder
Offline
User avatar

Posts: 350

Joined: 23rd May 2008

Ride: AU series 1 XR6

Location: hartley
SA, Australia

put a bolt or 2 through it
even on the broken 1

ive done it b4 and it works well
Top
 Profile  
 
 
 Post subject: Re: engine mount keeps breaking
Posted: Mon May 18, 2009 7:45 pm 
Technical Contributor
Offline
User avatar

Age: 38

Posts: 4093

Joined: 20th Mar 2005

Gallery: 2 images

Ride: 2.0 Turbo VW

Power: 142 rwkw

Location: Seaford State:
VIC, Australia

Meh, I'm on my third Drivers Engine mount :/


May change to EL ones. see how that goes.

 

_________________

Carefree, we may not be number one, but we're up there.

Top
 Profile  
 
 
 Post subject: Re: engine mount keeps breaking
Posted: Mon May 18, 2009 11:12 pm 
Getting Side Ways
Offline

Age: 27

Posts: 1323

Joined: 12th Nov 2006

Gallery: 9 images

Ride: 02 xls ute 347

Location: adelaide
SA, Australia

are the el ones alot stronger or would it be worth putting a bolt through them as well
its amazing how much power i have lost from the broken engine mount from getting no traction in second gear to having it just do cherpies

 

_________________

02 series 3 AU marline ute 5speed 347 stroker

Top
 Profile  
 
 
 Post subject: Re: engine mount keeps breaking
Posted: Mon May 18, 2009 11:41 pm 
Tyre Shredder
Offline
User avatar

Posts: 350

Joined: 23rd May 2008

Ride: AU series 1 XR6

Location: hartley
SA, Australia

honesly it only takes a few mins to put in a bolt and will give you the security. I know you dont have this kind of power but on our hotrod we made like slides inside the rubber on the mounts so it can move in and out but not sideways too much.
Top
 Profile  
 
 
 Post subject: Re: engine mount keeps breaking
Posted: Tue May 19, 2009 12:23 am 
Getting Side Ways
Offline

Posts: 5582

Joined: 20th May 2005

Gallery: 11 images

Ride: EB1 Fairmont Ghia T5 Wagon

Location: Seven Hills, Sydney
NSW, Australia

You can't use the EF/EL type engine mount on an EA-ED engine.

They are very different, and will not fit due to the different K Frames used.

I would also suggest the bolt through the mount. I may have to look at this myself.

BenJ

 

_________________

BenJ's EB T5 DOHC Ghia Wagon - Current Ride
BenJ's EB GL Sedan - Previous Ride
My respect and thanks go to - snap0964, Paulmac, SWC and MRE-50L

Top
 Profile  
 
 
 Post subject: Re: engine mount keeps breaking
Posted: Tue May 19, 2009 12:31 am 
Getting Side Ways
Offline

Age: 33

Posts: 6746

Joined: 13th Mar 2006

Gallery: 10 images

Ride: NCII Fairlane

Location: Bathurst
NSW, Australia

BenJ wrote:
You can't use the EF/EL type engine mount on an EA-ED engine.

They are very different, and will not fit due to the different K Frames used.

I would also suggest the bolt through the mount. I may have to look at this myself.

BenJ


Hmm I thought they were a swap over, because when i worked at the local wreckers I was asked to check the mounts on EA to ED EF to EL and AU. We concluded that they all would fit because all sat flush on each k frame the only thing we discovered was the mounting points on the block are essentially a deferent design same bolt pattern but different.

 

_________________

R.I.P Tobias my son.

Top
 Profile  
 
 
 Post subject: Re: engine mount keeps breaking
Posted: Tue May 19, 2009 12:43 am 
Getting Side Ways
Offline

Posts: 5582

Joined: 20th May 2005

Gallery: 11 images

Ride: EB1 Fairmont Ghia T5 Wagon

Location: Seven Hills, Sydney
NSW, Australia

Well, I had to remove the EL mounts off my EL block and fit the EB mounts to it so it would go into the EB Wagon.

BenJ

 

_________________

BenJ's EB T5 DOHC Ghia Wagon - Current Ride
BenJ's EB GL Sedan - Previous Ride
My respect and thanks go to - snap0964, Paulmac, SWC and MRE-50L

Top
 Profile  
 
 
 Post subject: Re: engine mount keeps breaking
Posted: Tue May 19, 2009 12:48 am 
Getting Side Ways
Offline

Age: 33

Posts: 6746

Joined: 13th Mar 2006

Gallery: 10 images

Ride: NCII Fairlane

Location: Bathurst
NSW, Australia

BenJ wrote:
Well, I had to remove the EL mounts off my EL block and fit the EB mounts to it so it would go into the EB Wagon.

BenJ


Well I am confused lol

Didn't the EF to EL go from the square to round mounts? I don't know :P

Just put a bloody bolt thru it and be done with it. :P

Back on topic somewhat have you replaced both left and right at the same time or one at random times?

 

_________________

R.I.P Tobias my son.

Top
 Profile  
 
 
 Post subject: Re: engine mount keeps breaking
Posted: Tue May 19, 2009 12:58 am 
Getting Side Ways
Offline

Age: 32

Posts: 1112

Joined: 18th Jan 2005

Location: MAFFRA
VIC, Australia

my ol ea with stage 3 crow cams kit,manual ect kept breaking mounts,i always put urethane ones in like 1 every week.one friday night one broke so i put in an old factory ford one i had in a shell,and it never let go.so id say put a genuine ford one in if you havent already.

 

_________________

97 el xr6,5 speed short shifter,sequential scoop,no arial,freshly resprayed,low on 17's,3 inch zorst,stainless hi flo cat,snort stage 3 stainless manifold,garrett t04e,front mount cooler,wolf 3d ecu,seimens 760cc injectors,walbro fuel pump

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 21 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: Google [Bot] and 20 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 19, 2017 2:01 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names