Fordmods Logo

Engine troubles 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: Engine troubles
Posted: Tue Jun 17, 2008 10:44 pm 
Getting Side Ways
Offline
User avatar

Age: 41

Posts: 3785

Joined: 5th Nov 2004

Ride: Ford

Location: Victoria
VIC, Australia

This arvo my ED wouldn't start.....It turns but doesn't fire. It had a new fuel pump fitted a few months ago so I don't think it's that. All the leads are in top condition.
Any suggestions?

 

_________________

Image

Top
 Profile  
 
 
Posted: Tue Jun 17, 2008 10:56 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 2288

Joined: 4th Dec 2004

Ride: '98 EL Fairmont

Location: Melbourne
VIC, Australia

CRT_LMP fuse in the fuse box.

 

_________________

Image

Top
 Profile  
 
 
Posted: Tue Jun 17, 2008 11:00 pm 
Getting Side Ways
Offline
User avatar

Age: 41

Posts: 3785

Joined: 5th Nov 2004

Ride: Ford

Location: Victoria
VIC, Australia

Checked all the fuses......All good in that department (It's the first thing I checked). It wants to start but it just won't. Any chance of it being an electrical problem?

 

_________________

Image

Top
 Profile  
 
 
Posted: Wed Jun 18, 2008 11:07 pm 
Getting Side Ways
Offline
User avatar

Age: 41

Posts: 3785

Joined: 5th Nov 2004

Ride: Ford

Location: Victoria
VIC, Australia

I checked a few more things this morning and I found there is no spark so I'm thinking it might be the module in the distributor or maybe the coil has s**t itself. So I've decided to get a new distributor. Coil and plugs fitted by the mechanic (It might not be cheap but buggered if I'm gonna stuff around trying to replace stuff thats hidden by the inlet manifold) lol.
The mechanic is gonna check the car over and give me a call tomorrow to let me know what the problem is.

 

_________________

Image

Top
 Profile  
 
 
Posted: Fri Jun 20, 2008 12:28 pm 
Getting Side Ways
Offline
User avatar

Age: 45

Posts: 3440

Joined: 23rd Dec 2007

Gallery: 32 images

Ride: BA XR6T (mix of BA, BF and FG)

Location: Perth
WA, Australia

Check your fusable links as well.

Get yourself a test light and test power on all the smaller wires running to the positive terminal on the battery..

Then that happened to me, it was one of those that had died.
Top
 Profile  
 
 
 Post subject: coil
Posted: Fri Jun 20, 2008 12:56 pm 
Getting Side Ways
Offline

Posts: 652

Joined: 31st Aug 2007

Gallery: 1 images

Ride: 08 BF Ghia

Location: Melbourne
VIC, Australia

My money would be on coil
Top
 Profile  
 
 
Posted: Fri Jun 20, 2008 1:12 pm 
Getting Side Ways
Offline
User avatar

Age: 41

Posts: 3785

Joined: 5th Nov 2004

Ride: Ford

Location: Victoria
VIC, Australia

I'm thinking coil too. The dizzy seems to be in good shape with no play in the shaft or anything, So hopefully it is just the coil.
I checked all the wires running to the positive terminal and all are good.
I might as well replace the plugs while I'm at it too because the plugs are getting a little old now.
Any recommendations on plugs?

 

_________________

Image

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 20 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 19, 2017 12:44 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names