Fordmods Logo

Engines A Pig 


Page 1 of 1 [ 1 post ] 

 Post subject: Engines A Pig
Posted: Wed Dec 07, 2005 1:36 pm 
Fordmods Newbie

Age: 29

Posts: 5

Joined: 25th Jul 2005

Gallery: 6 images

Ride: EL Falcon XR6

Location: Sydney
NSW, Australia

gday guys,

need a little assistance..
ive been having an issue with my engine its running like a pig.
it tends to not want to idle sometimes as it drops from 750rpm to 500rpm back up to 1000rpm and so on. then when im actually driving the car it lacks in acceleration and if i plant it it accelerates lacking and the revs sort of bounce up through the gears. WHile doing this it makes this sort of brumming noise through the exhaust system. its also has a misfire everynow and then but i have replaced plugs and leads.
ive sent it to mechanics and as the usual thing that happens it wouldnt do the problem while he had it, but as soon as i get it back it does it.

Im trying to work out whats my best line of attack.
do i get injectors cleaned
timing switch
anyone ever had a similiar problem and if so did you find out what causes it.

If anyone could help me out with some info it would be awesome and less costly..

thanks guys





Display posts from previous:
Sort by  
 Page 1 of 1  [ 1 post ] 

Who is online

Users browsing this forum: MSNbot Media and 20 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Thu Oct 27, 2016 6:07 pm All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names