Fordmods Logo

Flat Spot is giving me the sh*ts! 

 

Page 1 of 2 [ 26 posts ] Go to page 1, 2  Next

 
 Post subject: Flat Spot is giving me the sh*ts!
Posted: Mon Mar 31, 2008 8:06 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 5889

Joined: 2nd Mar 2006

Gallery: 5 images

Ride: '14 Grand Cherokee

Location: Port Lincoln
SA, Australia

hey guys,

my EL has a tendency to develop a sort of flat spot at about 2800rpm, it will try to rev but wont till i put my foot gradually right down tho the floor, then there will be this massive rush of power (obviously because i put my foot down :P)

i found today that the muffler has a rather large dent in it, possibly from a rock or something, about the size of my fist, pretty much right where the pipe goes into the muffler.

could this be part to blame for my flat spot?

im going to clean the TB and TPS when i can, to see if that sorts things out, but yeah was just wondering if this dent has anything to do with it.

cheers :D

 

_________________

11/93 ED OPT20 GLi | Full Boat Spec

Top
 Profile  
 
 
Posted: Mon Mar 31, 2008 8:23 pm 
Getting Side Ways
Offline

Posts: 6913

Joined: 6th Nov 2004

Gallery: 4 images

Ride: BF XR6, BF XT Wagon

Power: 197 rwkw

Location: Perth
WA, Australia

Quite possibly the dent might have something to do with it. I'd also look at the spark plugs and if any of the leads are damaged to the spark plugs.

I had a sort of hunting effect when one of my leads was damaged on my XR8. I replaced them and the power came back.

How bad is the dent on the muffler?

 

_________________

EL XR8
Timmeh banned himself from being a moderator.

Top
 Profile  
 
 
Posted: Mon Mar 31, 2008 8:28 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 5889

Joined: 2nd Mar 2006

Gallery: 5 images

Ride: '14 Grand Cherokee

Location: Port Lincoln
SA, Australia

Timmeh wrote:
Quite possibly the dent might have something to do with it. I'd also look at the spark plugs and if any of the leads are damaged to the spark plugs.

I had a sort of hunting effect when one of my leads was damaged on my XR8. I replaced them and the power came back.

How bad is the dent on the muffler?

i'll take a picture and put it up for ya.

 

_________________

11/93 ED OPT20 GLi | Full Boat Spec

Top
 Profile  
 
 
Posted: Mon Mar 31, 2008 8:32 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 5889

Joined: 2nd Mar 2006

Gallery: 5 images

Ride: '14 Grand Cherokee

Location: Port Lincoln
SA, Australia

bah cant get a good enough pic in the dark.

it goes about maybe 1 3/4'' deep into the muffler box, pretty much right where the pipe goes in.

----------------_________
| //// _________cat>>
| |
----------------

basically the slants are the area of damage.

 

_________________

11/93 ED OPT20 GLi | Full Boat Spec

Top
 Profile  
 
 
Posted: Mon Mar 31, 2008 8:36 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 5889

Joined: 2nd Mar 2006

Gallery: 5 images

Ride: '14 Grand Cherokee

Location: Port Lincoln
SA, Australia

oops that didnt quite work :P

 

_________________

11/93 ED OPT20 GLi | Full Boat Spec

Top
 Profile  
 
 
Posted: Mon Mar 31, 2008 9:09 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 607

Joined: 15th Dec 2004

Gallery: 23 images

Ride: GLXR 6

Location: Perth
WA, Australia

6 points for effort?

 

_________________

Image

Top
 Profile  
 
 
Posted: Mon Mar 31, 2008 9:09 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 5889

Joined: 2nd Mar 2006

Gallery: 5 images

Ride: '14 Grand Cherokee

Location: Port Lincoln
SA, Australia

another question id like to ask...

are tickford motors supposed to have a cam whine so loud i can hear it above the exhaust and stereo? :?

 

_________________

11/93 ED OPT20 GLi | Full Boat Spec

Top
 Profile  
 
 
Posted: Mon Mar 31, 2008 9:11 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 5889

Joined: 2nd Mar 2006

Gallery: 5 images

Ride: '14 Grand Cherokee

Location: Port Lincoln
SA, Australia

doofus wrote:
6 points for effort?


lol it was all lined up in the "post a reply" screen, just didnt quite end up that way on the thread screen lol

 

_________________

11/93 ED OPT20 GLi | Full Boat Spec

Top
 Profile  
 
 
Posted: Mon Mar 31, 2008 9:11 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 607

Joined: 15th Dec 2004

Gallery: 23 images

Ride: GLXR 6

Location: Perth
WA, Australia

narp...probably a belt?

 

_________________

Image

Top
 Profile  
 
 
Posted: Mon Mar 31, 2008 9:12 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 5889

Joined: 2nd Mar 2006

Gallery: 5 images

Ride: '14 Grand Cherokee

Location: Port Lincoln
SA, Australia

doofus wrote:
narp...probably a belt?


its definately cam whine, its not a sound a belt makes. it sounds awesome though :P

 

_________________

11/93 ED OPT20 GLi | Full Boat Spec

Top
 Profile  
 
 
 Post subject: Re: Flat Spot is giving me the sh*ts!
Posted: Mon Mar 31, 2008 11:19 pm 
Getting Side Ways
Offline
User avatar

Age: 35

Posts: 1775

Joined: 10th Jul 2007

Gallery: 8 images

Ride: BFII Turbo

Power: 253 rwkw

Location: Waurn Ponds
VIC, Australia

alfy wrote:
hey guys,

my EL has a tendency to develop a sort of flat spot at about 2800rpm, it will try to rev but wont till i put my foot gradually right down tho the floor, then there will be this massive rush of power (obviously because i put my foot down :P)


Is it auto or manual? If its manual and you are in the same gear while applying the throttle then that narrows things down. If the engine is hitting 2800 and going nowhere until WOT then you can concentrate around the throttle body/fuel filter&pump/injectors area. also check your accelerator cable, if its damaged in any way it can create a flat sopt.

Im leaning towards clogged injectors or accelerator cable.

 

_________________

enough isn't enough

Top
 Profile  
 
 
Posted: Mon Mar 31, 2008 11:35 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 5889

Joined: 2nd Mar 2006

Gallery: 5 images

Ride: '14 Grand Cherokee

Location: Port Lincoln
SA, Australia

its auto.

 

_________________

11/93 ED OPT20 GLi | Full Boat Spec

Top
 Profile  
 
 
Posted: Mon Mar 31, 2008 11:58 pm 
Fordmods Newbie
Offline

Age: 44

Posts: 9

Joined: 29th Mar 2008

Ride: lowdnes

Location: melbourne
VIC, Australia

alfy wrote:
another question id like to ask...

are tickford motors supposed to have a cam whine so loud i can hear it above the exhaust and stereo? :?



yeah mine does the same i love it if its not hurting the engine im keepin it lol
Top
 Profile  
 
 
Posted: Tue Apr 01, 2008 10:38 am 
Getting Side Ways
Offline
User avatar

Age: 35

Posts: 1775

Joined: 10th Jul 2007

Gallery: 8 images

Ride: BFII Turbo

Power: 253 rwkw

Location: Waurn Ponds
VIC, Australia

alfy wrote:
its auto.


did it kickdown when you went to WOT? I dont know what part of the auto does this but sometimes if the pressure is right on the throttle it doesnt kick down but the revs increase 300 odd rpm, as if there was a gear 3.5... think it might be the torque converter that does this? Dont know much about auto's so clarification would be nice...

 

_________________

enough isn't enough

Top
 Profile  
 
 
Posted: Tue Apr 01, 2008 10:45 am 
Getting Side Ways
Offline

Posts: 6166

Joined: 8th May 2007

alfy wrote:
doofus wrote:
narp...probably a belt?


its definately cam whine, its not a sound a belt makes. it sounds awesome though :P


Stick your ear on the rocker cover above the timing chain and see if its defintely coming from there. Mate you prolly got a snapped plastic chain guide. Get fixed asap as you could have a large chunk of guide floating around the chain which is a catstrophe waiting to happen.

I know mine snapped at the tensioner and the whine was the chain pushing onto the tensioner itself. I also had to dig out half the guide which was sitting next to the chain :shock:
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 26 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 36 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 11:14 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names