Fordmods Logo

Flatspot @ 2500RPM? 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: Flatspot @ 2500RPM?
Posted: Tue Jan 04, 2011 9:23 pm 
Getting Side Ways
Offline

Age: 26

Posts: 1109

Joined: 4th Sep 2009

Ride: 92 EB s

Location: DORRIGO
NSW, Australia

I own a eb series 1 spack 3.9L.
It has a flatspot at 2500rpm. Only really noticable in 2nd gear (5 speed manual)
Any idea on why.
It also has a miss at idle when warm. But only occasionaly. Any idea on that aswell.
Cheers in advance.
Top
 Profile  
 
 
 Post subject: Re: Flatspot @ 2500RPM?
Posted: Tue Jan 04, 2011 9:27 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 3374

Joined: 11th Mar 2008

Ride: EA SVO, AU2 Forte

Location: Bendigo
VIC, Australia

have you changed stuff like fuel filter, plugs etc to combat the miss when warm?

 

_________________

Daily driver: AU2. 5 speed. 19" FG luxos. Full exhaust. Lowered. AU3 XR leather interior, converted to full power windows. 3.45 LSD. IN THE FUTURE: Tickford 6
Weekend driver: EA SVO AU motor. Built BTR. TCE 2800 stall. T76 turbo. Locked diff. On E85. approx 320rwkw. 11.5 @121mph

Top
 Profile  
 
 
 Post subject: Re: Flatspot @ 2500RPM?
Posted: Tue Jan 04, 2011 10:31 pm 
Getting Side Ways
Offline

Age: 26

Posts: 1109

Joined: 4th Sep 2009

Ride: 92 EB s

Location: DORRIGO
NSW, Australia

Yea got new plugs, leads and fuel filter about 3 months ago. Rectified the really bad missing and the breaking down under load. But still has that miss when warm.
Maybe a new distributer cap?
Top
 Profile  
 
 
 Post subject: Re: Flatspot @ 2500RPM?
Posted: Wed Jan 05, 2011 7:39 am 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 3374

Joined: 11th Mar 2008

Ride: EA SVO, AU2 Forte

Location: Bendigo
VIC, Australia

maybe. is it dual fuel?

 

_________________

Daily driver: AU2. 5 speed. 19" FG luxos. Full exhaust. Lowered. AU3 XR leather interior, converted to full power windows. 3.45 LSD. IN THE FUTURE: Tickford 6
Weekend driver: EA SVO AU motor. Built BTR. TCE 2800 stall. T76 turbo. Locked diff. On E85. approx 320rwkw. 11.5 @121mph

Top
 Profile  
 
 
 Post subject: Re: Flatspot @ 2500RPM?
Posted: Wed Jan 05, 2011 9:16 am 
Getting Side Ways
Offline

Age: 26

Posts: 1109

Joined: 4th Sep 2009

Ride: 92 EB s

Location: DORRIGO
NSW, Australia

No its stardard. Run her on shell v-power.
I havnt changed the distributer cap since I've had it. But the miss don't really bug me. Just the flatspot.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 11:53 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names