Fordmods Logo

Ford BA Xr6 Lifter problem 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: Ford BA Xr6 Lifter problem
Posted: Tue Jul 09, 2013 7:14 pm 
Fordmods Newbie
Offline

Age: 25

Posts: 5

Joined: 19th May 2013

Ride: '05 MkII BA Xr6

Location: Adelaide
SA, Australia

Hi, Just did an oil change on my 2005 BA xr6 MkII N/A. now i have a ticking noise when i accelerate.

im thinking it could be the lifters? any ideas.
i changed the to Penrite HPR5 (5W-40) . have been reading that it could have been the oil so i have gone back to the manufactures specs and used 10W-30, Nulon 10W30.

Does any have this same problem or would now how to fix it or if what i have done will fix it?

cheers.
Top
 Profile  
 
 
 Post subject: Re: Ford BA Xr6 Lifter problem
Posted: Tue Jul 09, 2013 8:03 pm 
Moderator
Offline
User avatar

Age: 40

Posts: 2327

Joined: 6th Oct 2005

Ride: 93EB Fairmont / BA Falcon XR6T

Location: Western Sydney
NSW, Australia

I have been using the exact same oil in my BA since we bought it. Also use it in my EB. Never had a problem. Troyman and a few other members on here use Penrite as well with no issues.
Is the ticking constant ? You sure its the engine and not a pulley or something ?

 

_________________

93 EB II Fairmon8 with 17' EL GT's / Clear indicators / H.I.Ds / Sports exhaust / Lowered 2' / K&N / XR6 ECU.
2004 BA MKI XR6T in Lightning Strike paint / K&N / XR8 bonnet / BF lights and a few tweaks.

Top
 Profile  
 
 
 Post subject: Re: Ford BA Xr6 Lifter problem
Posted: Tue Jul 09, 2013 10:35 pm 
Fordmods Newbie
Offline

Age: 25

Posts: 5

Joined: 19th May 2013

Ride: '05 MkII BA Xr6

Location: Adelaide
SA, Australia

only when i accelerate and when i take my foot off its no longer there. as soon as i hit the accelerator again its back.
Top
 Profile  
 
 
 Post subject: Re: Ford BA Xr6 Lifter problem
Posted: Wed Jul 10, 2013 8:30 am 
Moderator
Offline
User avatar

Age: 40

Posts: 2327

Joined: 6th Oct 2005

Ride: 93EB Fairmont / BA Falcon XR6T

Location: Western Sydney
NSW, Australia

Its possible the oil is too thin but being a BA should be fine on 30 or 40. Im using HPR 5 in an EB with high mileage. How many ks on your BA ?

 

_________________

93 EB II Fairmon8 with 17' EL GT's / Clear indicators / H.I.Ds / Sports exhaust / Lowered 2' / K&N / XR6 ECU.
2004 BA MKI XR6T in Lightning Strike paint / K&N / XR8 bonnet / BF lights and a few tweaks.

Top
 Profile  
 
 
 Post subject: Re: Ford BA Xr6 Lifter problem
Posted: Wed Jul 10, 2013 9:24 am 
Fordmods Newbie
Offline

Age: 25

Posts: 5

Joined: 19th May 2013

Ride: '05 MkII BA Xr6

Location: Adelaide
SA, Australia

Only 70, 000kms. Its is really noticeable in the mornibg when it has been sitting all night when I drive through out he day it does get a little bit quieter.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: Google [Bot], Google Adsense [Bot] and 24 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 11:36 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names