Fordmods Logo

fuel pump just been replaced and no power supply to it 

 

Page 1 of 1 [ 9 posts ] 

 
 Post subject: fuel pump just been replaced and no power supply to it
Posted: Wed Nov 03, 2010 1:02 pm 
Getting Side Ways
Offline
User avatar

Age: 25

Posts: 4599

Joined: 30th Aug 2010

Ride: BF XR6,

Location: NEWCASTLE
NSW, Australia

just replaced the pump since it stopped working and realised it isnt getting power, checked the fuses theyre all fine. any ideas what it could be?

 

_________________

BF XR6
xr8 snorkel,typhoon lower snorkel,territory intake pipe,20% underdrive kit,pacemaker extractors,high flow cat,xforce exhaust,t56 conversion hd turbo clutch/ flywheel,m86 3.45 lsd,custom tune187.1rwkw as an auto

Top
 Profile  
 
 
 Post subject: Re: fuel pump just been replaced and no power supply to it
Posted: Wed Nov 03, 2010 1:07 pm 
Getting Side Ways
Offline

Posts: 5582

Joined: 20th May 2005

Gallery: 11 images

Ride: EB1 Fairmont Ghia T5 Wagon

Location: Seven Hills, Sydney
NSW, Australia

Have you checked there is power at the pump end? If not, then there is a break in the wiring between the relay and the pump.

Cheers
BenJ

 

_________________

BenJ's EB T5 DOHC Ghia Wagon - Current Ride
BenJ's EB GL Sedan - Previous Ride
My respect and thanks go to - snap0964, Paulmac, SWC and MRE-50L

Top
 Profile  
 
 
 Post subject: Re: fuel pump just been replaced and no power supply to it
Posted: Wed Nov 03, 2010 1:08 pm 
Getting Side Ways
Offline
User avatar

Age: 25

Posts: 4599

Joined: 30th Aug 2010

Ride: BF XR6,

Location: NEWCASTLE
NSW, Australia

no power, i was just reading where the relay is and could it need a new relay?

 

_________________

BF XR6
xr8 snorkel,typhoon lower snorkel,territory intake pipe,20% underdrive kit,pacemaker extractors,high flow cat,xforce exhaust,t56 conversion hd turbo clutch/ flywheel,m86 3.45 lsd,custom tune187.1rwkw as an auto

Top
 Profile  
 
 
 Post subject: Re: fuel pump just been replaced and no power supply to it
Posted: Wed Nov 03, 2010 1:09 pm 
Getting Side Ways
Offline
User avatar

Age: 25

Posts: 4599

Joined: 30th Aug 2010

Ride: BF XR6,

Location: NEWCASTLE
NSW, Australia

was also just driving on the highway and it cut out instantly if that helps?

 

_________________

BF XR6
xr8 snorkel,typhoon lower snorkel,territory intake pipe,20% underdrive kit,pacemaker extractors,high flow cat,xforce exhaust,t56 conversion hd turbo clutch/ flywheel,m86 3.45 lsd,custom tune187.1rwkw as an auto

Top
 Profile  
 
 
 Post subject: Re: fuel pump just been replaced and no power supply to it
Posted: Wed Nov 03, 2010 1:11 pm 
Getting Side Ways
Offline

Posts: 5582

Joined: 20th May 2005

Gallery: 11 images

Ride: EB1 Fairmont Ghia T5 Wagon

Location: Seven Hills, Sydney
NSW, Australia

Possibly.

What model car is it?

In an E Series it is mounted under the Radiator Overflow bottle on the back of the battery tray. I replaced mine with a normal relay when it died.

BenJ

 

_________________

BenJ's EB T5 DOHC Ghia Wagon - Current Ride
BenJ's EB GL Sedan - Previous Ride
My respect and thanks go to - snap0964, Paulmac, SWC and MRE-50L

Top
 Profile  
 
 
 Post subject: Re: fuel pump just been replaced and no power supply to it
Posted: Wed Nov 03, 2010 1:14 pm 
Getting Side Ways
Offline

Posts: 5582

Joined: 20th May 2005

Gallery: 11 images

Ride: EB1 Fairmont Ghia T5 Wagon

Location: Seven Hills, Sydney
NSW, Australia

Just noticed it is an EF.

The ECU triggers the Fuel Pump relay and if the ECU relay died, then the fuel pump won't trigger either. The ECU Relay is next to the Fuel Pump relay.

How did you determine the fuel pump was the issue in the first place?

PM me your phone number if you want to discuss.

Cheers
BenJ

 

_________________

BenJ's EB T5 DOHC Ghia Wagon - Current Ride
BenJ's EB GL Sedan - Previous Ride
My respect and thanks go to - snap0964, Paulmac, SWC and MRE-50L

Top
 Profile  
 
 
 Post subject: Re: fuel pump just been replaced and no power supply to it
Posted: Wed Nov 03, 2010 1:19 pm 
Getting Side Ways
Offline
User avatar

Age: 25

Posts: 4599

Joined: 30th Aug 2010

Ride: BF XR6,

Location: NEWCASTLE
NSW, Australia

the car just stopped in the traffic , and i wound it over and over until the battery was almost flat rolled it off the highway then notcied i couldnt hear the pump priming, knowing dirty fuel stuffs them up i just replaced it but then it still wont prime at all and there seems to be no power getting up the wiring to the pump as i checked thst next, im guessing its one of them relays?

 

_________________

BF XR6
xr8 snorkel,typhoon lower snorkel,territory intake pipe,20% underdrive kit,pacemaker extractors,high flow cat,xforce exhaust,t56 conversion hd turbo clutch/ flywheel,m86 3.45 lsd,custom tune187.1rwkw as an auto

Top
 Profile  
 
 
 Post subject: Re: fuel pump just been replaced and no power supply to it
Posted: Thu Nov 04, 2010 10:37 am 
Stock as a Rock
Offline

Age: 33

Posts: 100

Joined: 7th Feb 2009

Ride: EL Fairmont Ghia

Location: Gold Coast
QLD, Australia

Have you tried using a jumper wire on the fuel pump relay electric connector? You will need two people for this test one to listen at fuel pump and one to connect jumper wire. A multi metre is a perfect tool for this job, check for voltage at ecu and fuel pump relay connectors. If you know much about electronics test relay if you don't take relay to auto electrician they shouldn't charge you just to test it
Top
 Profile  
 
 
 Post subject: Re: fuel pump just been replaced and no power supply to it
Posted: Thu Nov 04, 2010 1:25 pm 
Getting Side Ways
Offline
User avatar

Age: 25

Posts: 4599

Joined: 30th Aug 2010

Ride: BF XR6,

Location: NEWCASTLE
NSW, Australia

already fixed it just wired it straight through until i got the car home then bought a new relay this morning

 

_________________

BF XR6
xr8 snorkel,typhoon lower snorkel,territory intake pipe,20% underdrive kit,pacemaker extractors,high flow cat,xforce exhaust,t56 conversion hd turbo clutch/ flywheel,m86 3.45 lsd,custom tune187.1rwkw as an auto

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 9 posts ] 

Who is online

Users browsing this forum: No registered users and 24 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 19, 2017 12:37 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names