Fordmods Logo

Fuel pump maybe? 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: Fuel pump maybe?
Posted: Mon Nov 15, 2010 12:14 pm 
Parts Gopher
Offline
User avatar

Age: 26

Posts: 61

Joined: 8th May 2010

Gallery: 1 images

Ride: Ford Falcon EB II

Location: Townsville
QLD, Australia

Hey guys,

I'm fairly this only started when I switched to BBM from log manifold. Basically it won't start the first crank, I can sit there for 5-6 seconds cranking but nothing, if I let go and try again, fires straight up. BUT if I turn the keys to accessories, then back then accessories again, I usually do this 2-3 times and it fires straight up.

I was thinking maybe the fuel pump? or maybe fuel regulator? I have recently changed fuel filter.

Any ideas?

 

_________________

~EB II~AU series III engine~4499s~high flow cat~2.5 inch exhaust~BBM~Shift kit stage 2~J3 chip~K&N pod~
Next mod: 3.9 LSD

Top
 Profile  
 
 
 Post subject: Re: Fuel pump maybe?
Posted: Mon Nov 15, 2010 12:42 pm 
Getting Side Ways
Offline
User avatar

Age: 54

Posts: 844

Joined: 12th Aug 2007

Gallery: 22 images

Ride: AU2 XR8 ute & 91 EA bitsa

Location: Melbourne
VIC, Australia

Have you got the fuel lines around the right way? I had the same problem. Would fire up with some carby cleaner and then stop immediatley.

 

_________________

AU2 XR8 with Raptor VL, ported Yella Terra GT40P heads, Scorpion 1.6 RRs, XE264HR-14 Comp Cam, ceramic coated Hurricane Headers, 60lb injectors, Walbro 255, 200cfi cats, 3" exhaust & Snow Performance water methanol injection

Top
 Profile  
 
 
 Post subject: Re: Fuel pump maybe?
Posted: Mon Nov 15, 2010 1:09 pm 
Parts Gopher
Offline
User avatar

Age: 26

Posts: 61

Joined: 8th May 2010

Gallery: 1 images

Ride: Ford Falcon EB II

Location: Townsville
QLD, Australia

Well once it starts, it runs like a champ, so I guess the lines are around the right way. It's just starting it lol

 

_________________

~EB II~AU series III engine~4499s~high flow cat~2.5 inch exhaust~BBM~Shift kit stage 2~J3 chip~K&N pod~
Next mod: 3.9 LSD

Top
 Profile  
 
 
 Post subject: Re: Fuel pump maybe?
Posted: Mon Nov 15, 2010 1:25 pm 
Getting Side Ways
Offline
User avatar

Age: 25

Posts: 4599

Joined: 30th Aug 2010

Ride: BF XR6,

Location: NEWCASTLE
NSW, Australia

my car has always done this even wen i put a new fuel pump in it but i blew the fuel pump relay and put a new pump in again when i replaced the relay and i havent had the problem since

 

_________________

BF XR6
xr8 snorkel,typhoon lower snorkel,territory intake pipe,20% underdrive kit,pacemaker extractors,high flow cat,xforce exhaust,t56 conversion hd turbo clutch/ flywheel,m86 3.45 lsd,custom tune187.1rwkw as an auto

Top
 Profile  
 
 
 Post subject: Re: Fuel pump maybe?
Posted: Mon Nov 15, 2010 1:28 pm 
Parts Gopher
Offline
User avatar

Age: 26

Posts: 61

Joined: 8th May 2010

Gallery: 1 images

Ride: Ford Falcon EB II

Location: Townsville
QLD, Australia

I'll check that out! Hopefully a cheap fix.

 

_________________

~EB II~AU series III engine~4499s~high flow cat~2.5 inch exhaust~BBM~Shift kit stage 2~J3 chip~K&N pod~
Next mod: 3.9 LSD

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 33 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 5:00 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names