Fordmods Logo

Head work and noisy torque converter (dying) 

 

Page 2 of 2 [ 23 posts ] Go to page Previous  1, 2

 
Posted: Fri Nov 04, 2005 2:27 pm 
Getting Side Ways
Offline
User avatar

Age: 36

Posts: 8655

Joined: 5th Nov 2004

Gallery: 37 images

Ride: V8 EF Futura

Location: Adelaide CBD
SA, Australia

opto wrote:
Seems to be the best cure for any car problem


Small pieces of plastic, approximately 3.4 x 2.1inch can also work wonders on these problems.

Broken vane is quite nasty. What's the plan for replacement? Stock? Stock stall but stronger??

 

_________________

I promise..... I will never die.

Fordmods Administration Group MINOR PUNKED

Top
 Profile  
 
 
Posted: Fri Nov 04, 2005 6:20 pm 
Fordmods Addict
Offline
User avatar

Age: 31

Posts: 7958

Joined: 1st Jun 2005

Gallery: 13 images

Ride: Falcon

Power: 237 rwkw

Location: Melbourne
VIC, Australia

4.9EF Futura wrote:
Small pieces of plastic, approximately 3.4 x 2.1inch can also work wonders on these problems.

But embaressing when said pieces of plastic fail to provide the wording 'Approved' on an electronic devices screen...

 

_________________

ED XR8 Sprint - S-Trim, V500, 249rwkw
BF MKII F6 Tornado - 237rwkw

Top
 Profile  
 
 
Posted: Fri Nov 04, 2005 10:24 pm 
Getting Side Ways
Offline
User avatar

Age: 54

Posts: 744

Joined: 11th Nov 2004

Gallery: 15 images

Ride: ED Falcon

Location: Adelaide
SA, Australia

I may go 200 to 300 rpm higher in the stall to lift the revs but its a question on what will hapen to the streetability/ fuel consumption

 

_________________

I post here cos the russian tank driver doesn't

Top
 Profile  
 
 
Posted: Tue Nov 08, 2005 7:49 pm 
Getting Side Ways
Offline
User avatar

Age: 54

Posts: 744

Joined: 11th Nov 2004

Gallery: 15 images

Ride: ED Falcon

Location: Adelaide
SA, Australia

The automatic tech found the driveplate touching the bell housing or coverplate, he disconnected the driveplate and refitted it in a new position ( rotated it relative to the original position ) and problem solved but 4 hrs to locate the solution.

 

_________________

I post here cos the russian tank driver doesn't

Top
 Profile  
 
 
Posted: Tue Nov 08, 2005 8:13 pm 
Getting Side Ways
Offline
User avatar

Age: 79

Posts: 1233

Joined: 7th Apr 2005

Gallery: 7 images

Ride: GTHO PH 1 EF ex chaser

Location: Willow vale, GOLD COAST
QLD, Australia

opto wrote:
The automatic tech found the driveplate touching the bell housing or coverplate, he disconnected the driveplate and refitted it in a new position ( rotated it relative to the original position ) and problem solved but 4 hrs to locate the solution.

Converter bolts also come loose and sound like big end knock I had to tighten mine recently and added a drop of locktite to the thread as I don't want that happening again. :roll: :twisted:

 

_________________

Rotten Old Revhead!!! XW GTHO + EF ex cop car (exractors 2.5 cat back zorst !6" Simmons K&N +airbox mods Lowered with Bilstein shocks+Whiteline Bars NEXT THING Swap HO for GTP or Ferrari!

Top
 Profile  
 
 
Posted: Tue Nov 08, 2005 10:01 pm 
Getting Side Ways
Offline
User avatar

Age: 43

Posts: 906

Joined: 9th Aug 2005

Gallery: 4 images

Ride: EB2

Location: s.e suburbs
VIC, Australia

thats the noise sounds like the bigend bearing but all mine replaced and took off the flywhell and back on but still that bloody noise
Top
 Profile  
 
 
Posted: Wed Nov 09, 2005 8:05 pm 
Getting Side Ways
Offline
User avatar

Age: 54

Posts: 744

Joined: 11th Nov 2004

Gallery: 15 images

Ride: ED Falcon

Location: Adelaide
SA, Australia

Okay , even the automatic tech got it wrong, seems as if the "bendix " spring in the starter motor is broken, I presume he means thestarter motor cog that engages with the flywheel/driveplate return spring. he has replaced the whole starter motor with a new one f*ckn $250.00, anyhow should be good for 15 years, longer than I will own this beast.

Got an unexpected compliment (or suckup) , he said its the fastest accelerating ED Ford he has driven. Like it but taken with a pinch of salt.

 

_________________

I post here cos the russian tank driver doesn't

Top
 Profile  
 
 
Posted: Wed Nov 09, 2005 8:19 pm 
Fordmods Addict
Offline
User avatar

Age: 31

Posts: 7958

Joined: 1st Jun 2005

Gallery: 13 images

Ride: Falcon

Power: 237 rwkw

Location: Melbourne
VIC, Australia

Ha ha...
He hasn't driven a Sprint then.. ;) j/k :lol:

My starter motor had a similar problem recently, but wasn't doing it when parked or running, just sounded like all hell breaking loose when starting because it was struggling to pull the cog off the driveplate quick enough.
I just put a reco in though :D
Mechanic said to me he found chunks of metal in the old starter :shock:

 

_________________

ED XR8 Sprint - S-Trim, V500, 249rwkw
BF MKII F6 Tornado - 237rwkw

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 2 of 2  [ 23 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: No registered users and 22 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 1:14 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names