Fordmods Logo

Fordmods Advertising

Heavy Clutch 


Page 2 of 2 [ 17 posts ] Go to page Previous  1, 2

Posted: Thu Dec 28, 2006 9:44 pm 
Fordmods Newbie
User avatar

Age: 33

Posts: 17

Joined: 22nd Nov 2006

Location: Sydney
NSW, Australia

well a grand Later i don't know what i was whing about. Firewalls fixed and new clutch plates and it's like brand new. Even through my slowly mending ankle <----see left----- i can fell a vast improvement. Thanks for the help ever one.
Posted: Fri Jan 05, 2007 7:58 pm 
Smokin em up
User avatar

Age: 30

Posts: 264

Joined: 5th Jan 2007

Ride: E-Hybrid Falcon

Location: nowra, nsw
NSW, Australia

Generally with the early e series it's the cluth cable retainer pulling itself through the firewall. After nearly burning my falcon to the ground i re-enforced my firewall with weld. when plating pay attention to the position of the tensioner nut because when i plated mine the nut was a poof-teenth out n my clutch was a prick to operate. re-inforcing the firewall after repair will stop this happening again, very common weak spot in factory 5 speed falcons.



crow cam,cai,exaust,bbm,190 reg & el injectors,xr6 interior,guages,white cluster,pioneer/mtx stereo,big boot install w.i.p, 17"rims,koni/pedders shocks&springs with nolathane re-bush,ssv kit,stainless inserts,clear lights,t5 & short shifter,chardonay/pearl paint

Display posts from previous:
Sort by  
 Page 2 of 2  [ 17 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: Yahoo [Bot] and 10 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Fri Oct 28, 2016 7:48 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names