Fordmods Logo

Help! Ba LPG 2003 losing coolant? Runs rough. Burn smell. 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: Help! Ba LPG 2003 losing coolant? Runs rough. Burn smell.
Posted: Mon Jan 31, 2011 12:55 am 
Fordmods Newbie
Offline

Age: 53

Posts: 1

Joined: 31st Jan 2011

Ride: Ford Ba

Location: Mandurah
WA, Australia

Ford Ba LGP 2003. For at least a couple of years every now & then starting would run rough. Lately its been more often. Near ran out of coolant a couple of weeks back & its been in the shop, pressure tested & the other test they do to see if any exhaust gases in the coolant. Negative. When it starts rough it burns a very acrid smell out of the exhaust & I think the motor is too hot for just a short run to the shops really. It burns coolant only while running rough? It never missed any services & they were carried out by Ford. Everyone says head gasket but why didnt the two tests show that? I dont want to be ripped off for the whole headgasket thing if there is a chance it could be something else the average 'Joe' doesnt know about. Appreciate your help soon, dont want it blowing up on me. Female owner...
Top
 Profile  
 
 
 Post subject: Re: Help! Ba LPG 2003 losing coolant? Runs rough. Burn smell.
Posted: Mon Jan 31, 2011 1:30 am 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 1322

Joined: 21st Dec 2004

Gallery: 40 images

Ride: EF GLi/Ghia bitsa

Location: Melbourne
VIC, Australia

it does sound rather like a blown headgasket, do a compression test.

Gab
Top
 Profile  
 
 
 Post subject: Re: Help! Ba LPG 2003 losing coolant? Runs rough. Burn smell.
Posted: Mon Jan 31, 2011 8:10 am 
Stock as a Rock
Offline

Age: 48

Posts: 129

Joined: 28th Jun 2007

Ride: BF Egas Tonner

Location: Sydney
NSW, Australia

When was the gas converter last serviced??
The rough idle could be a blocked solenoid in the coverter.
Top
 Profile  
 
 
 Post subject: Re: Help! Ba LPG 2003 losing coolant? Runs rough. Burn smell.
Posted: Mon Jan 31, 2011 9:18 am 
Getting Side Ways
Offline
User avatar

Age: 54

Posts: 4102

Joined: 18th Nov 2004

Gallery: 10 images

Ride: PX2 Ranger 4x4 XLT Dual CAB

Location: Carrum Downs
VIC, Australia

I'm thinking the coolant is leaking internally in the converter and your rough running is you engine is breathing in a mix of coolant, air and LPG

If it was a head gasket you would be losing coolant all the time, not only when its running rough

 

_________________

Image
She's meanness put to music and the b**ch is born to run!
Like the sign says, "speed's just a question of money. How fast can you go?"

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: Google Adsense [Bot] and 29 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 7:58 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names