Fordmods Logo

HELP!! EB engine problem 

 

Page 3 of 3 [ 42 posts ] Go to page Previous  1, 2, 3

 
 Post subject: Re: HELP!! EB engine problem
Posted: Sat Jun 01, 2013 6:44 pm 
Fordmods Junkie
Offline
User avatar

Posts: 2750

Joined: 22nd Jan 2009

Ride: '91 EB Wagoon

Location: Geeelong
VIC, Australia

mayb check actual timing against what ya dizzie is showing you??
Top
 Profile  
 
 
 Post subject: Re: HELP!! EB engine problem
Posted: Sat Jun 01, 2013 7:20 pm 
Tyre Shredder
Offline
User avatar

Age: 39

Posts: 385

Joined: 10th Nov 2004

Ride: EL Fairmont Ghia

Location: thirlmere
NSW, Australia

No, not sure but i havent touched the timing for a long time.
Top
 Profile  
 
 
 Post subject: Re: HELP!! EB engine problem
Posted: Sat Jun 01, 2013 10:18 pm 
Tyre Shredder
Offline
User avatar

Age: 39

Posts: 385

Joined: 10th Nov 2004

Ride: EL Fairmont Ghia

Location: thirlmere
NSW, Australia

I think something posted my reply twice very weird, ok i will have a look at the timing but still all sounds strange.

thanks.
Top
 Profile  
 
 
 Post subject: Re: HELP!! EB engine problem
Posted: Sun Jun 02, 2013 5:47 pm 
Tyre Shredder
Offline
User avatar

Age: 39

Posts: 385

Joined: 10th Nov 2004

Ride: EL Fairmont Ghia

Location: thirlmere
NSW, Australia

Just a thought, when i try and start it now it wont start, it tries too but i either get a backfire through the intake or the exhaust. Could it be possible that its the distributor? it is only 2 years old but it is one of the aftermarket ones. Would that also cause the smoke before it has died?
Top
 Profile  
 
 
 Post subject: Re: HELP!! EB engine problem
Posted: Sun Jun 02, 2013 6:15 pm 
Fordmods Junkie
Offline
User avatar

Posts: 2750

Joined: 22nd Jan 2009

Ride: '91 EB Wagoon

Location: Geeelong
VIC, Australia

ferr007 wrote:
Just a thought, when i try and start it now it wont start, it tries too but i either get a backfire through the intake or the exhaust. Could it be possible that its the distributor? it is only 2 years old but it is one of the aftermarket ones. Would that also cause the smoke before it has died?



thats why i asked you to check ya timing :roll: check actual against what ya dizzie says - car i had years ago had a cam in it fitted by me :oops: - coz the timing was out it blew shiitloads of smoke .... ummmm blue/white????
Top
 Profile  
 
 
 Post subject: Re: HELP!! EB engine problem
Posted: Mon Jun 03, 2013 3:28 am 
Getting Side Ways
Offline

Posts: 596

Joined: 4th May 2007

Ride: 1992 EBII Fairmont

Location: Aga
VIC, Australia

The only thing that will really make a car backfire on petrol really is the timing, your plugs and o2 sensor should all be caked in carbon (black powder stuff) from the intense overfueling.

If you have an AFTERMARKET dizzy you could be in for a lot more than just the dizzy, I'd stick a timing light on it and see if the marker stays in the same spot when in base timing mode because if not the aux shaft could be stripped. If you don't have a light take the cap off the dizzy and wiggle the shaft and if there's more than 1mm play (there should be none really) it's stripped.. pull it out and pray your aux shaft hasn't also.
Top
 Profile  
 
 
 Post subject: Re: HELP!! EB engine problem
Posted: Mon Jun 03, 2013 3:34 pm 
Smokin em up
Offline
User avatar

Age: 48

Posts: 205

Joined: 8th Dec 2009

Gallery: 1 images

Ride: EB XR8, Now Blown 1977 Mini S

Location: Toowoomba
QLD, Australia

If you have a sooty and black plug, you have a fuelling issue, black and wet, could still be a fuelling issue but wipe the plug and if sticky, oil blowby or leaky valve stem seals, guides. You could try a leak down test to see whether it is rings or guide seals. Probably moot as it will probably only tell you your compression is ok(it will increase your compression a little when you put about 5ml in each bore, one bore at a time, then measure your compression...any variable across all six can be seen and you can tell which one MAY be faulty...). Blue smoke is usually oil but could be your egr playing up and you have to put some Subaru upper engine cleaner through it...works a treat in de-coking your upper manifold and won't harm your cat or injectors.

Hooroo
Top
 Profile  
 
 
 Post subject: Re: HELP!! EB engine problem
Posted: Mon Jun 03, 2013 4:03 pm 
Tyre Shredder
Offline
User avatar

Age: 39

Posts: 385

Joined: 10th Nov 2004

Ride: EL Fairmont Ghia

Location: thirlmere
NSW, Australia

Ok i am going to check the dizzy this afternoon to see if i have any play. CPOCSM i dont think my car has an egr it is a 6 cylinder are they only on the v8s on the e series?
Top
 Profile  
 
 
 Post subject: Re: HELP!! EB engine problem
Posted: Mon Jun 03, 2013 4:49 pm 
Smokin em up
Offline
User avatar

Age: 48

Posts: 205

Joined: 8th Dec 2009

Gallery: 1 images

Ride: EB XR8, Now Blown 1977 Mini S

Location: Toowoomba
QLD, Australia

ferr007 wrote:
CPOCSM i dont think my car has an egr it is a 6 cylinder are they only on the v8s on the e series?


Ahh ok but is there any pcv/manifold return for tappet chest gases plumbed into your car...sorry has been eons since owning a six cylinder ford! Breathing is everything in the sixes and if there is a blockage somewhere, you may be pressurising your crankcase with blowby and oily burn off. Maybe I am too in the mind of mini breathing...the little a series motors need good breathing otherwise you will blow the dipstick clean out of the hole. Good breathing of the scavenger system lessens the chance of blowing seals/gaskets/dipsticks but hope you find your issue out.

Hooroo
Top
 Profile  
 
 
 Post subject: Re: HELP!! EB engine problem
Posted: Mon Jun 03, 2013 5:42 pm 
Tyre Shredder
Offline
User avatar

Age: 39

Posts: 385

Joined: 10th Nov 2004

Ride: EL Fairmont Ghia

Location: thirlmere
NSW, Australia

Ok i took my distributor cap off and there is more than 1mm of play, actually a fair bit more so i took the distributor out to have a look and the gears dont look too bad, there is some wearing but nothing major, could it be the aux drive gear? i tried to have a look but couldnt see too well from what i can feel it felt ok has sharp corners but otherwise it felt fine.
Top
 Profile  
 
 
 Post subject: Re: HELP!! EB engine problem
Posted: Mon Jun 03, 2013 5:50 pm 
Fordmods Junkie
Offline
User avatar

Posts: 2750

Joined: 22nd Jan 2009

Ride: '91 EB Wagoon

Location: Geeelong
VIC, Australia

ferr007 wrote:
i tried to have a look but couldnt see too well from what i can feel it felt ok has sharp corners but otherwise it felt fine.



which 'sharp' do ya mean?? sharp like a knife or sharp like a window glass edge?
Top
 Profile  
 
 
 Post subject: Re: HELP!! EB engine problem
Posted: Mon Jun 03, 2013 11:47 pm 
Tyre Shredder
Offline
User avatar

Age: 39

Posts: 385

Joined: 10th Nov 2004

Ride: EL Fairmont Ghia

Location: thirlmere
NSW, Australia

from what i can feel it is sharp like a window edge.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 3 of 3  [ 42 posts ]  Go to page Previous  1, 2, 3

Who is online

Users browsing this forum: No registered users and 22 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 11:32 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names