Fordmods Logo

HELP - Ed falcon battery terminals.. 

 

Page 2 of 2 [ 24 posts ] Go to page Previous  1, 2

 
 Post subject: Re: HELP - Ed falcon battery terminals..
Posted: Wed Jul 22, 2009 4:22 pm 
Oompa Loompa
Offline

Age: 40

Posts: 26

Joined: 19th Jun 2009

Ride: Ed Falcon

Location: Newcastle
NSW, Australia

Yes a close up pic would definately be good.. i do appreciate u guys tring to help me.. Hopefully ill have my car on the road soon :)
Top
 Profile  
 
 
 Post subject: Re: HELP - Ed falcon battery terminals..
Posted: Wed Jul 22, 2009 4:40 pm 
Smokin em up
Offline
User avatar

Age: 50

Posts: 259

Joined: 21st Aug 2008

Ride: Fairlane Concorde 4.0

Location: wagga
NSW, Australia

From your photos you have the battery and leads connected correctly. I can see the + symbol just behind the red starter lead. I can also see your 4 black wires (2 x 2 black fusible links. 2 go to the alternator. 2 for the ecu, relays and other systems), 1 green fusible link wire and one red fusible link wire all connected to the positive. I assume you did that + terminal bolt up nice and tight? If it's not tight, a poor connection to the starter will result. Does that white wire have a black trace on it?

I just noticed the diagram shows a wht/black wire running from the battery + to the start/charge circuit. My diagram is EA but ED should basically be the same.

 

_________________

NF Fairlane: Non Factory Dual Fuel - New coolant tank, New fuel injectors, New fuel pump, New earth cable, ECU capacitors replaced, New O2 sensor, leads and plugs, New Radiator/Condensor cleaned. 483,000kms. AU I6 Powered. Struts, Shockies, Tie rods and ball joints replaced.

Top
 Profile  
 
 
 Post subject: Re: HELP - Ed falcon battery terminals..
Posted: Wed Jul 22, 2009 5:16 pm 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

i noticed in one of your pics the nut on the positive terminal is not done up??
did you do it up before trying to start it??

here are some closer pics of mine..
i have a few extras on mine the extra thick one is power to the amp and the 2 smaller red ones are my thermo fans but the rest are std...
Attachment:
DSC01474.JPG
DSC01474.JPG [ 265.21 KiB | Viewed 94 times ]

Attachment:
DSC01475.JPG
DSC01475.JPG [ 268.15 KiB | Viewed 84 times ]
Top
 Profile  
 
 
 Post subject: Re: HELP - Ed falcon battery terminals..
Posted: Wed Jul 22, 2009 11:27 pm 
Technical Contributor
Offline
User avatar

Age: 26

Posts: 676

Joined: 7th Jun 2009

Ride: Ford EB II Falcon

Location: Morphett Vale
SA, Australia

Look to make sure the positive/nagative terminal is actually making a connection because if you have a bolt there without a nut it might not conduct, also check your fuse box because one blown fuse can stop a car from starting up, i learnt that the hard way !

Edit: if all you hear is a click its the TERMINALS tighten them and give that a whirl !

 

_________________

OLD CAR: EB II Falcon, Everglade Green, 250thous (Rough Guess), Wildcat Extractors, 2.5 Exhaust with Muffler + Hot Dog, 18 Inch Rodney Jane Mags, XH Snorkel, EA MPEFI Tubing !

NEW CAR: 1996 TE Magna...Mods Soon To Come

Top
 Profile  
 
 
 Post subject: Re: HELP - Ed falcon battery terminals..
Posted: Sat Jul 25, 2009 6:18 pm 
Oompa Loompa
Offline

Age: 40

Posts: 26

Joined: 19th Jun 2009

Ride: Ed Falcon

Location: Newcastle
NSW, Australia

Thanks guys for everything... think its time to scrap the car...

My bro in law came over (his mate has ed).. all leads are on correctly, bolts are tight.. blown fuses were replaced... keeps blowing the 10 amp fuse to the WAC relay.. they tried a 15 amp in there too... apparently its got a power surge comming from somewhere.. he thinks cause my boyfriend connected it up wrong so his thrown his hands up and told me to call an auto electrican..

cant afford,,, just brought the car 2 months ago, drove for 2 weeks, boyfriend poped the hood and didnt close, he then drove it. hood blew off the day i was registering it, finally has replaced the hood, (not painted, not replaced the struts,etc) just paid rego now this... nothing else anyone i know can do for me unfortunately..
Top
 Profile  
 
 
 Post subject: Re: HELP - Ed falcon battery terminals..
Posted: Sat Aug 01, 2009 11:55 pm 
Oompa Loompa
Offline

Age: 40

Posts: 26

Joined: 19th Jun 2009

Ride: Ed Falcon

Location: Newcastle
NSW, Australia

hi.. thanks again for all ur help.. called an auto electrician.. he checked battery... unfortunately cause my boyfriend hooked up both pos and neg to one terminal and tried to crank it he blew the body control module.. boyfried replaced it, at my cost :( and car starts..(thank god)

but no wipers (blows the fuses), no stereo and no a\c.. looks like ill have call auto electrican again.. turning out to be very costly..

but if anyone has any ideas before i take it there next week id appreciate it very much..
Top
 Profile  
 
 
 Post subject: Re: HELP - Ed falcon battery terminals..
Posted: Sun Aug 02, 2009 1:02 am 
Getting Side Ways
Offline
User avatar

Age: 35

Posts: 963

Joined: 14th Jul 2007

Gallery: 3 images

Ride: AU fairmont ghia

Location: Back in
ACT, Australia

only got 1 idea, never let your boyfriend near a car again!!! if constantly blowing fuses mean it is arcing somewhere, ie loose wire touching where is not spose to, better off calling a auto sparky, will save you money in the long run

 

_________________

AU FAIRMONT GHIA: 5.0 Dealer ordered SVO mods ( seeking clarification ATM), tickford suspension.

Top
 Profile  
 
 
 Post subject: Re: HELP - Ed falcon battery terminals..
Posted: Tue Aug 04, 2009 2:07 pm 
Oompa Loompa
Offline

Age: 40

Posts: 26

Joined: 19th Jun 2009

Ride: Ed Falcon

Location: Newcastle
NSW, Australia

EFNA wrote:
only got 1 idea, never let your boyfriend near a car again!!!



I hear u.. never again.. lol


thought id keep u up to date. Went to auto electricians today, apparently someone must have disconnected a wire and reconnected incorrectly because the wipers were connected wrong.. didnt take them long at all to fix it... the stereo was just the fuse behind the unit but the a\c has a short in the clutch.

so at least its going now i just gotta get new wipers as these ones are bent from when the bonnet flew up and hit it.. and unless i can find a cheap ac part ill just old school it and leave the window down.. lol
Top
 Profile  
 
 
 Post subject: Re: HELP - Ed falcon battery terminals..
Posted: Fri Sep 04, 2009 2:24 pm 
Oompa Loompa
Offline

Age: 40

Posts: 26

Joined: 19th Jun 2009

Ride: Ed Falcon

Location: Newcastle
NSW, Australia

uniacidz wrote:
Why on earth would ya BF hook up both neg and pos to one terminal?

As before mentioned, DO NOT LET HIM NEAR YOUR CAR!!!!

I hope he is only dumb for when it comes to cars.


no idea he keeps sayn he didnt even though 2 of us saw it done..

his not alowed to touch it anymore, well we arent together as of last week so theres no chance of that.. hehe

and as for the last part, unfortunately its not just cars.. he pretends his mr know it all but then stuffs everything..

Car is working now few sml things i gota do to get it back the same but i will take my time so i can save to pay someone to fix..
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 2 of 2  [ 24 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: No registered users and 32 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 11, 2017 8:53 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names