Fordmods Logo

Help - EL idles at 3000rpm on petrol 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: Help - EL idles at 3000rpm on petrol
Posted: Sat Oct 08, 2011 10:22 pm 
Fordmods Newbie
Offline

Posts: 2

Joined: 8th Oct 2011

Location: Canberra
ACT, Australia

My EL is running ok on LPG, but on petrol it idles up to 3000rpm.

I gave the idle speed controller a decent clean as per this page http://www.fordmods.com/documents.php?d=23. It's still black inside, but it had a good wash with both turps and WD-40. Reassembled it all and nothing has changed. Still idling like a Saturn rocket.

I found that by disconnecting the MAP sensor the idle revs would drop a bit, but still too high. When I disconnected the ISC wire at the same time as the MAP sensor is disconnected the revs drop a bit more, and its nearly tolerable, but still too high (~1200rpm). I'd consider running it with both disconnected, but it conks out on LPG with teh MAP sensor disconnected.

I've turned the idle screw to the extent that it's lost contact with the lever, so it can't be that...

Any tips would be hugely appreciated. I'm flat broke so trying to avoid a trip to the mechanic.

Cheers,
Scott.
Top
 Profile  
 
 
 Post subject: Re: Help - EL idles at 3000rpm on petrol
Posted: Sun Oct 09, 2011 12:32 am 
Tyre Shredder
Offline
User avatar

Posts: 326

Joined: 12th Jun 2010

Ride: EL Fairmont

Location: Central Highlands
QLD, Australia

I would be looking at a vacuum leak at the inlet manifold gasket, hoses of the inlet manifold etc...

 

_________________

Current ride 2007
ML GLX Dualcab Triton 4x4

Top
 Profile  
 
 
 Post subject: Re: Help - EL idles at 3000rpm on petrol
Posted: Sun Oct 09, 2011 7:33 am 
Technical Contributor
Offline

Age: 60

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

+1 for Vac leak
Top
 Profile  
 
 
 Post subject: Re: Help - EL idles at 3000rpm on petrol
Posted: Sun Oct 09, 2011 10:55 am 
Fordmods Newbie
Offline

Posts: 2

Joined: 8th Oct 2011

Location: Canberra
ACT, Australia

SWC wrote:
+1 for Vac leak


This is what I keep coming back to, but I've checked and doubechecked all the hoses and everything seems connected, no splits in hoses etc.

I noticed that down at the front some of the air filter box clips are missing and there's not a tight seal on the air filter box, but I don't think this would be the cause, would it? It doesn't seem to improve when I manually force a tight seal on the air filter box.
Top
 Profile  
 
 
 Post subject: Re: Help - EL idles at 3000rpm on petrol
Posted: Sun Oct 09, 2011 2:43 pm 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

check for a busted pcv valve, sometimes the plasic pcv's fail causing a higher idle and symptoms of a vac leak...
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 1:59 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names